Results 1 to 8 of 8

Thread: KDE Clock shows incorrect time since daylight change

  1. #1

    Default KDE Clock shows incorrect time since daylight change

    Laptop on UTC, no dual boot, ntp working, "date" command shows correct time. This is not a case of https://forums.opensuse.org/showthre...incorrect-time

    Observation:
    KDE widget "Analogue Clock": +2h
    KDE widget "Digital Clock": -2h
    KDE widget "Fuzzy Clock": +2h

    Total range 4h

    https://bugzilla.opensuse.org/show_bug.cgi?id=1114570 (no activity since report + confirmation)

    Anybody having this problem outside the timezone Europe/Dublin?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,781

    Default Re: KDE Clock shows incorrect time since daylight change

    Quote Originally Posted by jowagner View Post
    "date" command shows correct time.
    Please never tell only your conclusions. Always first and foremost SHOW what the computer says (copy/past, including the line with the prompt and the command, all the output up to and including the next prompt between CODE tags in the post, you get CODE tags by clicking on the # button in the tool bar of the post editor).

    E.g, when I want to inform people here what date shows:
    Code:
    henk@boven:~> datewo nov 28 10:53:06 CET 2018
    henk@boven:~>
    For your question: I have Europe/Amsterdam and no deviations.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    18,748
    Blog Entries
    14

    Default Re: KDE Clock shows incorrect time since daylight change

    There was some report ( looked for it, but can no longer find it ) where the culprit appeared to be that both ntpd and systemd-timesyncd were active, Please check, and if so, disable the ntpd service.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: KDE Clock shows incorrect time since daylight change

    Thanks for the replies and good news Fabian is working on back-porting some QT code that probably fixes the issue, see bug report.

    Quote Originally Posted by Knurpht View Post
    There was some report ( looked for it, but can no longer find it ) where the culprit appeared to be that both ntpd and systemd-timesyncd were active, Please check, and if so, disable the ntpd service.
    Code:
    hidden:~ # systemctl --all --full list-units | fgrep chrony
      chronyd.service                                                                                                loaded    active     running   NTP client/server                                                                           
    hidden:~ # systemctl --all --full list-units | fgrep ntp
    ● ntpd.service                                                                                                   not-found inactive   dead      ntpd.service                                                                                
    ● ntpdate.service                                                                                                not-found inactive   dead      ntpdate.service                                                                             
    ● sntp.service                                                                                                   not-found inactive   dead      sntp.service                                                                                
    hidden:~ # systemctl --all --full list-units | fgrep timesync
      systemd-timesyncd.service                                                                                      loaded    inactive   dead      Network Time Synchronization                                                                
    hidden:~ #
    Quote Originally Posted by hcvv
    Always first and foremost SHOW what the computer says
    Code:
    hidden:~ # date
    Thu Nov 29 07:49:10 GMT 2018
    hidden:~ #
    This is a standard Leap 15.0 install + rsyslog + patterns console tools, kvm host server and some dev patterns. Time settings have only been made via the installer. The laptop was powered off (not sleeping or hibernating) in the night of the daylight time change.
    Last edited by jowagner; 29-Nov-2018 at 01:01. Reason: typo (extra letter)

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    10,819
    Blog Entries
    3

    Default Re: KDE Clock shows incorrect time since daylight change

    Quote Originally Posted by jowagner View Post
    The laptop was powered off (not sleeping or hibernating) in the night of the daylight time change.
    If your computer is really configured for UTC, then that should not matter.

    What's the output from:
    Code:
    ls -l /etc/localtime
    and from
    Code:
    cat /etc/adjtime
    opensuse Leap 15.0; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  6. #6

    Default Re: KDE Clock shows incorrect time since daylight change

    Code:
    hidden:~ # ls -l /etc/localtime
    lrwxrwxrwx 1 root root 33 Aug 17 17:21 /etc/localtime -> /usr/share/zoneinfo/Europe/Dublin
    hidden:~ # cat /etc/adjtime
    0.0 0 0.0
    0
    UTC
    hidden:~ #
    Before spending more time on investigating this further, it will be sensible to wait for the qt fix that should become available shortly and probably solves the issue, see https://bugzilla.opensuse.org/show_bug.cgi?id=1114570
    Last edited by jowagner; 01-Dec-2018 at 09:13. Reason: hide laptop name from search engines

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    10,819
    Blog Entries
    3

    Default Re: KDE Clock shows incorrect time since daylight change

    Quote Originally Posted by jowagner View Post
    Code:
    hidden:~ # ls -l /etc/localtime
    lrwxrwxrwx 1 root root 33 Aug 17 17:21 /etc/localtime -> /usr/share/zoneinfo/Europe/Dublin
    hidden:~ # cat /etc/adjtime
    0.0 0 0.0
    0
    UTC
    hidden:~ #
    That all looks fine.

    Before spending more time on investigating this further, it will be sensible to wait for the qt fix that should become available shortly and probably solves the issue, see https://bugzilla.opensuse.org/show_bug.cgi?id=1114570
    That only affects a graphic widget. If that bug is your problem, then the command
    Code:
    date
    at a command line should show the correct time.
    opensuse Leap 15.0; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,781

    Default Re: KDE Clock shows incorrect time since daylight change

    Quote Originally Posted by nrickert View Post
    That all looks fine.



    That only affects a graphic widget. If that bug is your problem, then the command
    Code:
    date
    at a command line should show the correct time.
    That is what he reported in his first post above (without showing anything) and repeated (by showing the command) in a later post. He only complains about his personal KDE sessions showing times that differ from this system timezone. As I see it, he complains that KDE differs from the system default (well, that is of course possible, every user may set his "personal" time zone, that differs from the system's time zone) without him setting this in KDE. And that is also not consistent.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •