Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: opensuse Leap 15 KDE sometimes stuck on boot

  1. #1

    Exclamation opensuse Leap 15 KDE sometimes stuck on boot

    Hi,
    My setting of opensuse 15 is to boot automatically in KDE mode (plasma 5). I noticed that the screen freezes (sometimes) during the usage of opensuse 15 in KDE mode. Furthermore, during the boot time, sometimes, the boot sequence seems to get stuck on KDE splash screen logo the black one (after gnome leap logo the green one). I can move the mouse icon on that screen, therefore the screen is not frozen, but the boot seems to be stuck. I am switching back to boot in gnome mode to find out if I am getting the same symptoms. Any suggestions?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    23,786

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    I see you have no answers until now. That maybe for several reasons.

    You should see the difference between boot and login. A system does not boot into KDE and/or Gnome, it just boots. After this there may come a user that logs in. You may have made that login automaticaly for a certain user, but it is still a log in. That user then may use KDE. So I guess your problem is with a user that logs in into KDE.

    This means that you could do some further testing by loging out after a succesfull log in and then try a login again. Does it stuck then? At random or not? You may also want to switch off the automatic log in to have a more clear view of what happens when (on boot or on log in).

    Because you reposrt screen locks, it may be of interest what graphics card you have and which deiver you use for it.

    All this to give potential helpers more information.
    Henk van Velden

  3. #3

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    @hcvv,
    I switched back from gnome to KDE and disabled the automatic login. Therefore it is manual now. I will have to run openSUSE leap 15 like this for at least five days to determine if that makes a difference as you suggested.
    Regarding graphics, I used lshw -c video command to get the following output:
    Code:
      description: VGA compatible controller
           product: 82Q963/Q965 Integrated Graphics Controller
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 02
           width: 64 bits
           clock: 33MHz
           capabilities: msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:16 memory:f0400000-f04fffff memory:e0000000-efffffff ioport:1200(size=8) memory:c0000-dffff
    It is build in graphics card. I do not know how to determine what driver I am using for this.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    18,751
    Blog Entries
    14

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    Quote Originally Posted by openlost View Post
    @hcvv,
    I switched back from gnome to KDE and disabled the automatic login. Therefore it is manual now. I will have to run openSUSE leap 15 like this for at least five days to determine if that makes a difference as you suggested.
    Regarding graphics, I used lshw -c video command to get the following output:
    Code:
      description: VGA compatible controller
           product: 82Q963/Q965 Integrated Graphics Controller
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 02
           width: 64 bits
           clock: 33MHz
           capabilities: msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:16 memory:f0400000-f04fffff memory:e0000000-efffffff ioport:1200(size=8) memory:c0000-dffff
    It is build in graphics card. I do not know how to determine what driver I am using for this.

    That should not be an issue. Create a new user, login as that user and see if that new user experiences the same issues.
    Did you add any repos?
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    811

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    Quote Originally Posted by openlost View Post
    I do not know how to determine what driver I am using for this.
    Code:
    $ grep RETT /etc/os-release
    PRETTY_NAME="openSUSE Leap 15.0"
    $ sudo zypper in inxi
    ...
    (1/1) Installing: inxi-2.3.40-lp150.1.3.noarch .............................................[done]
    $ inxi -Gxx
    Graphics:  Card: Intel 82Q963/Q965 Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:2992
               Display Server: X.Org 1.19.6 drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1680x1050@59.97hz
               OpenGL: renderer: Mesa DRI Intel 965Q version: 2.1 Mesa 18.0.2 Direct Render: Yes
    $
    If you find yours reports "drivers: intel" rather than modesetting, you can try modesetting by removing the package xf86-video-intel with zypper or yast and restarting X. If it reports neither, but instead fbdev or vesa, then you may need to remove nomodeset from your grub stanza(s).
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

  6. #6

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    new observation:
    1) In KDE mode, while browsing using Firefox, the screen froze again but mouse icon was active.
    2) This is new and possible a bug. I used yast, user security option, to disable the automatic login. Later I used to terminal command and mentioned before to switch from KDE to GNOME. Terminal command shows that changes are made but after turning off and on, the effect is not there. I am still at login screen, and it is still set to plasma.

    I decided to go back to GNOME to operate PC in GNOME mode to see if I have login stuck and desktop freeze effect as well. I will keep testing in that mode for five days. Through that time I will make no attempt to troubleshoot KDE. I will keep you posted.

    Note: my Graphics driver is Intel.

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    811

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    Quote Originally Posted by openlost View Post
    Note: my Graphics driver is Intel.
    https://cgit.freedesktop.org/xorg/dr...6-video-intel/ shows the last official release of the intel driver was 4 years ago. It may be worth trying the modesetting alternative if you seem to have video-related issues. Modesetting is the only driver I use for Intel gfx devices it supports.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

  8. #8

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    @mcmazda, how do you setup modesetting alternatives driver?

  9. #9
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    811

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    Quote Originally Posted by openlost View Post
    @mcmazda, how do you setup modesetting alternatives driver?
    As directed in #5 is one way.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

  10. #10

    Default Re: opensuse Leap 15 KDE sometimes stuck on boot

    After 5 days of using opensuse leap 15 in gnome mode, I had no issues. Except that file manager had background black shaded and dark letter which makes files reading impossible. I have no way of changing that. But I had no login stuck in automatic mode, and no desktop screen freezing (except mouse icon). Therefore I conclude that issues are related to KDE mode setting. For login stuck issue, the solution seems to be by login manually. For desktop screen freezing, the driver should not be the issue because I believe that gnome and kde modes use the same graphics card driver. Therefore, there must be some thing else causing it.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •