Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Boot Times are too High

  1. #1

    Default Boot Times are too High

    Hey everyone,

    I had installed OpenSUSE TW on a Lenovo Laptop with Intel i5 and 12 GB of RAM.
    No additional software has been installed.
    All possible updates have been installed.

    The boot time is just too high. I had clocked it from the power on to desktop. It had taken nearly 3 minutes to reach the desktop.
    Surprisingly the VM Image I had taken tried on before installing on actual hardware had taken hardly 1 minute to boot.
    Not sure what is causing the slowness. Can you please help in identifying and resolving this issue ?

    Thanks in Advance,
    RD (y)

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    18,759
    Blog Entries
    14

    Default Re: Boot Times are too High

    Please show ouput of

    Code:
    systemd-analyze blame
    between CODE tags ( the # in the editor )
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Boot Times are too High

    Quote Originally Posted by Knurpht View Post
    Please show ouput of

    Code:
    systemd-analyze blame
    between CODE tags ( the # in the editor )
    My apologies, I saw the post a bit late.
    I had reinstalled OS TW again, but had removed a bunch of pattern during the installation screen itself. The boot times are a little better..Around a minute mark.
    Anyways posting the output here in case, it can be further optimized.

    Code:
    :~> systemd-analyze blame
              5.675s firewalld.service
              5.237s dev-sda8.device
              4.370s ModemManager.service
              4.362s btrfsmaintenance-refresh.service
              4.314s initrd-switch-root.service
              4.229s display-manager.service
              3.839s nscd.service
              3.465s postfix.service
              3.426s chronyd.service
              3.043s avahi-daemon.service
              3.021s kbdsettings.service
              3.021s bluetooth.service
              2.822s plymouth-quit-wait.service
              2.724s apparmor.service
              2.141s boot-efi.mount
              1.743s plymouth-start.service
              1.581s home.mount
              1.081s systemd-logind.service
               925ms polkit.service
               821ms dev-disk-by\x2duuid-0da24141\x2d1725\x2d4ba9\x2d99a6\x2de5285dc0d5f9.swap
               814ms systemd-udevd.service
               593ms upower.service
               581ms NetworkManager.service
               541ms var.mount
               536ms systemd-rfkill.service
               534ms root.mount
               525ms srv.mount
               519ms udisks2.service
               508ms tmp.mount
               489ms boot-grub2-i386\x2dpc.mount
               484ms boot-grub2-x86_64\x2defi.mount
               436ms systemd-remount-fs.service
               427ms dev-mqueue.mount
               423ms dev-hugepages.mount
               409ms sys-kernel-debug.mount
               396ms rtkit-daemon.service
    389ms opt.mount
               383ms systemd-udev-trigger.service
               356ms systemd-journal-flush.service
               329ms usr-local.mount
               286ms systemd-tmpfiles-setup-dev.service
               235ms auditd.service
               217ms sysroot.mount
               200ms systemd-modules-load.service
               194ms systemd-random-seed.service
               176ms user@1000.service
               169ms systemd-journald.service
               158ms iscsi.service
               153ms systemd-backlight@backlight:intel_backlight.service
               144ms wpa_supplicant.service
               143ms initrd-parse-etc.service
               137ms plymouth-read-write.service
               134ms mcelog.service
               114ms kmod-static-nodes.service
                98ms systemd-vconsole-setup.service
                94ms systemd-fsck-root.service
                88ms systemd-user-sessions.service
                73ms systemd-sysctl.service
                62ms systemd-tmpfiles-setup.service
                49ms dracut-cmdline.service
                40ms systemd-update-utmp.service
                26ms initrd-cleanup.service
                19ms plymouth-switch-root.service
                17ms dracut-pre-trigger.service
                16ms dracut-shutdown.service
                13ms \x2esnapshots.mount
                11ms user-runtime-dir@1000.service
                10ms systemd-update-utmp-runlevel.service
                 7ms initrd-udevadm-cleanup-db.service
                 6ms sys-fs-fuse-connections.mount
    Thanks for all the help.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    10,838
    Blog Entries
    3

    Default Re: Boot Times are too High

    Can you now provide the output from:
    Code:
    grep swap /etc/fstab
    There have been some cases where the installer has messed up the swap configuration, so that's one possible place to look.
    opensuse Leap 15.0; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    528

    Default Re: Boot Times are too High

    Quote Originally Posted by rainingdistros View Post
    Hey everyone,

    I had installed OpenSUSE TW on a Lenovo Laptop with Intel i5 and 12 GB of RAM.
    No additional software has been installed.
    All possible updates have been installed.

    The boot time is just too high. I had clocked it from the power on to desktop. It had taken nearly 3 minutes to reach the desktop.
    Surprisingly the VM Image I had taken tried on before installing on actual hardware had taken hardly 1 minute to boot.
    Not sure what is causing the slowness. Can you please help in identifying and resolving this issue ?

    Thanks in Advance,
    RD (y)
    i5 cpus are not created equal:

    Code:
    notebook:~ # systemd-analyze 
    Startup finished in 6.352s (firmware) + 4.393s (loader) + 4.231s (kernel) + 2.317s (initrd) + 3.741s (userspace) = 21.037s
    graphical.target reached after 3.571s in userspace
    notebook:~ # systemd-analyze critical-chain 
    The time after the unit is active or started is printed after the "@" character.
    The time the unit takes to start is printed after the "+" character.
    
    graphical.target @3.571s
    └─multi-user.target @3.571s
      └─cron.service @3.570s
        └─postfix.service @1.880s +1.685s
          └─network.target @1.875s
            └─wpa_supplicant.service @2.567s +45ms
              └─dbus.service @923ms
                └─basic.target @919ms
                  └─sockets.target @918ms
                    └─dbus.socket @918ms
                      └─sysinit.target @915ms
                        └─apparmor.service @302ms +612ms
                          └─systemd-journald.socket
                            └─system.slice
                              └─-.slice
    notebook:~ #
    My notebook is:

    Code:
    notebook:~ # inxi -zF
    System:    Host: notebook.fritz.box Kernel: 4.19.4-1.g2f38375-default x86_64 bits: 64 Console: tty 0 
               Distro: openSUSE Tumbleweed 20181122 
    Machine:   Type: Laptop System: HP product: HP Laptop 15-da0xxx v: Type1ProductConfigId serial: <filter> 
               Mobo: HP model: 84A6 v: 80.24 serial: <filter> UEFI: Insyde v: F.02 date: 05/24/2018 
    Battery:   ID-1: BAT1 charge: 29.6 Wh condition: 40.0/41.9 Wh (95%) 
    CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB 
               Speed: 600 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 601 5: 600 6: 600 7: 600 8: 600 
    Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
               Display: server: X.org 1.20.3 driver: modesetting unloaded: fbdev,vesa resolution: <xdpyinfo missing> 
               OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.1.7 
    Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
               Sound Server: ALSA v: k4.19.4-1.g2f38375-default 
    Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
               IF: eno1 state: down mac: <filter> 
               Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter driver: rtl8821ce 
               IF: wlo1 state: up mac: <filter> 
    Drives:    Local Storage: total: 238.47 GiB used: 166.02 GiB (69.6%) 
               ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG30ZMV256G size: 238.47 GiB 
    RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
    Partition: ID-1: / size: 29.40 GiB used: 6.46 GiB (22.0%) fs: ext4 dev: /dev/nvme0n1p2 
               ID-2: /home size: 200.17 GiB used: 159.55 GiB (79.7%) fs: ext4 dev: /dev/nvme0n1p3 
               ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p4 
    Sensors:   System Temperatures: cpu: 33.0 C mobo: N/A 
               Fan Speeds (RPM): N/A 
    Info:      Processes: 221 Uptime: N/A Memory: 7.70 GiB used: 1.02 GiB (13.2%) Shell: bash inxi: 3.0.27 
    notebook:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  6. #6

    Default Re: Boot Times are too High

    Quote Originally Posted by rainingdistros View Post
    Code:
    :~> systemd-analyze blame
              5.675s firewalld.service
              5.237s dev-sda8.device
              4.370s ModemManager.service
              4.362s btrfsmaintenance-refresh.service
              4.314s initrd-switch-root.service
              4.229s display-manager.service
              3.839s nscd.service
              3.465s postfix.service
              3.426s chronyd.service
              3.043s avahi-daemon.service
              3.021s kbdsettings.service
              3.021s bluetooth.service
              2.822s plymouth-quit-wait.service
              2.724s apparmor.service
              2.141s boot-efi.mount
              1.743s plymouth-start.service
              1.581s home.mount
              1.081s systemd-logind.service
               925ms polkit.service
               821ms dev-disk-by\x2duuid-0da24141\x2d1725\x2d4ba9\x2d99a6\x2de5285dc0d5f9.swap
               814ms systemd-udevd.service
               593ms upower.service
               581ms NetworkManager.service
               541ms var.mount
               536ms systemd-rfkill.service
               534ms root.mount
               525ms srv.mount
               519ms udisks2.service
               508ms tmp.mount
               489ms boot-grub2-i386\x2dpc.mount
               484ms boot-grub2-x86_64\x2defi.mount
               436ms systemd-remount-fs.service
               427ms dev-mqueue.mount
               423ms dev-hugepages.mount
               409ms sys-kernel-debug.mount
               396ms rtkit-daemon.service
    389ms opt.mount
               383ms systemd-udev-trigger.service
               356ms systemd-journal-flush.service
               329ms usr-local.mount
               286ms systemd-tmpfiles-setup-dev.service
               235ms auditd.service
               217ms sysroot.mount
               200ms systemd-modules-load.service
               194ms systemd-random-seed.service
               176ms user@1000.service
               169ms systemd-journald.service
               158ms iscsi.service
               153ms systemd-backlight@backlight:intel_backlight.service
               144ms wpa_supplicant.service
               143ms initrd-parse-etc.service
               137ms plymouth-read-write.service
               134ms mcelog.service
               114ms kmod-static-nodes.service
                98ms systemd-vconsole-setup.service
                94ms systemd-fsck-root.service
                88ms systemd-user-sessions.service
                73ms systemd-sysctl.service
                62ms systemd-tmpfiles-setup.service
                49ms dracut-cmdline.service
                40ms systemd-update-utmp.service
                26ms initrd-cleanup.service
                19ms plymouth-switch-root.service
                17ms dracut-pre-trigger.service
                16ms dracut-shutdown.service
                13ms \x2esnapshots.mount
                11ms user-runtime-dir@1000.service
                10ms systemd-update-utmp-runlevel.service
                 7ms initrd-udevadm-cleanup-db.service
                 6ms sys-fs-fuse-connections.mount
    I think you can disable several of those services. I presume you are adsl or fibre and not on a modem so you can disable ModemManager.service. If you are like me on ext4 and not on btrfs, you can disable btrfsmaintenance-refresh.service. On my computer I have disabled avahi-daemon.service (that is configuring an auto connection when you have no networking service), if you don't run a mail server you can disable postfix.service. The command is
    Code:
    systemctl disable <insert service here>

  7. #7

    Default Re: Boot Times are too High

    I shouldn't have thought of that,maybe some apps is hidden on the computer.

  8. #8

    Default Re: Boot Times are too High

    very interesting thing, I'm supposing to disable these services, is this ok about your opinion??
    pla@pla-3-TW:~> systemd-analyze blame
    14.306s apparmor.service, I don't know anything about it, is it ok to disable?
    9.776s ModemManager.service, I don't use modem, it is ok to disable?
    8.531s btrfsmaintenance-refresh.service, I on ext4, it is ok to disable?
    are there other services that I can disable about your opinion?
    manythanks, ciao, Pier

    Code:
    pla@pla-3-TW:~> systemd-analyze blame
             17.120s plymouth-quit-wait.service
             16.941s display-manager.service
             14.306s apparmor.service
             13.392s lvm2-monitor.service
             10.482s ca-certificates.service
              9.776s ModemManager.service
              8.531s btrfsmaintenance-refresh.service
              5.989s initrd-switch-root.service
              5.553s systemd-journal-flush.service
              4.810s mcelog.service
              4.773s nscd.service
              4.614s kbdsettings.service
              4.108s vboxdrv.service
              3.942s postfix.service
              3.780s systemd-udevd.service
              3.736s polkit.service
              3.096s NetworkManager.service
              2.261s backup-rpmdb.service
              2.231s ntpd.service
              2.151s sshd.service
              1.708s systemd-tmpfiles-setup-dev.service
              1.686s plymouth-start.service
              1.390s systemd-fsck@dev-disk-by\x2dlabel-dati.service
              1.301s systemd-tmpfiles-clean.service
              1.049s avahi-daemon.service
               859ms systemd-fsck@dev-disk-by\x2dlabel-home2.service
               800ms systemd-remount-fs.service
               792ms dev-disk-by\x2duuid-7d02d083\x2dd2a0\x2d4527\x2d9a0a\x2d95d7ce380c89.swap
               728ms systemd-udev-trigger.service
               710ms colord.service
               677ms systemd-sysctl.service
               630ms dev-mqueue.mount
               619ms iscsi.service
               578ms auditd.service
               531ms sys-kernel-debug.mount
               489ms dev-hugepages.mount
               484ms bluetooth.service
               459ms upower.service
               434ms systemd-fsck-root.service
               351ms logrotate.service
               343ms wpa_supplicant.service
               339ms systemd-user-sessions.service
               333ms systemd-modules-load.service
               323ms systemd-tmpfiles-setup.service
               295ms systemd-random-seed.service
               287ms systemd-logind.service
               285ms systemd-backlight@backlight:nv_backlight.service
               284ms systemd-backlight@leds:dell::kbd_backlight.service
               256ms fstrim.service
               191ms sysroot.mount
               186ms home.mount

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    25,022
    Blog Entries
    15

    Default Re: Boot Times are too High

    Quote Originally Posted by pier_andreit View Post
    very interesting thing, I'm supposing to disable these services, is this ok about your opinion??
    pla@pla-3-TW:~> systemd-analyze blame
    14.306s apparmor.service, I don't know anything about it, is it ok to disable?
    9.776s ModemManager.service, I don't use modem, it is ok to disable?
    8.531s btrfsmaintenance-refresh.service, I on ext4, it is ok to disable?
    are there other services that I can disable about your opinion?
    manythanks, ciao, Pier

    Code:
    pla@pla-3-TW:~> systemd-analyze blame
             17.120s plymouth-quit-wait.service
             16.941s display-manager.service
             14.306s apparmor.service
             13.392s lvm2-monitor.service
             10.482s ca-certificates.service
              9.776s ModemManager.service
              8.531s btrfsmaintenance-refresh.service
              5.989s initrd-switch-root.service
              5.553s systemd-journal-flush.service
              4.810s mcelog.service
              4.773s nscd.service
              4.614s kbdsettings.service
              4.108s vboxdrv.service
              3.942s postfix.service
              3.780s systemd-udevd.service
              3.736s polkit.service
              3.096s NetworkManager.service
              2.261s backup-rpmdb.service
              2.231s ntpd.service
              2.151s sshd.service
              1.708s systemd-tmpfiles-setup-dev.service
              1.686s plymouth-start.service
              1.390s systemd-fsck@dev-disk-by\x2dlabel-dati.service
              1.301s systemd-tmpfiles-clean.service
              1.049s avahi-daemon.service
               859ms systemd-fsck@dev-disk-by\x2dlabel-home2.service
               800ms systemd-remount-fs.service
               792ms dev-disk-by\x2duuid-7d02d083\x2dd2a0\x2d4527\x2d9a0a\x2d95d7ce380c89.swap
               728ms systemd-udev-trigger.service
               710ms colord.service
               677ms systemd-sysctl.service
               630ms dev-mqueue.mount
               619ms iscsi.service
               578ms auditd.service
               531ms sys-kernel-debug.mount
               489ms dev-hugepages.mount
               484ms bluetooth.service
               459ms upower.service
               434ms systemd-fsck-root.service
               351ms logrotate.service
               343ms wpa_supplicant.service
               339ms systemd-user-sessions.service
               333ms systemd-modules-load.service
               323ms systemd-tmpfiles-setup.service
               295ms systemd-random-seed.service
               287ms systemd-logind.service
               285ms systemd-backlight@backlight:nv_backlight.service
               284ms systemd-backlight@leds:dell::kbd_backlight.service
               256ms fstrim.service
               191ms sysroot.mount
               186ms home.mount
    Hi
    You probably want to check things first...

    For example, use journalctl to check the boot log for failed services, eg, on a recent setup here;
    Code:
    journalctl -b --no-pager |grep Failed
    
    Nov 26 08:09:28 big-bird systemd-backlight[844]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
    It's because the amdgpu one is used...
    Code:
    journalctl -b --no-pager |grep backlight:amdgpu
    
    Nov 26 08:09:28 big-bird systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0...
    So I want to not only disable, but ensure it doesn't pop back so I mask it...

    Code:
    systemctl status systemd-backlight@backlight\:acpi_video0.service
    systemctl disable systemd-backlight@backlight\:acpi_video0.service
    systemctl mask systemd-backlight@backlight\:acpi_video0.service
    
    Created symlink /etc/systemd/system/systemd-backlight@backlight:acpi_video0.service ? /dev/null.
    Likewise for things like ModemManager.

    That being said, the critical chain output is of more interest and delays here. The blame output can be missleading as tasks can be in parallel, esp things like fsck, purge kernels, rpmdb maintenance. If your only using ipv4 I always configure this in postfix main.cf inet_protocol since I disable ipv6. I also get rid of plymouth packages and add locks then rebuild initrd.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: Boot Times are too High

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You probably want to check things first...

    For example, use journalctl to check the boot log for failed services, eg, on a recent setup here;
    [CODE]
    journalctl -b --no-pager |grep Failed
    trying this I have only:
    Code:
    pla@pla-3-TW:~> journalctl -b --no-pager |grep Failed
    Hint: You are currently not seeing messages from other users and the system.
          Users in the 'systemd-journal' group can see all messages. Pass -q to
          turn off this notice.
    Nov 18 16:11:47 pla-3-TW.suse kdeinit5[2304]: org.kde.kcm_keyboard: Failed to parse the layout memory file "/home/pla/.local/share/kded5/keyboard/session/layout_memory.xml"
    Nov 18 16:11:56 pla-3-TW.suse pulseaudio[2414]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
    pla@pla-3-TW:~> su
    Password: 
    pla-3-TW:/home/pla # journalctl -b --no-pager |grep Failed
    Nov 18 16:11:47 pla-3-TW.suse kdeinit5[2304]: org.kde.kcm_keyboard: Failed to parse the layout memory file "/home/pla/.local/share/kded5/keyboard/session/layout_memory.xml"
    Nov 18 16:11:56 pla-3-TW.suse pulseaudio[2414]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
    pla-3-TW:/home/pla #

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •