Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: i¯m trying to start postgrest for the first time.

  1. #1
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    94

    Default i¯m trying to start postgrest for the first time.

    I know that a need to do some configuration. I think it was possible with Yast. But i do not remember how.
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: i¯m trying to start postgrest for the first time.

    You can start postgresql by simply starting the server service
    Code:
    systemctl start postgresql
    openSUSE maintainers generally provide you with most common defaults as a starting point.
    Modify as you wish.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    94

    Default Re: i¯m trying to start postgrest for the first time.

    i tried that

    Code:
    sinatra@t-bird:~> systemctl start postgresql
    Job for postgresql.service failed because the control process exited with error code.
    See "systemctl  status postgresql.service" and "journalctl  -xe" for details.
    sinatra@t-bird:~> ^C
    sinatra@t-bird:~> journalctl  -xe
    Hint: You are currently not seeing messages from other users and the system.
          Users in the 'systemd-journal' group can see all messages. Pass -q to
          turn off this notice.
    I had ro cut the listing of the command : "systemctl
    Because it was too long.

    I tried to start postgrest with the service manager of Yast, too. But without success.
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,016

    Default AW: i¯m trying to start postgrest for the first time.

    Starting as root with
    Code:
    su -l
    shows?

  5. #5
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    94

    Default Re: AW: i¯m trying to start postgrest for the first time.

    Quote Originally Posted by Sauerland View Post
    Starting as root with
    Code:
    su -l
    shows?
    in sudo mode
    this

    Code:
    t-bird:~ # systemctl start postgresql
    Job for postgresql.service failed because the control process exited with error code.
    See "systemctl  status postgresql.service" and "journalctl  -xe" for details.
    t-bird:~ #
    
    
    
    when a tried the service manager of Yast. That the log error.
    Code:
    ● postgresql.service - PostgreSQL database server   Loaded: loaded (/usr/lib/systemd/system/postgresql.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Thu 2018-11-22 12:16:46 EST; 1min 33s ago
    
    
    ᓄᕕ 22 12:16:46 t-bird systemd[1]: Starting PostgreSQL database server...
    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]:  Your database files were created by PostgreSQL version 9.4.
    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]:  Could not find executables for this version.
    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]:  Please install the PostgreSQL server package for version 9.4. 
    ᓄᕕ 22 12:16:46 t-bird systemd[1]: postgresql.service: Control process exited, code=exited status=1
    ᓄᕕ 22 12:16:46 t-bird systemd[1]: Failed to start PostgreSQL database server.
    ᓄᕕ 22 12:16:46 t-bird systemd[1]: postgresql.service: Unit entered failed state.
    ᓄᕕ 22 12:16:46 t-bird systemd[1]: postgresql.service: Failed with result 'exit-code'.
    but went i check with the software manager, i got every package install. Maybe i got too much because it seem that i have now 2 versions now since my upgrade to Leap 15. I got the 10 and the 9.6.8 version
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,016

    Default AW: i¯m trying to start postgrest for the first time.

    So the error is shown:
    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]: Your database files were created by PostgreSQL version 9.4.
    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]: Could not find executables for this version.
    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]: Please install the PostgreSQL server package for version 9.4.

  7. #7
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    94

    Default Re: i¯m trying to start postgrest for the first time.

    I removed the 10 version and force a reinstall of all progrest rpm.

    Failed again ..

    Code:
    ● postgresql.service - PostgreSQL database server   Loaded: loaded (/usr/lib/systemd/system/postgresql.service; enabled; vendor preset: disabled)   Active: failed (Result: exit-code) since Thu 2018-11-22 12:29:14 EST; 26min ago
    ᓄᕕ 22 12:29:14 t-bird systemd[1]: Starting PostgreSQL database server...ᓄᕕ 22 12:29:14 t-bird systemd[1]: postgresql.service: Control process exited, code=exited status=1ᓄᕕ 22 12:29:14 t-bird systemd[1]: Failed to start PostgreSQL database server.ᓄᕕ 22 12:29:14 t-bird systemd[1]: postgresql.service: Unit entered failed state.ᓄᕕ 22 12:29:14 t-bird systemd[1]: postgresql.service: Failed with result 'exit-code'.
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: i¯m trying to start postgrest for the first time.

    I think the error message was pretty clear...
    Your database files are PostgreSQL 9 and you installed PostgreSQL 10.

    So,
    Uninstall your postgresql10 packages with something like
    Code:
    zypper rm 'postgres*'
    And install PostgreSQL 9 with something like
    Code:
    zypper in postgresql9
    You should then be able to start your postgresql successfully by the following command and if unsuccessful will display a reason for the failure (you can post the result if you don't understand the problem)
    Code:
    systemctl start postgresql
    systemctl status postgresql
    This assumes you're installing PostgreSQL from your OSS.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  9. #9
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    94

    Default Re: i¯m trying to start postgrest for the first time.

    Quote Originally Posted by tsu2 View Post
    I think the error message was pretty clear...
    Your database files are PostgreSQL 9 and you installed PostgreSQL 10.

    So,
    Uninstall your postgresql10 packages with something like
    Code:
    zypper rm 'postgres*'
    And install PostgreSQL 9 with something like
    Code:
    zypper in postgresql9
    You should then be able to start your postgresql successfully by the following command and if unsuccessful will display a reason for the failure (you can post the result if you don't understand the problem)
    Code:
    systemctl start postgresql
    systemctl status postgresql
    This assumes you're installing PostgreSQL from your OSS.

    TSU
    Has i had state in my last message.. It's was already done. The version 10 have been removed and the 9 one had a force reinstall with Yast. all without success. But when i try to start the program with the service manager. I have this weird error.

    ᓄᕕ 22 12:16:46 t-bird postgresql-script[2311]: Your database files were created by PostgreSQL version 9.4.

    The install version is 9.6.8
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

  10. #10
    Join Date
    Aug 2017
    Location
    Montréal. Canada
    Posts
    94

    Default Re: i¯m trying to start postgrest for the first time.

    i had purge my computer from any rpm with any postgresql name in it. done a full reinstall of postgresql. Same problems

    Code:
    t-bird:/home/sinatra # systemctl status postgresql
     postgresql.service - PostgreSQL database server
       Loaded: loaded (/usr/lib/systemd/system/postgresql.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Thu 2018-11-22 16:09:20 EST; 30s ago
      Process: 16379 ExecStart=/usr/share/postgresql/postgresql-script start (code=exited, status=1/FAILURE)
    
    ᓄᕕ 22 16:09:20 t-bird systemd[1]: Starting PostgreSQL database server...
    ᓄᕕ 22 16:09:20 t-bird postgresql-script[16379]:  Your database files were created by PostgreSQL version 9.4.
    ᓄᕕ 22 16:09:20 t-bird postgresql-script[16379]:  Could not find executables for this version.
    ᓄᕕ 22 16:09:20 t-bird postgresql-script[16379]:  Please install the PostgreSQL server package for version 9.4.
    ᓄᕕ 22 16:09:20 t-bird systemd[1]: postgresql.service: Control process exited, code=exited status=1
    ᓄᕕ 22 16:09:20 t-bird systemd[1]: Failed to start PostgreSQL database server.
    ᓄᕕ 22 16:09:20 t-bird systemd[1]: postgresql.service: Unit entered failed state.
    ᓄᕕ 22 16:09:20 t-bird systemd[1]: postgresql.service: Failed with result 'exit-code'.
    
    
    Hard times create strong men,
    Strong men create good times,
    Good times create weak men,
    Weak men create hard times.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •