Hi,

I have a very strange problem and i can not find anything for my situation.
The problem is that i can not login as user or root in run level 3. I enter username and when i am prompted
for password , i give it but nothing happens, after 60 sec it is timing out and i am prompted for user name again.
In kde i can login ok. Also in run level 1 i can login as root ok. I am using nvidia drivers from nvidia site compiled for the kernel.

uname -a
Linux xxxxxx 4.12.14-lp150.12.25-default #1 SMP Thu Nov 1 06:14:23 UTC 2018 (3fcf457) x86_64 x86_64 x86_64 GNU/Linux

the driver is
NVIDIA-Linux-x86_64-340.107.run

Nvidia card is
VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)

Some errors i found with journalctl are the following.

systemd[1]: getty@tty1.service: Service has no hold-off time (RestartSec=0), scheduling restart.
systemd[1]: Stopped Getty on tty1.
systemd[1]: Started Getty on tty1.
-----------------------
[ 11.531029] NVRM: Your system is not currently configured to drive a VGA console
[ 11.531032] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[ 11.531034] NVRM: requires the use of a text-mode VGA console. Use of other console
[ 11.531036] NVRM: drivers including, but not limited to, vesafb, may result in
[ 11.531037] NVRM: corruption and stability problems, and is not supported.
--------------------------------------------------
systemctl cat getty@tty1.service

# /usr/lib/systemd/system/getty@.service
# This file is part of systemd.
#
# systemd is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2.1 of the License, or
# (at your option) any later version.

[Unit]
Description=Getty on %I
Documentation=man:agetty(8) man:systemd-getty-generator(8)
Documentation=http://0pointer.de/blog/projects/serial-console.html
After=systemd-user-sessions.service plymouth-quit-wait.service
After=rc-local.service

# If additional gettys are spawned during boot then we should make
# sure that this is synchronized before getty.target, even though
# getty.target didn't actually pull it in.
Before=getty.target
IgnoreOnIsolate=yes

# IgnoreOnIsolate causes issues with sulogin, if someone isolates
# rescue.target or starts rescue.service from multi-user.target or
# graphical.target.
Conflicts=rescue.service
Before=rescue.service

# On systems without virtual consoles, don't start any getty. Note
# that serial gettys are covered by serial-getty@.service, not this
# unit.
ConditionPathExists=/dev/tty0

[Service]
# the VT is cleared by TTYVTDisallocate
# The '-o' option value tells agetty to replace 'login' arguments with an
# option to preserve environment (-p), followed by '--' for safety, and then
# the entered username.
ExecStart=-/sbin/agetty -o '-p -- \\u' --noclear %I $TERM
Type=idle
Restart=always
RestartSec=0
UtmpIdentifier=%I
TTYPath=/dev/%I
TTYReset=yes
TTYVHangup=yes
TTYVTDisallocate=yes
KillMode=process
IgnoreSIGPIPE=no
SendSIGHUP=yes

# Unset locale for the console getty since the console has problems
# displaying some internationalized messages.
Environment=LANG= LANGUAGE= LC_CTYPE= LC_NUMERIC= LC_TIME= LC_COLLATE= LC_MONETARY= LC_MESSAGES= LC_PAPER= LC_NAME= LC_ADDRESS= LC_TELEPHONE= LC_MEASUREMENT= LC_IDENTIFICATION=

[Install]
WantedBy=getty.target
DefaultInstance=tty1

# /usr/lib/systemd/system/getty@tty1.service.d/noclear.conf
[Service]
# ensure tty1 isn't cleared (bnc#804158)
TTYVTDisallocate=no

i must also say that i have configured 2 screens and working as expected, first main screen is a 1920x1080 and the second is a 1680x1050

I also have a look at https://doc.opensuse.org/documentati...a.trouble.html but did not find something relevant
Any help would be appreciated.
thank you.