Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Kernel 4.19.1 won't boot (black screen)

  1. #11
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    721

    Default Re: Kernel 4.19.1 won't boot (black screen)

    Same identical issue with Kernel 4.19.2, the latest snapshot does not fix this as suggested. 4.19.2 must be missing some video card firmwares.

    Please advice the next steps. There should be no need to change the way I blacklist radeon and whitelist amdgpu: The exact same parameters work fine on my mother's computer on the same Kernel version and Tumbleweed snapshot, and also work fine on my machine with Kernel 4.18.5... their functionality has thus not changed. This must be hardware specific and related to the video card model.
    openSUSE Tumbleweed x64, KDE Framework 5

  2. #12
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    721

    Default Re: Kernel 4.19.1 won't boot (black screen)

    Seems many people on various distros are reporting this exact problem:

    https://forum.manjaro.org/t/problem-...nel-4-19/63778
    https://forum.manjaro.org/t/cant-get...tuck-on-radeon
    https://forum.manjaro.org/t/upgrade-...bles-my-amdgpu

    It's been suggested that it is caused by the following issue:

    https://bugs.freedesktop.org/show_bug.cgi?id=108260

    If that is indeed the case, the issue was supposedly fixed in Kernel 4.20. That is however a long way from now, and Kernel 4.18.5 doesn't even appear in my Advanced grub2 options menu any more! Can anyone dig up more information on this to confirm that bug is indeed the cause? And if that's correct then is there a chance the openSUSE admins could decide to either revert Tumbleweed to 4.18.5 in the meantime or do an early emergency upgrade to 4.20.0 in the following days?

    I also preformed a test which was suggested on another thread. It gave me some interesting results. I booted 4.19.2 with the following kernel parameter, additional to my default parameters in the first post:

    amdgpu.dc=0

    What changed: Instead of the black screen, the computer froze on the last grub2 screen (black box saying "loading initial ramdisks"). After less than a minute however, the NumLock / CapsLock leds became possible to toggle again, but most importantly the computer shut down cleanly when I pressed the power button. As others are suggesting, something must be causing X11 to not recognize or to later drop the display device.
    openSUSE Tumbleweed x64, KDE Framework 5

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,652
    Blog Entries
    15

    Default Re: Kernel 4.19.1 won't boot (black screen)

    On Tue 20 Nov 2018 02:46:03 PM CST, MirceaKitsune wrote:


    Same identical issue with Kernel 4.19.2, the latest snapshot does not
    fix this as suggested. 4.19.2 must be missing some video card firmwares.

    Please advice the next steps. There should be no need to change the way
    I blacklist radeon and whitelist amdgpu: The exact same parameters work
    fine on my mother's computer on the same Kernel version and Tumbleweed
    snapshot, and also work fine on my machine with Kernel 4.18.5... their
    functionality has thus not changed. This must be hardware specific and
    related to the video card model.


    Hi
    So, I would suggest moving back to radeon and see how that goes, remove
    the blacklist/whitelist(?) and the boot command line options. Disable
    plymouth as well (I remove all plymouth related stuff and lock) via
    boot option. See how that goes else it could be further down the food
    chain with your system...

    Both my AMD systems are running fine on the 4.19.2 kernel.

    No firmware missing for current cards (you may see some dracut
    firmware warnings about the newer cards not released yet).

    Not running things like virtualbox?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #14
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    721

    Default Re: Kernel 4.19.1 won't boot (black screen)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So, I would suggest moving back to radeon and see how that goes, remove
    the blacklist/whitelist(?) and the boot command line options. Disable
    plymouth as well (I remove all plymouth related stuff and lock) via
    boot option. See how that goes else it could be further down the food
    chain with your system...

    Both my AMD systems are running fine on the 4.19.2 kernel.

    No firmware missing for current cards (you may see some dracut
    firmware warnings about the newer cards not released yet).

    Not running things like virtualbox?
    I'm currently on the Kernel 4.19.2 with the radeon driver. This world perfectly fine. Of course I don't want to use radeon over amdgpu, which is inferior and also has some bizarre GPU crashes with image corruption on rare occasions.

    Was there a kernel parameter to disable plymouth? I can try that next as it may reveal some of the error messages unless the black screen will also cover those.

    I have Virtualbox installed. Of course this issue is me booting my real machine.
    openSUSE Tumbleweed x64, KDE Framework 5

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,652
    Blog Entries
    15

    Default Re: Kernel 4.19.1 won't boot (black screen)

    On Tue 20 Nov 2018 04:06:03 PM CST, MirceaKitsune wrote:


    malcolmlewis;2886767 Wrote:
    > Hi
    > So, I would suggest moving back to radeon and see how that goes,
    > remove the blacklist/whitelist(?) and the boot command line options.
    > Disable plymouth as well (I remove all plymouth related stuff and
    > lock) via boot option. See how that goes else it could be further
    > down the food chain with your system...
    >
    > Both my AMD systems are running fine on the 4.19.2 kernel.
    >
    > No firmware missing for current cards (you may see some dracut
    > firmware warnings about the newer cards not released yet).
    >
    > Not running things like virtualbox?


    I'm currently on the Kernel 4.19.2 with the radeon driver. This world
    perfectly fine. Of course I don't want to use radeon over amdgpu, which
    is inferior and also has some bizarre GPU crashes with image corruption
    on rare occasions.

    Was there a kernel parameter to disable plymouth? I can try that next as
    it may reveal some of the error messages unless the black screen will
    also cover those.

    I have Virtualbox installed. Of course this issue is me booting my real
    machine.


    Hi
    At the grub screen, press the 'e' key to edit add (in my case the
    linuxefi line);
    [CODE]
    plymouth.enable=0 console=tty
    [CODE]
    You also remove the 'quiet' option on this line, then press the F10 key
    to boot.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. #16

    Default Re: Kernel 4.19.1 won't boot (black screen)

    Quote Originally Posted by MirceaKitsune View Post
    https://bugzilla.opensuse.org/show_bug.cgi?id=1116106

    I'm running into a major issue, which seems to have been introduced with Kernel 4.19.1 which is now available in the latest openSUSE Tumbleweed snapshot.

    My machine refuses to boot with this kernel. It remains stuck at a black screen right after issuing the boot command in grub2. [/CODE]
    I also have issue with this kernel. PC boots fine, but no graphics login screen - only console login available. I have nvidia card with proprietary driver. Forced to fallback to 4.18.5.

  7. #17
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    721

    Default Re: Kernel 4.19.1 won't boot (black screen)

    As advised, I booted with the following additional parameters:

    Code:
    plymouth.enable=0 console=tty
    Result: I could see the verbose output as the boot logs were printed to the screen. Everything goes fine up until the very last moment when the login screen (sddm) is supposed to appear, that is when the screen goes black. If I add the parameter amdgpu.dc=0 to the mix, the only difference is that instead of the screen going black I see the last image (console output) frozen on the monitor. I didn't take a photo of that as the boot logs were perfectly normal and only indicated casual stuff (eg: describing various usb devices), there are no error messages or anything related to the display when the image gets stuck.
    openSUSE Tumbleweed x64, KDE Framework 5

  8. #18
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,652
    Blog Entries
    15

    Default Re: Kernel 4.19.1 won't boot (black screen)

    Quote Originally Posted by MirceaKitsune View Post
    As advised, I booted with the following additional parameters:

    Code:
    plymouth.enable=0 console=tty
    Result: I could see the verbose output as the boot logs were printed to the screen. Everything goes fine up until the very last moment when the login screen (sddm) is supposed to appear, that is when the screen goes black. If I add the parameter amdgpu.dc=0 to the mix, the only difference is that instead of the screen going black I see the last image (console output) frozen on the monitor. I didn't take a photo of that as the boot logs were perfectly normal and only indicated casual stuff (eg: describing various usb devices), there are no error messages or anything related to the display when the image gets stuck.
    Hi
    So one wonders if it's sddm related for your particular setup..... So, the test was with radeon or amdgpu? If amdgpu, what if you switch back to radeon?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #19
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    721

    Default Re: Kernel 4.19.1 won't boot (black screen)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So one wonders if it's sddm related for your particular setup..... So, the test was with radeon or amdgpu? If amdgpu, what if you switch back to radeon?
    Radeon works fine: I'm currently on 4.19.2 with it. Which I now have no choice about: Apparently the latest update decided to only keep two kernels around, which are 4.19.1 and 4.19.2... 4.18.5 was deleted from /boot and I no longer have it. If radeon didn't work I would now be locked out of my system and having to see how to repair it. I'm hoping the openSUSE developers will be working to find a solution to this quickly.
    openSUSE Tumbleweed x64, KDE Framework 5

  10. #20
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,652
    Blog Entries
    15

    Default Re: Kernel 4.19.1 won't boot (black screen)

    On Tue 20 Nov 2018 10:06:03 PM CST, MirceaKitsune wrote:


    malcolmlewis;2886816 Wrote:
    > Hi
    > So one wonders if it's sddm related for your particular setup..... So,
    > the test was with radeon or amdgpu? If amdgpu, what if you switch back
    > to radeon?


    Radeon works fine: I'm currently on 4.19.2 with it. Which I now have no
    choice about: Apparently the latest update decided to only keep two
    kernels around, which are 4.19.1 and 4.19.2... 4.18.5 was deleted from
    /boot and I no longer have it. If radeon didn't work I would now be
    locked out of my system and having to see how to repair it. I'm hoping
    the openSUSE developers will be working to find a solution to this
    quickly.


    Hi
    Yes, I mentioned that in another thread, user nrickert also has a tweak
    to keep the oldest....

    So have you looked at sddm logs? Temporarily change the login manager
    to gdm or another one? If you set your user to autologin to skip sddm,
    does the desktop turn up?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 | GNOME Shell 3.26.2 | 4.12.14-25.25-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •