I've got an effekt multiple types. Each time I've installed package update with the newer kernel version via SoftwareUpdater I've got unbootable system: black screen and no reaction to keyboard/mouse (no Ctrl+Shift+F1, nothing).

Booting in secure mode and booting using earlier kernel version all lead to the same result => unbootable system.

The only thing that works - booting readonly snapshot (previous one), reactivating it and installing packages via YAST, manually turning off update for nvidia-packages (nvidia-gfxG04-kmp-default and nvidia-glG04).

No idea why those packages get proposed.

Output of zypper update-command (before having installed kernal update):
Code:
# zypper update
Loading repository data...
Reading installed packages...

The following 24 package updates will NOT be installed:
  autofs btrfsmaintenance btrfsprogs btrfsprogs-udev-rules e2fsprogs e2fsprogs-devel fuse gptfdisk libbtrfs0 libcom_err-devel
  libcom_err2 libext2fs-devel libext2fs2 libfuse2 libgphoto2-6 libgphoto2-6-lang libparted0 libreiserfscore0 ntfs-3g ntfsprogs parted
  parted-lang sshfs unetbootin

The following 7 NEW packages are going to be installed:
  Mesa-libGLESv1_CM1 kernel-default-4.12.14-lp150.12.25.1 kernel-default-devel-4.12.14-lp150.12.25.1
  kernel-devel-4.12.14-lp150.12.25.1 kernel-source-4.12.14-lp150.12.25.1 nvidia-gfxG04-kmp-default nvidia-glG04

The following 7 packages are going to be upgraded:
  kernel-macros kodi libxvidcore4 libxvidcore4-32bit xine-ui xvidcore youtube-dl
It could be caused by my issues with nvidia driver some time ago (it was opensuse 42 or so):
  1. I've installed nvidia driver from script (it was very complex case - was hard to disable niveau)
  2. than unfortunately updated it using yast (installed nvidia binary package)
  3. than didn't know how to clean it up.
  4. after some time I've uninstalled nvidia and reactivated niveau. NVidia driver hasn't helped with closed video formats, but caused longer booting times and poor console.


Now I've added nvidia packages to the black list and hope it is "solved" for me. But the question is: why nvidia is proposed during installation of newer kernel version? (Why I had to suffer so long? or Could it be prevented somehow?)