Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32

Thread: Frequent display freezes with nouveau after update to Leap 15.0

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,447
    Blog Entries
    1

    Lightbulb Re: Frequent display freezes with nouveau after update to Leap 15.0

    inxi 3.0.27 is the more informative Tumbleweed version.
    FWIW, it is possible to update xinxi with a simple
    Code:
    sudo xinxi -U
    I've just done that....now using version 3.0.27-00 (2018-10-14)
    openSUSE Leap 15.0; KDE Plasma 5

  2. #12

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    Quote Originally Posted by mrmazda View Post
    Did you restart X or reboot after removing xf86-video-nouveau? What you get consequently should resemble what follows
    I did restart. I had Mesa-dri-nouveau in my rqm list, so I removed that as well (and then restarted again). But, inxi (now 3.0.27-00) still shows my X11 driver as nouveau.
    Code:
    # rpm -qa | grep veau
    libdrm_nouveau2-2.4.91-lp150.1.2.x86_64
    libdrm_nouveau2-32bit-2.4.91-lp150.1.2.x86_64
    # inxi -Gxx
    Graphics:
      Device-1: NVIDIA GF119M [NVS 4200M] vendor: Dell driver: nouveau v: kernel 
      bus ID: 01:00.0 chip ID: 10de:1056 
      Display: x11 server: X.Org 1.19.6 driver: nouveau unloaded: fbdev,modesetting,vesa 
      alternate: nv,nvidia compositor: gnome-shell resolution: 1920x1080~60Hz 
      OpenGL: renderer: llvmpipe (LLVM 5.0 256 bits) v: 3.3 Mesa 18.0.2 compat-v: 3.0 
      direct render: Yes

  3. #13

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    Quote Originally Posted by palswim View Post
    I did restart. I had Mesa-dri-nouveau in my rqm list, so I removed that as well (and then restarted again). But, inxi (now 3.0.27-00) still shows my X11 driver as nouveau.
    Though my system is responding slowly, like I was running in software rendering. I searched for nouveau in my /etc/ directory and found nothing (outside of French language strings).

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,447
    Blog Entries
    1

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    Can you please also post the output of the following?
    Code:
     cat /var/log/Xorg.0.log |grep -i load
    openSUSE Leap 15.0; KDE Plasma 5

  5. #15
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,028

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    I can't imagine how the output of your rpm -qa | grep veau and inxi -Gxx commands can be reconciled. The nouveau X driver is provided by the (not installed) package xf96-video-nouveau.

    Please show us a complete Xorg.0.log.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  6. #16
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,028

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    palswim, is your / filesystem BTRFS? I'd like to see the mount stats and your partitioning if it is.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  7. #17
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,089
    Blog Entries
    14

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    Quote Originally Posted by mrmazda View Post
    I can't imagine how the output of your rpm -qa | grep veau and inxi -Gxx commands can be reconciled. The nouveau X driver is provided by the (not installed) package xf96-video-nouveau.

    Please show us a complete Xorg.0.log.
    I think what's shown is the nouveau module that's in the initrd. Try running
    Code:
    dracut -f
    then reboot.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #18
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,941

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    ... and please continue to ignore my suggestion. I enjoy spending time trying to help and being ignored.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  9. #19
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,028

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    Quote Originally Posted by Knurpht View Post
    I think what's shown is the nouveau module that's in the initrd.
    That's not an inclusion in an initrd that I would expect. On three different installations that use xf86-video-nouveau I just tried
    Code:
    lsinitrd /boot/initrd | grep -i veau
    and got null output from each.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  10. #20
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,447
    Blog Entries
    1

    Default Re: Frequent display freezes with nouveau after update to Leap 15.0

    Quote Originally Posted by mrmazda View Post
    That's not an inclusion in an initrd that I would expect. On three different installations that use xf86-video-nouveau I just tried
    Code:
    lsinitrd /boot/initrd | grep -i veau
    and got null output from each.
    Agreed - the Xorg driver is a user-space driver anyway, and loaded by Xorg as required.
    openSUSE Leap 15.0; KDE Plasma 5

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •