Results 1 to 3 of 3

Thread: Cannot Install RPM package - no signature?

  1. #1

    Default Cannot Install RPM package - no signature?

    I am trying to install the latest version of LuckyBackup on my KDE Desktop. There is an rpm for openSuSE Leap 42.3 so I tried to run it with the installer. I get the following error message:-

    Code:
    Error: INVALID:luckybackup-0.5.0-29.1.x86_64 (file-e3437bce): Signature verification failed [4-Signatures public key is not available]
         Header V3 DSA/SHA1 Signature, key ID 1f94d5b1: NOKEY
         Header SHA1 digest: OK (0c85aae81b1f5b624f3064994a247940f59d6c72)
         MD5 digest: OK (2a7dc4612734e7686471b3c2870824c8)
         V3 DSA/SHA1 Signature, key ID 1f94d5b1: NOKEY
    There is a newer rpm.md5 file with later date but cannot see how to use it. Both the rpm file and the rpm.md5 files have SHA1 and MD5 text shown if I open the i button on the SourceForge Luckybackup web page but cannot get any means of installation to work.
    Any ideas how I should fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,115
    Blog Entries
    15

    Default Re: Cannot Install RPM package - no signature?

    Quote Originally Posted by Budgie2 View Post
    I am trying to install the latest version of LuckyBackup on my KDE Desktop. There is an rpm for openSuSE Leap 42.3 so I tried to run it with the installer. I get the following error message:-

    Code:
    Error: INVALID:luckybackup-0.5.0-29.1.x86_64 (file-e3437bce): Signature verification failed [4-Signatures public key is not available]
         Header V3 DSA/SHA1 Signature, key ID 1f94d5b1: NOKEY
         Header SHA1 digest: OK (0c85aae81b1f5b624f3064994a247940f59d6c72)
         MD5 digest: OK (2a7dc4612734e7686471b3c2870824c8)
         V3 DSA/SHA1 Signature, key ID 1f94d5b1: NOKEY
    There is a newer rpm.md5 file with later date but cannot see how to use it. Both the rpm file and the rpm.md5 files have SHA1 and MD5 text shown if I open the i button on the SourceForge Luckybackup web page but cannot get any means of installation to work.
    Any ideas how I should fix this?
    Hi
    Is this an openSUSE built RPM? If so whichever repo you need to download the gpg key. A quick way is to add the repo and it will pull in the key. Else you need to manually add the gpg key.

    Else if your happy with the source of the rpm, just select the ignore option...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,987
    Blog Entries
    14

    Default Re: Cannot Install RPM package - no signature?

    Quote Originally Posted by Budgie2 View Post
    I am trying to install the latest version of LuckyBackup on my KDE Desktop. There is an rpm for openSuSE Leap 42.3 so I tried to run it with the installer. I get the following error message:-

    Code:
    Error: INVALID:luckybackup-0.5.0-29.1.x86_64 (file-e3437bce): Signature verification failed [4-Signatures public key is not available]
         Header V3 DSA/SHA1 Signature, key ID 1f94d5b1: NOKEY
         Header SHA1 digest: OK (0c85aae81b1f5b624f3064994a247940f59d6c72)
         MD5 digest: OK (2a7dc4612734e7686471b3c2870824c8)
         V3 DSA/SHA1 Signature, key ID 1f94d5b1: NOKEY
    There is a newer rpm.md5 file with later date but cannot see how to use it. Both the rpm file and the rpm.md5 files have SHA1 and MD5 text shown if I open the i button on the SourceForge Luckybackup web page but cannot get any means of installation to work.
    Any ideas how I should fix this?
    I don't understand what you're writing about. How did you try to install? Do not just download packages from somewhere. FWIW I branched luckybackup from some other repo, it builds fine, runs fine and nothing like an installer.
    Like said, if you don't have the repo key on your system, it will complain. But the proper way to do this is to add the repo to your system, install the package ( and remove the repo if you want to keep the # of repos limited.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •