Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: AMD driver RX 580

  1. #1
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    592

    Default AMD driver RX 580

    Which AMD driver should I use for openSuSE Leap 15 GPU is AMD RX580 8GB.

    https://www.amd.com/en/support/graph.../radeon-rx-580

    Greetings
    Anton
    Last edited by malcolmlewis; 17-Jan-2020 at 09:01. Reason: User now on openSUSE Leap 15.1

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,856
    Blog Entries
    15

    Default Re: AMD driver RX 580

    Quote Originally Posted by anton View Post
    Which AMD driver should I use for openSuSE Leap 15 GPU is AMD RX580 8GB.

    https://www.amd.com/en/support/graph.../radeon-rx-580

    Greetings
    Anton
    Hi
    I would stick with the OSS amdgpu driver, any of the proprietary options downgrades X server components.

    Are you using the amdgpu or radeon driver?

    Code:
    /sbin/lspci -nnk |egrep -A3 "VGA|Display|3D"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    592

    Default Re: AMD driver RX 580

    For the moment I am still using an old nvidia GTX 580 but I want to switch to AND RX 580.
    Of course I first want to know if there is good driver support.

    Otherwise its better for me to stick with nvidia.
    For RX 580 we need the radeon driver only which one for opensuse Leap can't find it.
    https://www.amd.com/en/support/graph.../radeon-rx-580

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,856
    Blog Entries
    15

    Default Re: AMD driver RX 580

    Quote Originally Posted by anton View Post
    For the moment I am still using an old nvidia GTX 580 but I want to switch to AND RX 580.
    Of course I first want to know if there is good driver support.

    Otherwise its better for me to stick with nvidia.
    For RX 580 we need the radeon driver only which one for opensuse Leap can't find it.
    https://www.amd.com/en/support/graph.../radeon-rx-580
    Hi
    Newer GCN cards use amdgpu (or radeon), legacy cards use radeon. Your card is GCN so should be using amdgpu and openSUSE should switch to it.

    I would stick with the Nvidia card.....

    I have no issues to date with amdgpu, but I only have R3, R4 and R5 GPU's.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,758

    Default Re: AMD driver RX 580

    Phoronix benchmarked the «Arctic Islands» “Polaris” RX 580 with a 4.11 kernel and Mesa 17.1, albeit with AMD's GPU-Pro driver: <https://www.phoronix.com/scan.php?pa...80-linux&num=2>.

    According to the Gentoo AMDGPU wiki, support for the «Arctic Islands» AMD cards was first made available with Linux kernel version 4.7-rc6: <https://wiki.gentoo.org/wiki/AMDGPU>.

    Leap 15.0 has the version 4.12 kernel and Mesa 18.0; therefore, you should be OK with the “amdgpu” driver …
    • Check the contents of the directory ‘/lib/firmware/amdgpu/’: “polaris10_??????” files should be present, meaning that, the RX 580 is supported …
    • AFAICS, the “amdgpu” driver delivered with Leap 15.0 supports AMD's «Volcanic Islands», «Arctic Islands» and «Vega» families …

  6. #6
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    592

    Default Re: AMD driver RX 580

    Thanks I want to use the card for Blender and Eevee. Not for gaming. Nvidia GTX 1070 Ti 8GB is probably better but also more expensive.

  7. #7
    Join Date
    Jun 2012
    Location
    Serbia
    Posts
    50

    Default Re: AMD driver RX 580

    Fo Blender you need openCL, and it is not available through open-source driver (amdgpu). So you need either proprietary (amdgpu-pro) or rocm (also open, but not available for openSUSE). I couldn't mage to get amdgpu-pro working on Leap 15 (R7 260X), so nVidia might be better choice, unless you want to switch to Ubuntu

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,978

    Default Re: AMD driver RX 580

    openCL won't work with the default (modesetting) FOSS X driver?
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  9. #9
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    592

    Default Re: AMD driver RX 580

    Quote Originally Posted by mrmazda View Post
    openCL won't work with the default (modesetting) FOSS X driver?
    OK that is disappointed will it give driver problems when updating openSUSE patches.

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,758

    Talking Re: AMD driver RX 580

    Quote Originally Posted by mrmazda View Post
    openCL won't work with the default (modesetting) FOSS X driver?
    AFAICS, OpenCL 1.2 is supported only by AMD's AMDGPU-Pro Driver (version 17.40); the “amdgpu” team seem to have expected that Mesa with “Clover” would resolve the OpenCL issue but, that strategy currently doesn't seem to have worked out …

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •