Results 1 to 8 of 8

Thread: Turn Off "Enter password to unlock" Message

  1. #1

    Default Turn Off "Enter password to unlock" Message

    I am using openSUSE 15 Leap, 64-bit, with the KDE desktop environment. Not much of a Linux expert...
    Today I installed Skype.
    Every time that I launch Skype, a pop-up window appears:

    Enter password to unlock
    An application wants access to the keyring "Default keyring", but it is locked.
    How do I permanently get rid of this pop-up window? I am the only one using the PC, so I do not need this level of security...

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Turn Off "Enter password to unlock" Message

    I'm not sure, but that sounds like a "Gnome keyring" message. Perhaps Skype is Gnome based.

    If you use GDM (instead of SDDM) for login, then the Gnome keyring is automatically opened during login -- but only if it is using the login password for the keyring. If you have set a different password, then you might need to first change that. And I'm not sure how, if Gnome is not installed.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Turn Off "Enter password to unlock" Message

    Quote Originally Posted by nrickert View Post
    I'm not sure, but that sounds like a "Gnome keyring" message. Perhaps Skype is Gnome based.

    If you use GDM (instead of SDDM) for login, then the Gnome keyring is automatically opened during login -- but only if it is using the login password for the keyring. If you have set a different password, then you might need to first change that. And I'm not sure how, if Gnome is not installed.
    To my knowledge, Gnome is not installed on my system. The desktop environment that I am using is KDE...

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Turn Off "Enter password to unlock" Message

    KDE prompts are always for "kwallet" or "kdewallet" or similar. Gnome and XFCE prompts are for "default keyring".

    If Skype is based on Gnome, then installing it would pull in some Gnome libraries. Even without the Gnome desktop being installed, you could have applications that use the Gnome keyring.

    From a google search, Gnome keyrings are stored at ".local/share/keyrings" (relative to your home directory).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: Turn Off "Enter password to unlock" Message

    Quote Originally Posted by nrickert View Post
    KDE prompts are always for "kwallet" or "kdewallet" or similar. Gnome and XFCE prompts are for "default keyring".

    If Skype is based on Gnome, then installing it would pull in some Gnome libraries. Even without the Gnome desktop being installed, you could have applications that use the Gnome keyring.

    From a google search, Gnome keyrings are stored at ".local/share/keyrings" (relative to your home directory).
    I do not have a .local/share/keyrings directory in my /home directory.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Turn Off "Enter password to unlock" Message

    Well, okay.

    If it is really kdewallet that you are being prompted for, then you can set the wallet password to blank (an empty string). And then you won't be prompted. Or you can install "pam_kwallet" which should open the wallet automatically during login (but it won't work if you auto-login).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7

    Default Re: Turn Off "Enter password to unlock" Message

    Quote Originally Posted by nrickert View Post
    Well, okay.

    If it is really kdewallet that you are being prompted for, then you can set the wallet password to blank (an empty string). And then you won't be prompted. Or you can install "pam_kwallet" which should open the wallet automatically during login (but it won't work if you auto-login).
    How do i reset kwallet's password to an empty string? Right now, it has a password in it for Skype. I did not know that I could set a blank password so the first time that the window popped up I created a password...
    I did some searching on how to reset the kwallet password to blank but I could not find anything that seems to explain in simple terms how to do it...

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,624
    Blog Entries
    3

    Default Re: Turn Off "Enter password to unlock" Message

    Quote Originally Posted by tb75252 View Post
    How do i reset kwallet's password to an empty string?
    If you run "kdewalletmanager" (from the start menu/system) there's an option to change password. But that won't work if you are using "gpg" encryption for the wallet.

    The other choice is to just delete the wallet and start over. It is in ".local/share/kwalletd". You can just delete everything in that directory. Best to do that when not logged into KDE. You can logout, and then login to Icewm to do that. Or logout, and then use CTRL-ALT-F1 to get a console session to remove those files. When you login again, a new wallet is created. Well, actually, it is created when you first try to use it. You are prompted for a wallet password. Choose "blowfish" encryption and set the password to the empty string (i.e. don't type anything into the password field).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •