Results 1 to 6 of 6

Thread: Trying to get 64 and 32 bit versions of Vulkan to co-exist

  1. #1

    Default Trying to get 64 and 32 bit versions of Vulkan to co-exist

    Hi. I'm trying to get some games running on Lutris. Several of them require both the 64 and 32 bit Vulkan loaders. The opensuse "Vulkan" package (which is the vulkan loader) is 64 bit only however, and no 32 bit package is offered.

    I found the i586 rpm online, in a community repo. When I try to install it, it seems I can only keep one version or the other.

    I need to be able to keep both installed. Do you know how I might go about doing that?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Trying to get 64 and 32 bit versions of Vulkan to co-exist

    According to the Vulkan-loader project, 32=bit is not officially supported although they <think> the instructions they provide should work.
    That sounds to me like they <really> don't want apps to be using the 32=bit Vulkan-loader.
    Maybe the proper solution is to contact the developers of the app/game which requires it and nudge them to fix this instead of you trying to come up with a workaround

    The Vulkan=loader source, if you ever wanted to build it yourself (I doubt would be better than what you get from openSUSE)

    https://github.com/KhronosGroup/Vulk...aster/BUILD.md

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Trying to get 64 and 32 bit versions of Vulkan to co-exist

    Thanks for your reply. Unfortunately, I'm trying to run closed-source Windows games. Some of them have a 32-bit launcher, like the Blizzard app and Origin, then a 64 bit game, so they require both vulkan launchers. It seems many popular distros (ubuntu, arch) offer both versions.

    I actually have all the loader files. I extracted them from the rpm from the repo. I'm just not sure what to do with them now without overwriting the 64 bit loader files.

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Trying to get 64 and 32 bit versions of Vulkan to co-exist

    Quote Originally Posted by infofront View Post
    Thanks for your reply. Unfortunately, I'm trying to run closed-source Windows games. Some of them have a 32-bit launcher, like the Blizzard app and Origin, then a 64 bit game, so they require both vulkan launchers. It seems many popular distros (ubuntu, arch) offer both versions.

    I actually have all the loader files. I extracted them from the rpm from the repo. I'm just not sure what to do with them now without overwriting the 64 bit loader files.
    I've not unpacked or inspected the package contents so I can't say with certainty,
    But ordinarily 32-bit and 64-bit files are stored in different locations
    I'm going to guess you're running the same command to invoke your Vulkan-loader, but I'm also going to guess that command points to another executable specific to 32-bit or 64-bit.
    If you didn't actually uninstall your 32-bit or 64-bit files, I'm also guessing they both still co-exist on your system.

    Run the following command to inspect the package contents of each RPM package... Noting the file locations for each and the binaries listed.
    Code:
    rpm -ql packagename
    Am speculating, but I would expect that you should see executables you can invoke invoke directly instead of using your current command.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: Trying to get 64 and 32 bit versions of Vulkan to co-exist

    By default, the 64 and 32 bit Vulkan loader packages go to the same location on Opensuse, which is part of the problem.

    Lutris handles the loader commands, and detects to see if both 64 bit and 32 bit loaders are installed on a system. I'm still a linux newbie. Is there some kind of central configuration file that Lutris would be checking to see if the loaders are installed?

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Trying to get 64 and 32 bit versions of Vulkan to co-exist

    I'd be surprised if there is something complicated about what is happening here...

    If you can, since you say that installing one over-writes the other.

    So, if you can uninstall the 64=bit version, then install the 32-bit version and post the package contents,
    Then install the 64-bit version and post the package contents for that.

    If you can do that,
    I'd be interested in verifying there isn't a simple way to invoke each individually.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •