Results 1 to 6 of 6

Thread: The following 18 package updates will NOT be installed

  1. #1
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default The following 18 package updates will NOT be installed

    Hi,

    I installed Leap 15 then did zypper up and then added the packman repo.

    Now when I do zypper up I see this

    Code:
    # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following 18 package updates will NOT be installed:
      gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-libav
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libgstadaptivedemux-1_0-0
      libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
      libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
      libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
      libgstwayland-1_0-0 libquicktime0 vlc-codec-gstreamer
    
    Nothing to do.
    What should I do ?
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,038
    Blog Entries
    14

    Default Re: The following 18 package updates will NOT be installed

    Quote Originally Posted by suse_kid View Post
    Hi,

    I installed Leap 15 then did zypper up and then added the packman repo.

    Now when I do zypper up I see this

    Code:
    # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following 18 package updates will NOT be installed:
      gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-libav
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libgstadaptivedemux-1_0-0
      libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
      libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
      libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
      libgstwayland-1_0-0 libquicktime0 vlc-codec-gstreamer
    
    Nothing to do.
    What should I do ?
    Did you also do the "vendor switch" to the Packman repo?
    If so, this is perfectly normal. These packages exist both in the distro's repo and the Packman repo, you should use the packman ones, and zypper tells you that there are updated packages in the distribution that will not be installed since you told zypper the use the packman ones.
    If not,
    Code:
    sudo zypper dup --from Packman\ Repository --allow-vendor-change
    makes the vendor change happen. Yet you will see such a list of packages, since you cannot have the same package both from the distro and from Packman
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,875
    Blog Entries
    3

    Default Re: The following 18 package updates will NOT be installed

    That sort of message is not necessarily a problem. However, I am not seeing those at present with Leap 15.0. So I think it is telling you that there are updates in the packman repo, but they won't be installed because that would require a vendor change.

    Now that you have added the packman repo, you need to switch packages to that repo.

    One way to do that, is to use Yast Software Management. Select the "Repositories" view. Then click on the packman repo (in the list of repos). There should be an option near the top of the screen, to switch system packages to this repo. Use that option.

    You will probably get a conflict dialog for each package to be switched. In my opinion, that's bug, since you already said you wanted to switch.

    The other way to switch, which is the one that I used, avoids that conflict dialog. I simply used:
    Code:
    zypper dup --from "packman" --allow-vendor-change
    except that you must replace "packman" with the name of your packman repo. And use quotes if that name contains spaces or other special characters.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Mar 2011
    Location
    India
    Posts
    303

    Default Re: The following 18 package updates will NOT be installed

    Code:
    # zypper dup --from "packman" --allow-vendor-change
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    Repository 'packman' not found by its alias, number, or URI.
    Use 'zypper repos' to get the list of defined repositories.
    ^^ This didn't work but this worked

    Code:
    # sudo zypper dup --from Packman\ Repository --allow-vendor-change
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    The following 18 packages are going to be upgraded:
      gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-libav
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libgstadaptivedemux-1_0-0
      libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
      libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
      libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
      libgstwayland-1_0-0 libquicktime0 vlc-codec-gstreamer
    
    The following 18 packages are going to change vendor:
      gstreamer-plugins-bad         openSUSE -> http://packman.links2linux.de
      gstreamer-plugins-bad-lang    openSUSE -> http://packman.links2linux.de
      gstreamer-plugins-libav       openSUSE -> http://packman.links2linux.de
      gstreamer-plugins-ugly        openSUSE -> http://packman.links2linux.de
      gstreamer-plugins-ugly-lang   openSUSE -> http://packman.links2linux.de
      libgstadaptivedemux-1_0-0     openSUSE -> http://packman.links2linux.de
      libgstbadaudio-1_0-0          openSUSE -> http://packman.links2linux.de
      libgstbadbase-1_0-0           openSUSE -> http://packman.links2linux.de
      libgstbadvideo-1_0-0          openSUSE -> http://packman.links2linux.de
      libgstbasecamerabinsrc-1_0-0  openSUSE -> http://packman.links2linux.de
      libgstcodecparsers-1_0-0      openSUSE -> http://packman.links2linux.de
      libgstgl-1_0-0                openSUSE -> http://packman.links2linux.de
      libgstmpegts-1_0-0            openSUSE -> http://packman.links2linux.de
      libgstphotography-1_0-0       openSUSE -> http://packman.links2linux.de
      libgsturidownloader-1_0-0     openSUSE -> http://packman.links2linux.de
      libgstwayland-1_0-0           openSUSE -> http://packman.links2linux.de
      libquicktime0                 openSUSE -> http://packman.links2linux.de
      vlc-codec-gstreamer           openSUSE -> http://packman.links2linux.de
    
    18 packages to upgrade, 18  to change vendor.
    Overall download size: 3.5 MiB. Already cached: 0 B. After the operation, 4.0
    KiB will be freed.
    Continue? [y/n/...? shows all options] (y): 
    Retrieving package libgstcodecparsers-1_0-0-1.12.5-lp150.2.7.x86_64
                                              (1/18), 182.3 KiB (266.4 KiB unpacked)
    Retrieving: libgstcodecparsers-1_0-0-1.12.5-lp150.2.7.x86_64.[done (58.8 KiB/s)]
    Retrieving package libgsturidownloader-1_0-0-1.12.5-lp150.2.7.x86_64
                                              (2/18),  91.2 KiB ( 30.9 KiB unpacked)
    Retrieving: libgsturidownloader-1_0-0-1.12.5-lp150.2.7.x86_64[done (40.2 KiB/s)]
    Retrieving package vlc-codec-gstreamer-3.0.2-lp150.3.5.x86_64
                                              (3/18),  83.8 KiB ( 43.1 KiB unpacked)
    Retrieving: vlc-codec-gstreamer-3.0.2-lp150.3.5.x86_64.rpm ...............[done]
    Retrieving package gstreamer-plugins-ugly-1.12.5-lp150.2.2.x86_64
                                              (4/18), 176.5 KiB (435.1 KiB unpacked)
    Retrieving: gstreamer-plugins-ugly-1.12.5-lp150.2.2.x86_64.r[done (128.4 KiB/s)]
    Retrieving package libquicktime0-1.2.4cvs20150223-lp150.4.14.x86_64
                                              (5/18), 190.2 KiB (565.4 KiB unpacked)
    Retrieving: libquicktime0-1.2.4cvs20150223-lp150.4.14.x86_64.[done (54.6 KiB/s)]
    Retrieving package libgstbadbase-1_0-0-1.12.5-lp150.2.7.x86_64
                                              (6/18), 106.1 KiB ( 71.1 KiB unpacked)
    Retrieving: libgstbadbase-1_0-0-1.12.5-lp150.2.7.x86_64.rpm .[done (34.0 KiB/s)]
    Retrieving package libgstgl-1_0-0-1.12.5-lp150.2.7.x86_64
                                              (7/18), 210.5 KiB (386.4 KiB unpacked)
    Retrieving: libgstgl-1_0-0-1.12.5-lp150.2.7.x86_64.rpm ......[done (59.8 KiB/s)]
    Retrieving package libgstmpegts-1_0-0-1.12.5-lp150.2.7.x86_64
                                              (8/18), 125.9 KiB (162.5 KiB unpacked)
    Retrieving: libgstmpegts-1_0-0-1.12.5-lp150.2.7.x86_64.rpm ..[done (45.1 KiB/s)]
    Retrieving package libgstwayland-1_0-0-1.12.5-lp150.2.7.x86_64
                                              (9/18),  84.5 KiB ( 10.1 KiB unpacked)
    Retrieving: libgstwayland-1_0-0-1.12.5-lp150.2.7.x86_64.rpm .[done (30.9 KiB/s)]
    Retrieving package libgstbasecamerabinsrc-1_0-0-1.12.5-lp150.2.7.x86_64
                                             (10/18),  90.9 KiB ( 26.7 KiB unpacked)
    Retrieving: libgstbasecamerabinsrc-1_0-0-1.12.5-lp150.2.7.x86[done (73.3 KiB/s)]
    Retrieving package gstreamer-plugins-libav-1.12.5-lp150.3.3.x86_64
                                             (11/18), 163.1 KiB (264.3 KiB unpacked)
    Retrieving: gstreamer-plugins-libav-1.12.5-lp150.3.3.x86_64.r[done (52.9 KiB/s)]
    Retrieving package libgstphotography-1_0-0-1.12.5-lp150.2.7.x86_64
                                             (12/18),  89.0 KiB ( 34.2 KiB unpacked)
    Retrieving: libgstphotography-1_0-0-1.12.5-lp150.2.7.x86_64.r[done (41.6 KiB/s)]
    Retrieving package libgstadaptivedemux-1_0-0-1.12.5-lp150.2.7.x86_64
                                             (13/18), 115.6 KiB ( 95.6 KiB unpacked)
    Retrieving: libgstadaptivedemux-1_0-0-1.12.5-lp150.2.7.x86_64[done (40.9 KiB/s)]
    Retrieving package gstreamer-plugins-ugly-lang-1.12.5-lp150.2.2.noarch
                                             (14/18),  61.6 KiB ( 73.1 KiB unpacked)
    Retrieving: gstreamer-plugins-ugly-lang-1.12.5-lp150.2.2.noar[done (11.1 KiB/s)]
    Retrieving package libgstbadaudio-1_0-0-1.12.5-lp150.2.7.x86_64
                                             (15/18),  92.7 KiB ( 30.6 KiB unpacked)
    Retrieving: libgstbadaudio-1_0-0-1.12.5-lp150.2.7.x86_64.rpm [done (60.6 KiB/s)]
    Retrieving package libgstbadvideo-1_0-0-1.12.5-lp150.2.7.x86_64
                                             (16/18), 101.3 KiB ( 55.4 KiB unpacked)
    Retrieving: libgstbadvideo-1_0-0-1.12.5-lp150.2.7.x86_64.rpm [done (38.1 KiB/s)]
    Retrieving package gstreamer-plugins-bad-1.12.5-lp150.2.7.x86_64
                                             (17/18),   1.5 MiB (  5.0 MiB unpacked)
    Retrieving: gstreamer-plugins-bad-1.12.5-lp150.2.7.x86_64.rpm ..................................................................................................................................[done (47.2 KiB/s)]
    Retrieving package gstreamer-plugins-bad-lang-1.12.5-lp150.2.7.noarch                                                                                                       (18/18), 107.8 KiB (107.8 KiB unpacked)
    Retrieving: gstreamer-plugins-bad-lang-1.12.5-lp150.2.7.noarch.rpm .............................................................................................................................[done (45.0 KiB/s)]
    Checking for file conflicts: ................................................................................................................................................................................[done]
    ( 1/18) Installing: libgstcodecparsers-1_0-0-1.12.5-lp150.2.7.x86_64 ........................................................................................................................................[done]
    ( 2/18) Installing: libgsturidownloader-1_0-0-1.12.5-lp150.2.7.x86_64 .......................................................................................................................................[done]
    ( 3/18) Installing: vlc-codec-gstreamer-3.0.2-lp150.3.5.x86_64 ..............................................................................................................................................[done]
    ( 4/18) Installing: gstreamer-plugins-ugly-1.12.5-lp150.2.2.x86_64 ..........................................................................................................................................[done]
    ( 5/18) Installing: libquicktime0-1.2.4cvs20150223-lp150.4.14.x86_64 ........................................................................................................................................[done]
    ( 6/18) Installing: libgstbadbase-1_0-0-1.12.5-lp150.2.7.x86_64 .............................................................................................................................................[done]
    ( 7/18) Installing: libgstgl-1_0-0-1.12.5-lp150.2.7.x86_64 ..................................................................................................................................................[done]
    ( 8/18) Installing: libgstmpegts-1_0-0-1.12.5-lp150.2.7.x86_64 ..............................................................................................................................................[done]
    ( 9/18) Installing: libgstwayland-1_0-0-1.12.5-lp150.2.7.x86_64 .............................................................................................................................................[done]
    (10/18) Installing: libgstbasecamerabinsrc-1_0-0-1.12.5-lp150.2.7.x86_64 ....................................................................................................................................[done]
    (11/18) Installing: gstreamer-plugins-libav-1.12.5-lp150.3.3.x86_64 .........................................................................................................................................[done]
    (12/18) Installing: libgstphotography-1_0-0-1.12.5-lp150.2.7.x86_64 .........................................................................................................................................[done]
    (13/18) Installing: libgstadaptivedemux-1_0-0-1.12.5-lp150.2.7.x86_64 .......................................................................................................................................[done]
    (14/18) Installing: gstreamer-plugins-ugly-lang-1.12.5-lp150.2.2.noarch .....................................................................................................................................[done]
    (15/18) Installing: libgstbadaudio-1_0-0-1.12.5-lp150.2.7.x86_64 ............................................................................................................................................[done]
    (16/18) Installing: libgstbadvideo-1_0-0-1.12.5-lp150.2.7.x86_64 ............................................................................................................................................[done]
    (17/18) Installing: gstreamer-plugins-bad-1.12.5-lp150.2.7.x86_64 ...........................................................................................................................................[done]
    (18/18) Installing: gstreamer-plugins-bad-lang-1.12.5-lp150.2.7.noarch ......................................................................................................................................[done]
    There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.
    openSUSE Leap 15
    You aren't rich until you have something that money can't buy.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: The following 18 package updates will NOT be installed

    By sasying "packman" in the suggestion, it means that you enter an identification of the Packman repository as it is on your system. When you study
    Code:
    man zypper
    you will see that you can use either the Name, the Alias or the Number of the repository.

    You can see all of them with
    Code:
    zypper lr -d
    Henk van Velden

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,059

    Default AW: The following 18 package updates will NOT be installed

    Quote Originally Posted by suse_kid View Post
    Hi,

    I installed Leap 15 then did zypper up and then added the packman repo.

    Now when I do zypper up I see this

    Code:
    # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following 18 package updates will NOT be installed:
      gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-libav
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libgstadaptivedemux-1_0-0
      libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
      libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
      libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
      libgstwayland-1_0-0 libquicktime0 vlc-codec-gstreamer
    
    Nothing to do.
    What should I do ?
    That means:
    There are newer versions/releases of a pacakge in another repo as the installed one.
    zypper up will not do any repo change.

    And often its not necessary to have the newest packages with the newest errors installed.
    That depends only on you.

    I do following if such message is showing:
    Code:
    zypper se -s packagename
    To see, in which repo is what version and if I want to switch.

    PS:
    your packages are from packman and I would switch to them as posted by the other members.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •