Results 1 to 6 of 6

Thread: Latte Dock Won't Launch For Only One User

  1. #1

    Default Latte Dock Won't Launch For Only One User

    I use Latte Dock on my openSUSE machines and had almost no problems with it. However, on my laptop, and only under my user account (my wife's works fine), Latte Dock will not launch with the 0.8.x series in the offical repo. If I install 0.7.5 or earlier from a different repo it will run. I have uninstalled and reinstalled, wiped config files and most recently nuked my entire user account and deleted the entire home folder. Yet, Latte Dock will not run.

    Running Latte from the terminal returns, "An instance is already running!, use --replace to restart Latte". Adding the --replace flag doesn't work and only returns the previous error. Curiously, Latte isn't listed in the Task Manager at all despite claiming it is running.

    I am out of ideas. Anyone else experience this behavior or have an ideas. Help is much appreciated.

  2. #2

    Default Re: Latte Dock Won't Launch For Only One User

    I found this while searching the code on GitHub, but I'm not exactly sure what it means is at issue.

    Code:
    if (!lockFile.tryLock(timeout)) { qInfo() << i18n("An instance is already running!, use --replace to restart Latte");
    qGuiApp->exit();
    return 0;
    }

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Latte Dock Won't Launch For Only One User

    If it runs on one account and not another it is probably a configuration file problem rename or delete any associated configuration files.

  4. #4

    Default Re: Latte Dock Won't Launch For Only One User

    Quote Originally Posted by gogalthorp View Post
    If it runs on one account and not another it is probably a configuration file problem rename or delete any associated configuration files.
    Yes, that's what I thought as well, but as I indicated above, I completely deleted my user account and all files then recreated my account fresh and it still wouldn't run.

  5. #5

    Default Re: Latte Dock Won't Launch For Only One User

    What has happened is the following, for some reason the lock file that indicates that Latte is running has changed permissions and Qt can not delete it. Possibly root user created it or something relevant, do not ask me how this happened, I have no idea. It could be from a Qt upgrade or Latte crash or whatever...

    You can do the following:

    1. As long as Latte is not running in reality
    2. locate file: /tmp/latte-dock.<username>.lock
    3. try to delete the previous file, if you cant delete it as regular user, delete as root

  6. #6

    Default Re: Latte Dock Won't Launch For Only One User

    Quote Originally Posted by psifidotos View Post
    What has happened is the following, for some reason the lock file that indicates that Latte is running has changed permissions and Qt can not delete it. Possibly root user created it or something relevant, do not ask me how this happened, I have no idea. It could be from a Qt upgrade or Latte crash or whatever...

    You can do the following:

    1. As long as Latte is not running in reality
    2. locate file: /tmp/latte-dock.<username>.lock
    3. try to delete the previous file, if you cant delete it as regular user, delete as root
    Thank you! That did it. I thought I also cleaned the temp files, but I guess not.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •