Results 1 to 4 of 4

Thread: GDM does not start (Nvidia proprietary)

  1. #1

    Default GDM does not start (Nvidia proprietary)

    So it has been a while since GDM stopped working on my end. I've workaround it by using LightDM, but as I'm back to using Gnome making GDM work seems like a good idea.
    I have no clue where to start looking though. Tried reinstalling gdm, removing nouveau (I'm using proprietary driver from the official repo) - no luck.
    Any ideas?

  2. #2
    Join Date
    Oct 2014

    Default Re: GDM does not start (Nvidia proprietary)

    GDM now uses Wayland by default and Nvidia doesn't like Wayland.
    Try to uncomment the line reading "#WaylandEnable=false" in /etc/gdm/custom.conf and reboot.
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Beta

  3. #3

    Default Re: GDM does not start (Nvidia proprietary)

    thx @OrsoBruno ! Unless I've did something incorrectly that didn't help (side note - how I wish Nvida folks had grown up a tad and adhered to specs made by Wayland team -> one of the reason my next GPU probably won't be a green team one).
    Gdm is still stuck at:

    I've tried both auto option and manual in update-alternatives --config default-displaymanager :

    Just in case here's a screenshot from the grub as well:

  4. #4

    Default Re: GDM does not start (Nvidia proprietary)

    Let me know if there's some other info I should provide to sort it out.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts