Results 1 to 9 of 9

Thread: How do I insert an in-line image in a forum post?

Hybrid View

  1. #1

    Default How do I insert an in-line image in a forum post?

    HI,

    If I upload an image to https://paste.opensuse.org/, I am given a link.
    If I use that link in my browser, I can see my image.

    However, when I try to paste that link (using the Link or Insert Image) into a forum post, it does not seem to work?

    Using the Link button, I see this:
    Code:
    [URL="https://paste.opensuse.org/10202002"]https://paste.opensuse.org/10202002[/URL]
    ... and using the Insert Image, I see this
    Code:
    [IMG]https://paste.opensuse.org/10202002[/IMG]
    Neither gives a view of my image in the forum post?

    Secondly, is it possible to switch editor mode while in use? I have been able to switch from "Enhanced Interface" to "Standard Editor" using the General Settings tab in "My Profile" but that is very long winded!

    Regards, Martin
    openSUSE Leap 15; KDE Plasma 5.12.5;

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,649
    Blog Entries
    14

    Default Re: How do I insert an in-line image in a forum post?

    To post inline images, use a service like imgur.com and copy paste the BB code here. We don't use real inline image, mainly for storage reasons.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,857

    Default Re: How do I insert an in-line image in a forum post?

    This thread will be moved to Forums Feedback > How to usethe Forums and is CLOSED for the moment.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,857

    Default Re: How do I insert an in-line image in a forum post?

    Quote Originally Posted by martinprowe View Post
    HI,

    If I upload an image to https://paste.opensuse.org/, I am given a link.
    If I use that link in my browser, I can see my image.

    However, when I try to paste that link (using the Link or Insert Image) into a forum post, it does not seem to work?

    Using the Link button, I see this:
    Code:
    [URL="https://paste.opensuse.org/10202002"]https://paste.opensuse.org/10202002[/URL]
    ... and using the Insert Image, I see this
    Code:
    [IMG]https://paste.opensuse.org/10202002[/IMG]
    Neither gives a view of my image in the forum post?

    Secondly, is it possible to switch editor mode while in use? I have been able to switch from "Enhanced Interface" to "Standard Editor" using the General Settings tab in "My Profile" but that is very long winded!

    Regards, Martin
    Moved from Unreviewed Howto and open again.
    Henk van Velden

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,354
    Blog Entries
    3

    Default Re: How do I insert an in-line image in a forum post?

    Quote Originally Posted by martinprowe View Post
    Secondly, is it possible to switch editor mode while in use?
    Try clicking that A/A icon in the edit box header.
    openSUSE Leap 15.1; KDE Plasma 5;

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,181
    Blog Entries
    1

    Default Re: How do I insert an in-line image in a forum post?

    Quote Originally Posted by martinprowe View Post
    HI,

    If I upload an image to https://paste.opensuse.org/, I am given a link.
    If I use that link in my browser, I can see my image.

    However, when I try to paste that link (using the Link or Insert Image) into a forum post, it does not seem to work?

    Using the Link button, I see this:
    Code:
    [URL="https://paste.opensuse.org/10202002"]https://paste.opensuse.org/10202002[/URL]
    ... and using the Insert Image, I see this
    Code:
    [IMG]https://paste.opensuse.org/10202002[/IMG]
    Neither gives a view of my image in the forum post?
    I use the URL from the image location itself by right clicking on the online image > Copy Image Location. That will provide the actual filename including extension....
    https://paste.opensuse.org/images/10202002.png

    ....so when image is inserted it will be displayed thus....

    Last edited by deano_ferrari; 16-Oct-2018 at 23:42.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #7

    Default Re: How do I insert an in-line image in a forum post?

    Quote Originally Posted by deano_ferrari View Post
    .... That will provide the actual filename including extension....
    ....so when image is inserted ...
    in the "Insert Image"
    ...it will be displayed thus....
    Ah, now I have it!

    openSUSE Leap 15; KDE Plasma 5.12.5;

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,181
    Blog Entries
    1

    Default Re: How do I insert an in-line image in a forum post?

    That's it!
    openSUSE Leap 15.0; KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,923
    Blog Entries
    2

    Default Re: How do I insert an in-line image in a forum post?

    Here is another method which I use...
    Where you store your image at opensuse.org and not elsewhere (keeps the stored image and image in the same organization).

    1. Create a Wiki page of your own for any purpose you wish (or don't use it for anything more than to gain access to openSUSE image storage). You can use the instructions in my signature at the end of this post to do so.

    2. Once you've created your wiki page, login with your credentials.

    3. Once logged in, some new links will appear in the navigational pane (left margin) of the page, and one will be to upload files. Click on this link and follow instructions, using the file picker to select your image and upload.

    4. Once uploaded, keep the page open and open a new web browser page to create your Forum post.

    5. Now, to actually insert your image into your Forum post...
    - Rt-click anywhere on the image of your uploaded file and "copy link location" - The actual language will depend on the browser you're using but the idea is to copy the link to your image into your clipboard.
    - In your Forum post, click on the button "Insert Image" and paste your link into the form. The form should recognize that your image link points to an openSUSE address, and should modify to point to an "internal" link instead of pointing to some third party site.
    - Complete the form and verify your image appears in your Forum post editor. Continue.

    Once you've done this a couple times, it becomes simple and fast.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •