Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Slow Booting & Found Culprit?

  1. #11
    Join Date
    Oct 2010
    Location
    Honolulu
    Posts
    13

    Default Re: Slow Booting & Found Culprit?

    Quote Originally Posted by dcurtisfra View Post
    With respect to the Plymouth "quit wait" issue, assuming that Plymouth is enabled, these two Bug Reports are currently being worked: <https://bugzilla.opensuse.org/show_bug.cgi?id=1110199> and <https://bugzilla.opensuse.org/show_bug.cgi?id=1110364>.
    • With Plymouth enabled, my current "work around" is to add a "plymouth-quit-wait.service" Conflict to '/usr/lib/systemd/system/display-manager.service' -- yes, yes, the file is by default write protected but, as "root" the vi command "w!" deals with this situation …
    If I read your bug report and suggestion above correctly, would the workaround be just adding "-wait" to an existing "plymouth-quit.service" conflict? Or is it added as an additional conflict? I found this in my /usr/lib/systemd/system/display-manager.service:
    Code:
    [Unit]
    Description=X Display Manager
    Requires=var-run.mount
    Conflicts=getty@tty7.service plymouth-quit.service
    After=ypbind.service gpm.service time-sync.target winbind.service acpid.service
    Wants=remote-fs.target dbus.socket systemd-user-sessions.service systemd-logind.service
    After=remote-fs.target dbus.socket systemd-user-sessions.service systemd-logind.service getty@tty7.service plymouth-quit.service

  2. #12
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Talking Re: Slow Booting & Found Culprit?

    Quote Originally Posted by dougdeep View Post
    If I read your bug report and suggestion above correctly, would the workaround be just adding "-wait" to an existing "plymouth-quit.service" conflict? Or is it added as an additional conflict?
    AFAICS, there are two conflicts: one related to the "Plymouth quit" service and, one related to the "Plymouth quit wait" service …

    What's unsettling is, simply adding the "Plymouth quit wait" Conflict to the systemd Display Manager service doesn't seem to be as reliable as working through all the "non-systemd" script portions and making them "systemd aware" -- it seems that, Plymouth is also being used by systems which do not use systemd to perform the system initialisation …

    Yes, I know, there's an awful amount of "up-stream" script files there and, theoretically, SUSE/openSUSE should be requesting the "up-stream" maintainers to get their act with respect to systemd sorted …

    UNIX® has, traditionally, the motto "do it once and, do it well" …

    As far as Plymouth is concerned, the current system initialisation using systemd seems to have pulled in some components which, IMHO, cause the system initialisation to break this basic "way of doing things" …

    It could be that, Fraser_Bell has suggested the best solution: "remove Plymouth" …

  3. #13
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: Slow Booting & Found Culprit?

    Quote Originally Posted by dcurtisfra View Post
    It could be that, Fraser_Bell has suggested the best solution: "remove Plymouth" …
    Or just use "plymouth.enable=0" in the boot kernel command line. You can set that in Yast bootloader (replace "splash=silent" with "plymouth.enable=0".

    Boot time and shutdown time are both faster since I made that change.
    openSUSE Leap 15.1; KDE Plasma 5;

  4. #14
    Join Date
    Oct 2010
    Location
    Honolulu
    Posts
    13

    Default Re: Slow Booting & Found Culprit?

    Quote Originally Posted by nrickert View Post
    Or just use "plymouth.enable=0" in the boot kernel command line. You can set that in Yast bootloader (replace "splash=silent" with "plymouth.enable=0".

    Boot time and shutdown time are both faster since I made that change.
    Thanks. That was easy to do. I was not a real fan of the startup bouncing square (or whatever that thing is).

  5. #15
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,572

    Default Re: Slow Booting & Found Culprit?

    Quote Originally Posted by dougdeep View Post
    Thanks. That was easy to do. I was not a real fan of the startup bouncing square (or whatever that thing is).
    Plymouth can be uninstalled, to reduce initrd size, save storage space, and bandwidth and time doing updates. I taboo it during initial installation, so it doesn't get installed in the first place.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  6. #16
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Cool Re: Slow Booting & Found Culprit?

    For the folks who "toe the Distro decision" line, a Plymouth "bouncing Leap" symbol issue has been found and, the repair is on the way: Bug 1110199.

    It seems that, the Plymouth daemon was not responding to the "quit" command quickly enough -- due to a flag associated with the framing needed for the "throbber" animation and, especially the point in time when the "throbber" changes colour from white to green …
    • The animation is currently a block of 73 frames (48 frames on Tumbleweed) which will be changed to 60 frames for Leap 15.x …
    • It seems that, it takes somewhere between 0 and 2 seconds to finish the "throbber" animation -- when framing at 30 FPS …

  7. #17
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    16

    Default Re: Slow Booting & Found Culprit?

    Quote Originally Posted by nrickert View Post
    Or just use "plymouth.enable=0" in the boot kernel command line. You can set that in Yast bootloader (replace "splash=silent" with "plymouth.enable=0".

    Boot time and shutdown time are both faster since I made that change.
    I didn't have a very long boot time, but after applying this change my boot time has got way faster.

    Thank you.

  8. #18
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    153

    Default Re: Slow Booting & Found Culprit?

    Aside from disabling Plymouth (the first thing I jettison after any openSUSE install), my initial boot times have been around 10 to 15s. About 5 years ago, I began systematically reducing boot times while experimenting:
    • 6,235s — Leap 42.2 with wicked, IPv6 and Plymouth disabled, on a single-partition ext4 SSD-based root filesystem
    • 3.737s — replace wicked with NetworkManager
    • 3.528s — replace Postfix with Exim
    • 2.992s — ntpd off, smartd off, irqbalance off
    • 2.691s — replace sddm with no-frills minimally configured kdm
    • 2.567s — cupsd off (not doing any printing)
    • 2.326s — reduce grub2 output and kernel/console output to errors only
    • 2.127s — switch from noop scheduling to deadline

    After installing Leap 15, I discovered that I can further reduce boot times by generating an uncompressed initrd after each Kernel update:
    Code:
    dracut --hostonly --force --no-compress --omit "img-lib cifs fcoe fcoe-uefi rdma multipath iscsi qemu lvm mdraid dm dmraid pollcdrom plymouth btrfs wacom convertfs"
    It seems to take my system longer to unpack a smaller but compressed ramdisk image than it takes the SSD to read an uncompressed one (obviously, do check the above list of services omitted, maybe your installation happens to be needing them!)

    Current best boot time: 1.455s (although, my average cold-boot time is more like 1.7s):
    Code:
    graphical.target @546ms
    └─display-manager.service @442ms +100ms
      └─systemd-user-sessions.service @438ms +3ms
        └─network.target @438ms
          └─NetworkManager.service @350ms +87ms
            └─dbus.service @312ms
              └─basic.target @311ms
                └─sockets.target @311ms
                  └─dbus.socket @311ms
                    └─sysinit.target @310ms
                      └─swap.target @310ms
                        └─dev-disk-by\x2duuid-f4481…08ff.swap @305ms +5ms
                          └─dev-disk-by\x2duuid-f4481…08ff.device @303ms
    
    openSUSE Leap 15.0 (Linux 4.12.14-lp150.12.25-default #1 SMP Thu Nov 1 06:14:23 UTC 2018 (3fcf457)) x86-64
    Startup finished in 229ms (kernel) + 675ms (initrd) + 550ms (userspace) = 1.455s
    My system is a Core-i5 on an ASUS mainboard, with 8GB RAM and two SATA-SSDs (one for the root fs, the other for swap and quick backups).
    Cheers!

  9. #19
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    894

    Default Re: Slow Booting & Found Culprit?

    The following is from a default KDE install (no tinkering whatsoever) running on modern low cost hardware:

    Code:
    notebook:~ # inxi -zSM
    System:    Host: notebook.fritz.box Kernel: 4.19.7-1-default x86_64 bits: 64 Console: tty 0 
               Distro: openSUSE Tumbleweed 20181211 
    Machine:   Type: Laptop System: HP product: HP Laptop 15-da0xxx v: Type1ProductConfigId serial: <filter> 
               Mobo: HP model: 84A6 v: 80.24 serial: <filter> UEFI: Insyde v: F.02 date: 05/24/2018 
    notebook:~ # systemd-analyze critical-chain 
    The time after the unit is active or started is printed after the "@" character.
    The time the unit takes to start is printed after the "+" character.
    
    graphical.target @3.066s
    └─multi-user.target @3.066s
      └─cron.service @3.066s
        └─postfix.service @1.745s +1.319s
          └─network.target @1.743s
            └─wpa_supplicant.service @2.478s +22ms
              └─dbus.service @916ms
                └─basic.target @914ms
                  └─paths.target @914ms
                    └─ca-certificates.path @895ms
                      └─sysinit.target @892ms
                        └─apparmor.service @334ms +558ms
                          └─systemd-journald.socket
                            └─-.mount
                              └─system.slice
                                └─-.slice
    notebook:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  10. #20
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    153

    Default Re: Slow Booting & Found Culprit?

    Quote Originally Posted by unix111 View Post
    Current best boot time: 1.455s
    Just a tiny belated follow-up to my old post:

    After years of inactivity regarding my network configuration (having switched from wicked to NetworkManager), I decided to give systemd-networkd a try two weeks ago. I’ve just posted the details over here.

    Result: systemd now manages to bring up my eth0 in 19ms (for comparison: NM was around 100ms, wicked 5s to 10s), and it works quietly and flawlessly, including those 15 meters of in-wall electric cabling to my DSL router, bridged by two devolo dLAN 1000 duo powerline-to-ethernet adapters. Less clutter thanks to a systemctl-masked wicked and uninstalled NetworkManager as well as consolidation of my trivial static DSL/networking setup within the already pre-installed systemd-networkd (preinstalled with Leap 15.0, that is).

    Together with all other optimizations mentioned in my first reply above, my boot times according to systemd-analyze are around 1.5 seconds now; personal best was 1.319s five days ago.

    Conclusion: give systemd-networkd a try.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •