Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: kde - boot message "failed to setup virtual console'

  1. #11
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,894

    Default Re: kde - boot message "failed to setup virtual console'

    Quote Originally Posted by lord_valarian View Post
    Duckduckgo search: Linux failed to setup virtual console


    https://ask.fedoraproject.org/en/que...rtual-console/

    The article describes it as grub init error. Can this be used to fix it?

    Need help.


    Toshiba satellite A215
    What is the link with KDE (in your thread title)?

    This is during boot, way before a user decides to log in and maybe use KDE.
    Henk van Velden

  2. #12

    Default Re: kde - boot message "failed to setup virtual console'

    Quote Originally Posted by nietgiftig View Post
    Perhaps more then a folded peace of paper on the top left of your monitor when you start your computer.After the start take it away, but keep it in a handy place so you can use again on the next start.
    Ok, problem solved, no more messages.


    Thanks to all.

  3. #13

    Default Re: kde - boot message "failed to setup virtual console'

    Quote Originally Posted by hcvv View Post
    What is the link with KDE (in your thread title)?

    This is during boot, way before a user decides to log in and maybe use KDE.
    In other messages, I kept forgetting to add the desktop environment type. So, now I include KDE to all messages to show that if needed.

  4. #14
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    147

    Default Re: kde - boot message "failed to setup virtual console'

    Quote Originally Posted by lord_valarian View Post
    This is the output. 'dracut: Could not find FONT_MAP none!'? Note: need to boot to see if still get the error.
    Not sure if you still see this error, but also for that problem there is a ticket and a work-around, see Bug 1013573 - "dracut: Could not find FONT_MAP none!" warning while rebuilding initrd

  5. #15

    Default Re: kde - boot message "failed to setup virtual console'

    Quote Originally Posted by marel View Post
    Not sure if you still see this error, but also for that problem there is a ticket and a work-around, see Bug 1013573 - "dracut: Could not find FONT_MAP none!" warning while rebuilding initrd
    I rebooted and the error returned. I did '#zypper remove patch'. uninstall successful. I did something wrong.

    #cd cd /usr/lib/dracut

    #patch -p1 < /home/username/bin/systemd-vconsole-setup-race-fix.patch
    If 'patch' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf patch

    #zypper in '/home/username/bin/systemd-vconsole-setup-race-fix.patch'
    Loading repository data...
    Reading installed packages...
    '/home/username/bin/systemd-vconsole-setup-race-fix.patch' not found in package names. Trying capabilities.
    No provider of '/home/username/bin/systemd-vconsole-setup-race-fix.patch' found.
    Resolving package dependencies...

    Nothing to do.

  6. #16
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,671
    Blog Entries
    14

    Default Re: kde - boot message "failed to setup virtual console'

    Quote Originally Posted by lord_valarian View Post
    I rebooted and the error returned. I did '#zypper remove patch'. uninstall successful. I did something wrong.

    #cd cd /usr/lib/dracut

    #patch -p1 < /home/username/bin/systemd-vconsole-setup-race-fix.patch
    If 'patch' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf patch

    #zypper in '/home/username/bin/systemd-vconsole-setup-race-fix.patch'
    Loading repository data...
    Reading installed packages...
    '/home/username/bin/systemd-vconsole-setup-race-fix.patch' not found in package names. Trying capabilities.
    No provider of '/home/username/bin/systemd-vconsole-setup-race-fix.patch' found.
    Resolving package dependencies...

    Nothing to do.
    @Lord_Valarian: please, please stop this. The main reason for your borked system(s) is right above in the quote. There is no such thing as /home/username, no one told you to install a patch with zypper, and I could go on for a while quoting from your posts. Same goes for the numerous requests to use CODE tags, to provide output and so on. Consider this a forums team warning.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •