Results 1 to 5 of 5

Thread: Problems adding two USB printers

  1. #1

    Default Problems adding two USB printers

    I am trying to connect two USB printers to a standard LEAP 15 intallation. Plugging in each separately works fine (Brother HL2030, Canon Pixma MX320). However, when plugging in both at the same time, only the first one to be plugged in is seen. I suspect a problem with the udev rules, but coudn't figure it quite out.

    When monitoring udev events with
    Code:
    sudo udevadm control --reload-rules && sudo udevadm trigger
    I get for the first printer
    Code:
    KERNEL[1240702.054310] add      /devices/pci0000:00/0000:00:14.0/usb2/2-3/2-3.1/2-3.1:1.0/usbmisc/lp0 (usbmisc)
    KERNEL[1240702.055359] remove   /devices/parport0/ppdev0.0 (parport)
    UDEV  [1240702.062902] remove   /devices/parport0/ppdev0.0 (parport)
    UDEV  [1240702.062950] add      /devices/pci0000:00/0000:00:14.0/usb2/2-3/2-3.1/2-3.1:1.0/usbmisc/lp0 (usbmisc)
    However, the second printer does not trigger any usbmisc/lp* events:
    Code:
    KERNEL[1241138.367378] add      /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2.2 (usb)
    UDEV  [1241138.372138] add      /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2.2 (usb)
    Thank you very much in advance for any help.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,771
    Blog Entries
    14

    Default Re: Problems adding two USB printers

    What does
    Code:
    dmesg | grep usb | tail -30
    give, immediately after plugging in both printers.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,274
    Blog Entries
    1

    Default Re: Problems adding two USB printers

    Further to Knurpht's advice, can you also show us what is reported by the following commands when both printers attached?
    Code:
    sudo lpinfo -v
    and running the CUPS usb backend manually
    Code:
    /usr/lib/cups/backend/usb
    openSUSE Leap 15.0; KDE Plasma 5

  4. #4

    Default Re: Problems adding two USB printers

    After re-plugging the printers a couple of times, the problem resolved itself. I could unfortunately not identify any pattern, as far as I remember the current usb ports used are the original ones. Thanks for the input.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,274
    Blog Entries
    1

    Default Re: Problems adding two USB printers

    Quote Originally Posted by dodydog View Post
    After re-plugging the printers a couple of times, the problem resolved itself. I could unfortunately not identify any pattern, as far as I remember the current usb ports used are the original ones. Thanks for the input.
    It will remain a mystery then, but good to know that it's working as expected again. Thanks for the coming back with an update.
    openSUSE Leap 15.0; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •