Results 1 to 6 of 6

Thread: Yast update failure for ghostscript

  1. #1

    Default Yast update failure for ghostscript

    Hi,
    on 43.2, Yast automatic or manual update of ghostscript-devel package from version 9.15 to 9.25 (marked as a security update) fails with
    Code:
    libspectre-devel-0.2.7-16.1.x86_64 requires ghostscript-devel = 9.15, but this requirement cannot be provided
    Is there an inconsistency in packages?
    What to do?
    Thanks for any help.
    Best regards

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,065

    Default AW: Yast update failure for ghostscript

    Please post:
    Code:
    zypper lr -d
    Also
    Code:
    zypper up
    Code:
    zypper se -s ghostscript spectre

  3. #3

    Default Re: Yast update failure for ghostscript

    here are the responses:

    Code:
    /home/xx> zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                            | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+----------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | http-opensuse-guide.org-3a0759ba | libdvdcss repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                       |        
     2 | http-packman.inode.at-b91fda63   | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                         |        
     3 | openSUSE-Leap-42.3-0             | openSUSE-Leap-42.3-0                    | Yes     | (r ) Yes  | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ-852S_HE18_097566   |        
     4 | repo-debug                       | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |        
     5 | repo-debug-non-oss               | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/  |        
     6 | repo-debug-update                | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                 |        
     7 | repo-debug-update-non-oss        | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/             |        
     8 | repo-non-oss                     | openSUSE-Leap-42.3-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/        |        
     9 | repo-oss                         | openSUSE-Leap-42.3-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |        
    10 | repo-source                      | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |        
    11 | repo-source-non-oss              | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |        
    12 | repo-update                      | openSUSE-Leap-42.3-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                       |        
    13 | repo-update-non-oss              | openSUSE-Leap-42.3-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/
    as root:

    Code:
    # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following item is locked and will not be changed by any action:
     Installed:
      unison
    
    The following 25 package updates will NOT be installed:
      ghostscript ghostscript-devel ghostscript-x11 gstreamer-plugins-bad-lang
      gstreamer-plugins-ugly-lang k3b k3b-lang libgstadaptivedemux-1_0-0
      libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
      libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
      libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
      libgstwayland-1_0-0 libmjpegutils-2_0-0 libquicktime0 libsox3 libxine2
      libxine2-pulse mjpegtools sox
    
    The following 7 NEW packages are going to be installed:
      akonadi-search akonadi-search-lang libirrecord0 liblirc0 liblirc_driver0
      lirc-config lirc-core
    
    The following 3 packages are going to be REMOVED:
      baloo-pim lirc lirc-remotes
    
    7 new packages to install, 3 to remove.
    Overall download size: 0 B. Already cached: 867.3 KiB. After the operation,
    additional 338.8 KiB will be used.
    Continue? [y/n/...? shows all options] (y): y
    In cache akonadi-search-17.04.2-1.1.x86_64.rpm
                                               (1/7), 151.9 KiB (601.4 KiB unpacked)
    In cache liblirc0-0.9.4c-4.1.x86_64.rpm    (2/7),  75.0 KiB (144.7 KiB unpacked)
    In cache liblirc_driver0-0.9.4c-4.1.x86_64.rpm
                                               (3/7),  51.0 KiB ( 63.6 KiB unpacked)
    In cache akonadi-search-lang-17.04.2-1.1.noarch.rpm
                                               (4/7),  31.8 KiB ( 79.1 KiB unpacked)
    In cache libirrecord0-0.9.4c-4.1.x86_64.rpm
                                               (5/7),  39.3 KiB ( 38.5 KiB unpacked)
    In cache lirc-core-0.9.4c-4.1.x86_64.rpm   (6/7), 439.8 KiB (  1.7 MiB unpacked)
    In cache lirc-config-0.9.4c-4.1.noarch.rpm (7/7),  78.5 KiB (323.3 KiB unpacked)
    Checking for file conflicts: .............................................[done]
    (1/7) Installing: akonadi-search-17.04.2-1.1.x86_64 ......................[done]
    (2/7) Installing: liblirc0-0.9.4c-4.1.x86_64 .............................[done]
    (3/7) Installing: liblirc_driver0-0.9.4c-4.1.x86_64 ......................[done]
    (4/7) Installing: akonadi-search-lang-17.04.2-1.1.noarch .................[done]
    (5/7) Installing: libirrecord0-0.9.4c-4.1.x86_64 .........................[done]
    (6/7) Installing: lirc-core-0.9.4c-4.1.x86_64 ............................[done]
    (7/7) Installing: lirc-config-0.9.4c-4.1.noarch ..........................[done]
    seems to me that some new packages have arrived in the meantime.

    as root:

    Code:
    # zypper se -s ghostscript spectre
    Loading repository data...
    Reading installed packages...
    
    S  | Name                         | Type       | Version        | Arch   | Repository
    ---+------------------------------+------------+----------------+--------+--------------------------
    i+ | OpenPrintingPPDs-ghostscript | package    | 4.0.0.2-6.1    | noarch | openSUSE-Leap-42.3-Oss
    i+ | OpenPrintingPPDs-ghostscript | package    | 4.0.0.2-6.1    | noarch | openSUSE-Leap-42.3-0
    i+ | cups-filters-ghostscript     | package    | 1.8.2-4.2.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | cups-filters-ghostscript     | package    | 1.8.2-3.1      | x86_64 | openSUSE-Leap-42.3-Oss
    v  | cups-filters-ghostscript     | package    | 1.8.2-3.1      | x86_64 | openSUSE-Leap-42.3-0
    v  | ghostscript                  | package    | 9.25-14.9.1    | x86_64 | openSUSE-Leap-42.3-Update
    i+ | ghostscript                  | package    | 9.15-14.6.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript                  | package    | 9.15-14.3.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript                  | package    | 9.15-13.14     | x86_64 | openSUSE-Leap-42.3-Oss
    v  | ghostscript                  | package    | 9.15-13.14     | x86_64 | openSUSE-Leap-42.3-0
       | ghostscript                  | srcpackage | 9.25-14.9.1    | noarch | openSUSE-Leap-42.3-Update
       | ghostscript                  | srcpackage | 9.15-14.6.1    | noarch | openSUSE-Leap-42.3-Update
       | ghostscript                  | srcpackage | 9.15-14.3.1    | noarch | openSUSE-Leap-42.3-Update
       | ghostscript-cjk              | package    | 20050315-171.1 | noarch | openSUSE-Leap-42.3-Oss
       | ghostscript-cjk              | package    | 20050315-171.1 | noarch | openSUSE-Leap-42.3-0
    v  | ghostscript-devel            | package    | 9.25-14.9.1    | x86_64 | openSUSE-Leap-42.3-Update
    i+ | ghostscript-devel            | package    | 9.15-14.6.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript-devel            | package    | 9.15-14.3.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript-devel            | package    | 9.15-13.14     | x86_64 | openSUSE-Leap-42.3-Oss
    v  | ghostscript-devel            | package    | 9.15-13.14     | x86_64 | openSUSE-Leap-42.3-0
       | ghostscript-fonts            | package    | 9.06-10.13     | noarch | openSUSE-Leap-42.3-Oss
       | ghostscript-fonts            | package    | 9.06-10.13     | noarch | openSUSE-Leap-42.3-0
       | ghostscript-fonts-grops      | package    | 1.22.2-9.21    | noarch | openSUSE-Leap-42.3-Oss
       | ghostscript-fonts-grops      | package    | 1.22.2-9.21    | noarch | openSUSE-Leap-42.3-0
    i+ | ghostscript-fonts-other      | package    | 9.06-10.13     | noarch | openSUSE-Leap-42.3-Oss
    i+ | ghostscript-fonts-other      | package    | 9.06-10.13     | noarch | openSUSE-Leap-42.3-0
    i+ | ghostscript-fonts-std        | package    | 9.06-10.13     | noarch | openSUSE-Leap-42.3-Oss
    i+ | ghostscript-fonts-std        | package    | 9.06-10.13     | noarch | openSUSE-Leap-42.3-0
       | ghostscript-mini             | srcpackage | 9.25-14.9.1    | noarch | openSUSE-Leap-42.3-Update
       | ghostscript-mini             | srcpackage | 9.15-14.6.1    | noarch | openSUSE-Leap-42.3-Update
       | ghostscript-mini             | srcpackage | 9.15-14.3.1    | noarch | openSUSE-Leap-42.3-Update
       | ghostscript-mini             | package    | 9.25-14.9.1    | x86_64 | openSUSE-Leap-42.3-Update
       | ghostscript-mini             | package    | 9.15-14.6.1    | x86_64 | openSUSE-Leap-42.3-Update
       | ghostscript-mini             | package    | 9.15-14.3.1    | x86_64 | openSUSE-Leap-42.3-Update
       | ghostscript-mini-devel       | package    | 9.25-14.9.1    | x86_64 | openSUSE-Leap-42.3-Update
       | ghostscript-mini-devel       | package    | 9.15-14.6.1    | x86_64 | openSUSE-Leap-42.3-Update
       | ghostscript-mini-devel       | package    | 9.15-14.3.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript-x11              | package    | 9.25-14.9.1    | x86_64 | openSUSE-Leap-42.3-Update
    i+ | ghostscript-x11              | package    | 9.15-14.6.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript-x11              | package    | 9.15-14.3.1    | x86_64 | openSUSE-Leap-42.3-Update
    v  | ghostscript-x11              | package    | 9.15-13.14     | x86_64 | openSUSE-Leap-42.3-Oss
    v  | ghostscript-x11              | package    | 9.15-13.14     | x86_64 | openSUSE-Leap-42.3-0
    i+ | libspectre-devel             | package    | 0.2.7-16.1     | x86_64 | openSUSE-Leap-42.3-Oss
    i+ | libspectre-devel             | package    | 0.2.7-16.1     | x86_64 | openSUSE-Leap-42.3-0
    i+ | libspectre1                  | package    | 0.2.7-16.1     | x86_64 | openSUSE-Leap-42.3-Oss
    i+ | libspectre1                  | package    | 0.2.7-16.1     | x86_64 | openSUSE-Leap-42.3-0

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,065

    Default AW: Yast update failure for ghostscript

    Same error here in 42.3.

    I think its an error in the spec-file to build libspectre.

    Maybe you can delete the -devel packages?
    You need them only for developing.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,065

    Default AW: Yast update failure for ghostscript


  6. #6

    Default Re: Yast update failure for ghostscript

    thanks - so it seems there are two options: deleting the devel packages or waiting for the bug to be resolved in the repositories, right?
    Once the latter is achieved, it might be worthwhile to post the result here.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •