Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

  1. #1

    Default KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    I normally use the KDE5/Plasma desktop, along with ALSA only for audio. However, I have an application which only has support for pulseaudio, but I am having a profile problem, which is preventing pulseaudio from running correctly. When I start pulseaudio, the daemon appears to start and run correctly, however there is no audio on my primary sound card, which is a Creative Sound Blaster X-Fi Titanium (emu20K2). The sound card is not even detected by pulse in KDE5, unless pulseaudio has autospawn enabled at boot. Otherwise, only my secondary card, an Nvidia HDMI connection is detected. The audio works properly with the Nvdia HDMI on my TV. The Creative X-Fi works properly with ALSA in all situations, and pulseaudio works properly with any other desktop environment, except KDE. After I discovered that pulseaudio works correctly in other desktop environments, I tried creating a new user profile just to test with, and that too also works correctly with pulseaudio in KDE5. So there must be a damaged config file or a corrupt file stored somewhere in my profile, but I have been unable to locate the problem file. The only files I have been able to locate with any pulseaudio data in it, has been the pulse folder itself, obviously, which is not the problem, and the kmixrc files, which also don't seem to be the problem. I'd really like to locate the problem files and correct the issue, rather than having to wipe out my entire KDE profile, and redo all of my settings. So if anyone knows where KDE5 would store the relevant information, or if someone knows how I might correct the issue, without wiping my profile, I would greatly appreciate the help.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,220
    Blog Entries
    1

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    The only files I have been able to locate with any pulseaudio data in it, has been the pulse folder itself, obviously, which is not the problem, and the kmixrc files, which also don't seem to be the problem.
    I assume that you meant the user's ~/.config/pulse/ directory?
    openSUSE Leap 15.1; KDE Plasma 5

  3. #3

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by deano_ferrari View Post
    I assume that you meant the user's ~/.config/pulse/ directory?
    Correct, sorry if it was unclear. I'm certain that the problem is not the ~/.config/pulse/ directory though, because I've deleted all of the auto-generated files in there, and even renamed the folder, to have a new one created, just for good measure. Plus, as I mentioned, pulseaudio is working correctly in every other desktop environment. I've checked it in Gnome, TDE, LXQt and Mate, and it works properly in all of them, and it's even working fine in KDE5 with a different user profile. So it's definitely something specific in my KDE5/Plasma user profile.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,220
    Blog Entries
    1

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by drakkar123 View Post
    Correct, sorry if it was unclear. I'm certain that the problem is not the ~/.config/pulse/ directory though, because I've deleted all of the auto-generated files in there, and even renamed the folder, to have a new one created, just for good measure.
    Well, that's what I was clarifying.

    Plus, as I mentioned, pulseaudio is working correctly in every other desktop environment. I've checked it in Gnome, TDE, LXQt and Mate, and it works properly in all of them, and it's even working fine in KDE5 with a different user profile. So it's definitely something specific in my KDE5/Plasma user profile.
    Do you have the KDE desktop configured to restore the previous session, or does it start with an empty session for this particular user?

    System Settings > Startup and Shutdown > Desktop Session
    Last edited by deano_ferrari; 02-Oct-2018 at 16:50.
    openSUSE Leap 15.1; KDE Plasma 5

  5. #5

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by deano_ferrari View Post
    Well, that's what I was clarifying.


    Do you have the KDE desktop configured to restore the previous session, or does it start with an empty session for this particular user?

    System Settings > Startup and Shutdown > Desktop Session
    It's set to restore the previous session. I'm sure if I set it to a blank session, the problem would be gone, but then so would all of my other KDE profile settings as well, which is what I'm hoping to avoid. I may end up having to do that, but I'd rather do that as a last resort. If I can figure out where KDE stores any pulseaudio related information in the profile, I should be able to either, edit or delete, just the relevant files and save the rest of my profile settings. That's what I'm hoping to be able to do anyway. I just haven't been able to find any KDE/Plasma specific files, related to pulse or audio, except for the previously mentioned directories/files, which I've already been able to rule out. But I know KDE must be storing the data somewhere, I just can't find it. My guess is that it's probably a problem with some kind of broken restore data related to either the Audio Volume Plasma widget or perhaps Phonon, but that's just my guess, and I haven't been able to locate any files related to either.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,220
    Blog Entries
    1

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by drakkar123 View Post
    It's set to restore the previous session. I'm sure if I set it to a blank session, the problem would be gone, but then so would all of my other KDE profile settings as well, which is what I'm hoping to avoid.
    Not true. Your user-specific settings will remain - just session-related activities/states will gone. Anyway, session-related information is saved in ~/.config/ksmserverrc.
    openSUSE Leap 15.1; KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,220
    Blog Entries
    1

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    More specifically session management in ~/.config/ksmserverrc, and saved states in the ~/.config/session/ directory.
    openSUSE Leap 15.1; KDE Plasma 5

  8. #8

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by deano_ferrari View Post
    Not true. Your user-specific settings will remain - just session-related activities/states will gone. Anyway, session-related information is saved in ~/.config/ksmserverrc.
    Okay, well that's actually very helpful to know. I've only started with a blank session once, and it was probably at least 10 years ago now, and I only remember it removing everything, even down the system tray and all. So I've been hesitant to try it again. But as long as it retains all of the settings, then it's probably the best option. Thank you for the info.

  9. #9

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by deano_ferrari View Post
    More specifically session management in ~/.config/ksmserverrc, and saved states in the ~/.config/session/ directory.
    I renamed both the ~/.config/session folder and ~/.config/ksmserverrc, then changed the settings to start with a blank session. Changing it to start with a blank session, definitely behaved differently, than the last time I tried it in an old version of KDE, which I was rather relieved about. However, after making the changes and rebooting, pulse is still not working on the primary sound card. Also, the card was no longer even detected by pulse after the reboot, even with the pulseaudio autospawn setting enabled, as it was previously. After looking into it further, I discovered that unless KMix is running at startup, along with the pulse autospawn enabled, the X-Fi is not detected by Pulse. Seems a little odd to me, since if I am not mistaken, KMix doesn't even normally run in KDE5 anymore by default. The same problem with detection occurs if I try to start pulseaudio manually in a console. This problem doesn't occur in any other desktop environment either, so I'm guessing it's probably directly related to the source of the problem.

    Either way, even when the card is properly detected, and everything looks as though it's running correctly, there is still no audio through pulse on the X-Fi in KDE. The only problem I can find in the pulseaudio log, is when I try playing a sound file using VLC, I see that it is corking and uncorking continuously, during the attempted playback, like something else is locking the card up, but there are no other running streams, ALSA works fine, and of course pulseaudio works fine in every other desktop environment. If you have any other suggestions, I would greatly appreciate any help you are able to provide.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,220
    Blog Entries
    1

    Default Re: KDE5-Plasma User Profile Problem Preventing Sound with Pulseaudio

    Quote Originally Posted by drakkar123 View Post
    After looking into it further, I discovered that unless KMix is running at startup, along with the pulse autospawn enabled, the X-Fi is not detected by Pulse. Seems a little odd to me, since if I am not mistaken, KMix doesn't even normally run in KDE5 anymore by default.
    Plasma 5 uses the 'Audio Volume' applet by default. Does that not display on your dektop in the system tray at login?

    Do you have the 'KMixD Mixer Service' enabled and running in KDE 'Background Services'?
    openSUSE Leap 15.1; KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •