Results 1 to 7 of 7

Thread: Repos cannot be accessed via HTTPS (since today)

  1. #1

    Exclamation Repos cannot be accessed via HTTPS (since today)

    Hi,

    Trying a 'zypper up' today gives me:

    Code:
    Download (curl) error for 'https://download.opensuse.org/distribution/leap/15.0/repo/non-oss/repodata/repomd.xml':
    Error code: Curl error 35
    Error message: error:1408F10B:SSL routines:ssl3_get_record:wrong version number
    
    Abort, retry, ignore? [a/r/i/...? shows all options] (a):
    Also opening the URL in a browser gives:
    This site can’t provide a secure connection

    download.opensuse.org sent an invalid response.
    ERR_SSL_PROTOCOL_ERROR
    So far I have always been able to access openSUSE repos via HTTPS. Should that be reported somewhere?

    FWIW: I wonder why by default the repos are plain HTTP.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: Repos cannot be accessed via HTTPS (since today)

    Henk van Velden

  3. #3

    Default Re: Repos cannot be accessed via HTTPS (since today)

    Thanks Henk.

    So - partial outage.

    What about the second question? Why are repos HTTP by default (unless one explicitly changes them to HTTPS)?

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Repos cannot be accessed via HTTPS (since today)

    Quote Originally Posted by hcvv View Post
    according to the status page there is a redirect workaround in place.
    However, as of today after the "redirect" was put in place I'm still getting an array of errors

    Download (curl) error for 'http://download.opensuse.org/repositories/home:/osmc/openSUSE_Leap_15.0/repodata/repomd.xml':
    Error code: Curl error 56
    Error message: Recv failure: Connection reset by peer
    Download (curl) error for 'https://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.0/repodata/repomd.xml':
    Error code: Curl error 35
    Error message: error:1408F10B:SSL routines:ssl3_get_record:wrong version number
    Timeout exceeded when accessing 'http://download.opensuse.org/update/leap/15.0/non-oss/repodata/repomd.xml'.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: Repos cannot be accessed via HTTPS (since today)

    Everything seems to work again. So please text again and then come back if you still have a problem.
    Henk van Velden

  6. #6

    Default Re: Repos cannot be accessed via HTTPS (since today)

    Quote Originally Posted by hcvv View Post
    Everything seems to work again. So please text again and then come back if you still have a problem.
    Thanks. Yes, it does.

    I still hope someone can clarify the other question.

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Repos cannot be accessed via HTTPS (since today)

    yes. . .. everything working again without errors

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •