Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: boot on Apollo Lake

  1. #1
    Join Date
    Sep 2018
    Location
    Italy
    Posts
    11

    Default boot on Apollo Lake

    Hi! Is it possible to install opensuse leap 15 on apollo lake latops?

    I tried to disable secure boot and fast boot in boot menu (aptio setup utility) but nothing, opensuse installation program doesn't start... it appears only a black screen and a white cursor.

    Ubuntu and Manjaro can be booted, but I would not change distro.

    Thanks

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    700

    Default Re: boot on Apollo Lake

    It certainly should be. What model is the laptop? Is it only Intel, or is there also NVidia or AMD gfx, aka Optimus, in need of special installation instructions (Bumblebee)? The black screen is often avoided so that installation can proceed by using the E key at the openSUSE media boot menu and appending "nomodeset" to the line containing "splash=silent quiet".
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,177

    Default Re: boot on Apollo Lake

    Do you get a startup menu? how did you copy/burn to the install media?

    For openSUSE you do not want to modify the iso image at all which can happen with some of the Linux USB install boot helpers. You want a simple binary copy of the ISO to the device (not a partition on the device)

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    1,871

    Question Re: boot on Apollo Lake

    Quote Originally Posted by svenzo View Post
    I tried to disable secure boot and fast boot in boot menu
    Is there a UEFI Boot Mode option for "UEFI with CSM" (Compatibility Support Module) in the UEFI menu?
    • If there is, enable it …
    • And, after doing that, take a look to see if the boot medium (USB?) can be set to "Legacy" mode …

  5. #5
    Join Date
    Sep 2018
    Location
    Italy
    Posts
    11

    Default Re: boot on Apollo Lake

    Sorry, I was wrong... the right soc is Gemini Lake, not Apollo Lake!

    What model is the laptop?
    E-book pro by Microtech with Ubuntu 18.04 LTS (CPU Intel pentium silver n5000, gpu intel hd graphics 605, ram 8gb, 32 gb eMMC + ssd m2 wd green 240gb. More spec. at
    HTML Code:
    https://microtech.store/e-book-pro-n5000-specifiche/e-book
    The black screen is often avoided so that installation can proceed by using the E key at the openSUSE media boot menu and appending "nomodeset" to the line containing "splash=silent quiet"
    Boot from USB doesn't arrive to openSUSE media boot menu

    Do you get a startup menu?
    No, I don't.

    how did you copy/burn to the install media?
    Suse imagewriter

    Is there a UEFI Boot Mode option for "UEFI with CSM" (Compatibility Support Module) in the UEFI menu?
    There isn't. (American Megatrends Aptio setup utility 2018)

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    1,871

    Question Re: boot on Apollo Lake

    Linux Kernel support for the Intel Gemini Lake chips became available with version 4.11 …
    Therefore, with Leap 15.1 (Kernel version 4.12) it could, possibly, "work out of the box", once the USB has booted …
    Are you absolutely sure that, there's nothing, anywhere, in the "Boot" section of the Aptio setup related to the USB ports?
    The Laptop looks very nice -- aluminium instead of plastic case …

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    700

    Default Re: boot on Apollo Lake

    According to https://en.wikipedia.org/wiki/List_o...ocessing_units, Gemini preceded Kaby, on which I have two 42.3s and two 15.0s running OOTB, one on a Gigabyte motherboard, the other Asus. So apparently Gemini & Kaby must have been backported to openSUSE's 4.4.x kernel and OP shouldn't need wait on 15.1 (which in alpha is already on the mirrors).
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    18,377
    Blog Entries
    14

    Default Re: boot on Apollo Lake

    If you don't even hit a startup menu ( GRUB ), there's either something wrong with the install medium, or something wrong in the UEFI settings. Also, look for USB Legacy mode in the BIOS.
    Another suggestion: download a Leap 15 live image, and use 'dd' or Etcher on Ubuntu to create the install disk. My bet would be a failing install stick.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Sep 2018
    Location
    Italy
    Posts
    11

    Default Re: boot on Apollo Lake

    Quote Originally Posted by Knurpht View Post
    If you don't even hit a startup menu ( GRUB ), there's either something wrong with the install medium, or something wrong in the UEFI settings. Also, look for USB Legacy mode in the BIOS.
    Another suggestion: download a Leap 15 live image, and use 'dd' or Etcher on Ubuntu to create the install disk. My bet would be a failing install stick.
    I tried, but nothing changes.

    I was reading this https://forums.opensuse.org/showthread.php/532950-Booting-to-LEAP-ISO-Hangs-at-Black-Screen/page2

    it seems the same problem that I have. In the last post a bug in grub is suggested as cause of the issue, but I don't know how to apply the fix suggested.

  10. #10
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    700

    Default Re: boot on Apollo Lake

    I have an Asus Kaby Lake (1/2 generation newer than Gemini Lake) motherboard with text mode Aptio AMI BIOS dated 2018-05-11. F8 at POST brings up a boot device selection screen. If yours is like mine I suspect in trying to boot your stick that you need to be able to see at the F8 screen a description of your stick that includes "UEFI" and that if selected your stick should boot into the GUI installation screen. This may require first going into BIOS setup and changing "Boot Option Priorities" and/or "UEFI Hard Drive Priorities" and/or making a different "Boot Override" selection.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •