Results 1 to 4 of 4

Thread: subversion can not find libldap-2.4.so.2

  1. #1

    Default subversion can not find libldap-2.4.so.2

    I have 3 machines all running LEAP 15. But on one, subversion/svn does not work

    > svn: error while loading shared libraries: libldap-2.4.so.2: cannot open shared object file: No such file or directory

    > ls -l /usr/lib/libldap*

    gives

    /usr/lib/libldap_r-2.4.so.2 -> libldap_r-2.4.so.2.10.9
    /usr/lib/libldap_r-2.4.so.2.10.9

    thanks for any help
    Ken

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,296
    Blog Entries
    2

    Default Re: subversion can not find libldap-2.4.so.2

    Recommend creating a symlink so that your app can identify the library by the name it expects...

    https://en.opensuse.org/User:Tsu2/Ma...ken_Stuff_Work

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: subversion can not find libldap-2.4.so.2

    Quote Originally Posted by kpdere2968 View Post
    I have 3 machines all running LEAP 15. But on one, subversion/svn does not work

    > svn: error while loading shared libraries: libldap-2.4.so.2: cannot open shared object file: No such file or directory

    > ls -l /usr/lib/libldap*

    gives

    /usr/lib/libldap_r-2.4.so.2 -> libldap_r-2.4.so.2.10.9
    /usr/lib/libldap_r-2.4.so.2.10.9

    thanks for any help
    Ken
    that's a 32 bit library svn should be using the 64 bit /usr/lib64/libldap_r-2.4.so.2.10.9 see if you have that one
    I'd say check your repositories
    Code:
    zypper lr -d
    see where svn is from
    Code:
    zypper se -si svn
    and see if your dependencies are OK
    Code:
    zypper verify

  4. #4

    Default Re: subversion can not find libldap-2.4.so.2

    Quote Originally Posted by I_A View Post
    that's a 32 bit library svn should be using the 64 bit /usr/lib64/libldap_r-2.4.so.2.10.9 see if you have that one
    I'd say check your repositories
    Code:
    zypper lr -d
    see where svn is from
    Code:
    zypper se -si svn
    and see if your dependencies are OK
    Code:
    zypper verify
    did all the zypper commands
    the verify command removed and replaced a lot of things but svn is now working !
    many thanks

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •