Quote Originally Posted by mrmazda View Post
With the info provided it's hard to understand just what happened when, and the current state of things. If you can boot TW, get the script from https://github.com/arvidjaar/bootinfoscript and run it in a vtty or Konsole or XTerm, then do
Code:
susepaste -n Medin25 -e 40320 RESULTS.TXT
so we can see what you have where and then suggest how to proceed. You may have to install susepaste first with zypper or yast. Also give us the exact model of your laptop so we can have an idea of its specifications. If you can install inxi with zypper or yast and provide output from
Code:
inxi -bGxx
run from Konsole or an XTerm it would be even better. Alternatively, output from inxi can be redirected to a file and uploaded with susepaste just like with RESULTS.TXT.
Maybe I wasn't really clear enough so I'll put it like this:

Problem 1:

1. Installation process of Tumbleweed
2. Adding another EFI boot partition (as required) to the system even though already one exists as default (probably for windows 10)
3. After installation openSUSE worked but Windows kept crashing and I couldn't get into it or boot it at all which I already mentioned
4. Tried everything to fix it and thought that maybe Windows switched up some boot directories so that it couldn't find it's way to grub2. Maybe it has something to to with Legacy mode or UEFI, even though I tried all of it it kept failing.
5. Had to reinstall openSUSE and Windows
6. Installed Windows just fine but the system reserved of the previous one is still there so the crashed volume could still be accessed even though it can't boot
7. I'm in a state where I want to install again Tumbleweed but don't know how to deal with the EFI boot partition which Linux requires and feel confused as a newbie for Linux systems and openSUSE

Problem 2:

My friend in the other hand installed it and it worked fine without needing an EFI boot partition, but he has problems with the software updates. It has to do something with the keybase that can't let the system provide the right tools to download files that need to be provided for the repositories from like multimedia and packman. He can't download basic things like vlc because it's missing it's codecs and files required for it to be installed.
He refreshed the repositories, tried everything from the forums and sites, enabled all repositories except for the Leap 15.1 one that for some reason makes the whole update part not work at all. Strangely enough it says that everything is up to date in the console from the repositories. Maybe he is looking for the wrong thing, or those things are not that connected, but he tried everything and nothing worked.

Thank you for the replies you gave me. Any other advice, help or solution to these problems?