Results 1 to 8 of 8

Thread: boot process waiting for removable HDD device

  1. #1

    Default boot process waiting for removable HDD device

    Hi,
    I am using Leap 15.0 with a separate boot partition (sda1) as well as root, home and swap filesystem inside an encrypted LVM (sda2).
    Now, recently, I have formatted an external HDD with Yast. It had NTFS in the original state, but I changed the filesystem to ext4 (encrypted). If I connect this HDD I can access it fine (store data, read etc.). It appears as sdb1 after plugging in and typing the passphrase. After use, I can unmount, and it disappears.
    However, during the boot process (when, of course, the removable HDD is not connected) "a start job is running ..." that is looking for the LUKS device associated with the removable HDD and waiting for 1:30 min. This is annoying because the waiting period is longer than the boot process itself (I feel).
    When I changed the formatting options in Yast, I also set the mounting options to "Do not mount device", but when applying this, I see as message
    Code:
    The system might not be able to boot: 
    
     
    
    • Missing device with size equal or bigger than 2 MiB and partition id bios_boot
    Do you want to continue?
    Well, there is the sda1 boot partition that has been used in the boot process all the time before the external HDD was formatted, so I figured that I wanted to continue. However, the "Do not mount device" does not seem to be persistent, because after rebooting (and connecting the HDD), the mounting options again show "Mount device" and a mount point.
    Can anyone help me to find the reason for this behavior and a way to achieve the goal to eliminate waiting for the external, removable HDD during the boot process?
    Thank you.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: boot process waiting for removable HDD device

    There are too many possibilities here.

    I will make a wild guess. Try the command:
    Code:
    grep resume /etc/default/grub
    That might need root (depends on the permissions for "/etc/default/grub".

    Does the output of that command contain a UUID which matches what you see in the "waiting for" message?

    If not, I'll try some other guesses. But this problem -- picking the wrong swap partition for the "resume=" was an issue with Leap 15.0 (but fixed for Leap 15.1).

    If my wild guess is right, then you need to change that UUID parameter to the UUID of your swap partition/volume. You can actually make that change with Yast bootloader, where you go to the kernel parameter tab.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,667

    Default Re: boot process waiting for removable HDD device

    Please look at the file /etc/fstab
    If you see a line referring to your removable HDD, try to delete it and reboot.
    Or you might open a terminal and post here between CODE tags (the # button above the editing line) the result of:
    Code:
    cat /etc/fstab
    EDIT: Well, try nrickert's suggestion first
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  4. #4

    Default Re: boot process waiting for removable HDD device

    Quote Originally Posted by nrickert View Post
    There are too many possibilities here.

    I will make a wild guess. Try the command:
    Code:
    grep resume /etc/default/grub
    That might need root (depends on the permissions for "/etc/default/grub".

    Does the output of that command contain a UUID which matches what you see in the "waiting for" message?

    If not, I'll try some other guesses. But this problem -- picking the wrong swap partition for the "resume=" was an issue with Leap 15.0 (but fixed for Leap 15.1).

    If my wild guess is right, then you need to change that UUID parameter to the UUID of your swap partition/volume. You can actually make that change with Yast bootloader, where you go to the kernel parameter tab.
    Yes, I am aware that we might have many possibilities here. I'll follow the suggestions already been made to narrow down the problem. Thanks for responding so quickly.
    So, first as a response to nrickert's mail:
    The resume= parameter in /etc/default/grub refers to a different UUID, in fact exactly that one that is reported by the command
    Code:
    lsblk -o name,uuid,mountpoint
    for swap. Thus, this can not be the reason.
    Other guesses that can be tested?

  5. #5

    Default Re: boot process waiting for removable HDD device

    Quote Originally Posted by OrsoBruno View Post
    Please look at the file /etc/fstab
    If you see a line referring to your removable HDD, try to delete it and reboot.
    Or you might open a terminal and post here between CODE tags (the # button above the editing line) the result of:
    Code:
    cat /etc/fstab
    EDIT: Well, try nrickert's suggestion first
    Well, here is the contents of /etc/fstab:
    Code:
    /dev/system/root                           /      ext4  acl,user_xattr  0  1
    /dev/system/home                           /home  ext4  defaults        0  2
    UUID=e920a247-b5d0-4199-a405-b66d18258c0e  /boot  ext4  defaults        0  2
    The uuid shown here for /boot is exactly that for the separate boot partition /dev/sda1. So, no obvious (at least for me) problem here.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: boot process waiting for removable HDD device

    Quote Originally Posted by BerndSpeiser View Post
    Other guesses that can be tested?
    The next one I would suggest checking, is "/etc/crypttab". See if there is an entry there for a partition on the external drive. If there is, mark it as "noauto".

    Each line is supposed to have 4 columns. Recently the installer has been using only the first two columns. If you have to change anything in that file, then I recommend that you make it 4 columns for each entry. You can use "none none" for the third and fourth column if you don't have anything else to put there.

    If there's an entry for a partition on your external drive, then put "noauto" in the fourth column for that entry. And, if you do make any changes to that file, run
    Code:
    mkinitrd
    to appropriately update the "initrd" files.
    openSUSE Leap 15.1; KDE Plasma 5;

  7. #7

    Default Re: boot process waiting for removable HDD device

    Quote Originally Posted by nrickert View Post
    The next one I would suggest checking, is "/etc/crypttab". See if there is an entry there for a partition on the external drive. If there is, mark it as "noauto".

    Each line is supposed to have 4 columns. Recently the installer has been using only the first two columns. If you have to change anything in that file, then I recommend that you make it 4 columns for each entry. You can use "none none" for the third and fourth column if you don't have anything else to put there.

    If there's an entry for a partition on your external drive, then put "noauto" in the fourth column for that entry. And, if you do make any changes to that file, run
    Code:
    mkinitrd
    to appropriately update the "initrd" files.
    OK, that did the trick! In fact /etc/crypttab is the only file in /etc that contains the uuid of the encrypted device. /etc/crypttab now looks like this
    Code:
    cr-auto-1  /dev/sda2 none none
    cr_usb-WD_Elements_25A2_575832314141383035363331-0:0-part1  UUID=6f56ca7d-ae2d-4165-abbb-ed34369ff7c3 none noauto
    where the first "none" means that no password file is supplied, and the passphrase has to be given after the device is plugged into the USB connection and before it can be accessed. That is exactly what I expect.

    Thanks! But having done that: do I have to repeat this edit of /etc/crypttab and recreating the initrd file once a new kernel version is installed or is the change persistent?

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,193
    Blog Entries
    3

    Default Re: boot process waiting for removable HDD device

    Quote Originally Posted by BerndSpeiser View Post
    Thanks! But having done that: do I have to repeat this edit of /etc/crypttab and recreating the initrd file once a new kernel version is installed or is the change persistent?
    That change should be persistent. So you should be set.
    openSUSE Leap 15.1; KDE Plasma 5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •