Page 7 of 7 FirstFirst ... 567
Results 61 to 64 of 64

Thread: How to have a custom UEFI grub menu for a multiboot system

  1. #61
    Join Date
    Jul 2018
    Location
    US
    Posts
    71

    Default Re: How to have a custom UEFI grub menu for a multiboot system

    Quote Originally Posted by mrmazda View Post
    I've been using *SUSE for far more than a decade than I can remember. I've never seen a new kernel installation not produce symlinks vmlinuz and initrd for the newest kernel and initrd.
    I realized why there were no symlinks. I've been installing all kinds of different Linux distros and when you initially install it, there are no symlinks because grub is using the direct link to the kernel.

    But, when the 1st new kernel gets installed, it creates the symlinks. That is why I got confused for a minute.

    BTW, I have both Debian Stretch and Buster installed and did not use the swap file during installation.
    When I booted up it mounted the swap partition even though it was not in the /etc/fstab file. But, I added it immediately after installation.
    Intel Core i7-4770K, NVIDIA GeForce GTX 980 Ti, Mobo: ASUSTeK, model: Z87-K, Mem: 16GB, Sound Blaster Audigy Series, HD: Western Digital 1TB SSD, OCZ 500GB SSD, 2 Toshiba 2TB SATA HD

  2. #62
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,173
    Blog Entries
    3

    Default Re: How to have a custom UEFI grub menu for a multiboot system

    Quote Originally Posted by Cavsfan View Post
    BTW, I have both Debian Stretch and Buster installed and did not use the swap file during installation.
    When I booted up it mounted the swap partition even though it was not in the /etc/fstab file.
    Yes, some systems do that. I haven't looked closely, but I assume that they create a systemd mount unit to mount swap.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #63
    Join Date
    Jul 2018
    Location
    US
    Posts
    71

    Default Re: How to have a custom UEFI grub menu for a multiboot system

    Quote Originally Posted by Cavsfan View Post
    BTW, I have both Debian Stretch and Buster installed and did not use the swap file during installation.
    When I booted up it mounted the swap partition even though it was not in the /etc/fstab file. But, I added it immediately after installation.
    Quote Originally Posted by nrickert View Post
    Yes, some systems do that. I haven't looked closely, but I assume that they create a systemd mount unit to mount swap.
    I've since deleted Stretch, way too boring and it could not find npm to install a npm-server for Visual Studio Code. Only distro I have ever seen that did that/ or didn't do that depending on how you look at it.
    I've since made Buster into Testing and Installed Mageia 7 where Stretch was. Both have working Fusion Icons so that is a +1 for me.

    Also, while I was installing one of the 2, I first tried using 50GB of another 480GB SSD for /, selecting my swap file but, did not check the format box.
    However it still wanted to format the swap, so I started over and told it not to use a swap, it still wanted to format my swap.

    So, apparently under that scenario you cannot prevent your swap file from being formatted no matter what you do. I ended up putting it on my 1TB SSD which still has lots of room and it didn't format the swap.
    Intel Core i7-4770K, NVIDIA GeForce GTX 980 Ti, Mobo: ASUSTeK, model: Z87-K, Mem: 16GB, Sound Blaster Audigy Series, HD: Western Digital 1TB SSD, OCZ 500GB SSD, 2 Toshiba 2TB SATA HD

  4. #64
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,173
    Blog Entries
    3

    Default Re: How to have a custom UEFI grub menu for a multiboot system

    Quote Originally Posted by Cavsfan View Post
    However it still wanted to format the swap, so I started over and told it not to use a swap, it still wanted to format my swap.
    I recently installed KDE Neon (which is ubuntu 18.04 + latest KDE). The installer said that it was going to format swap. And there was no way that I could tell it otherwise. But the UUID of swap did not change. So either it did not format it, or it formatted using the "-U" option (to "mkswap") to specify that the same UUID be used.
    openSUSE Leap 15.1; KDE Plasma 5;

Page 7 of 7 FirstFirst ... 567

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •