Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: How to switch off dgpu with nouveau

  1. #1
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    395

    Default How to switch off dgpu with nouveau

    Just installed leap 15 on a laptop with nvidia optimus card.

    Before, i was runing leap 42.2, and everything went smooth with nouveau.
    The machine was switching from the discrete nvidia gpu and the intel integrated gpu silently without any action from me.
    The leds on the laptop was indicating that the discrete nvidia gpu was turned off when not needed and turned on when necessary.
    It was installed without any configuration from me.
    Most important : the temperature and battery consumption was reasonable.

    And now the leds on the laptop indicate that the discrete nvidia gpu is always on.
    Disappointment : the temperature and battery consumption is high

    I tried to follow this :
    https://nouveau.freedesktop.org/wiki/Optimus/
    But it did not work.

    Initially, i realised that the intel driver for x was not installed. I had to install manually the xorg intel drivers and other things like : nf86-video-intel, and xf86-video-nv .... Don't which one is doing what...

    I also tried to install the switcheroo pakages and activated the service, but no joy.

    Yet, it still doesn't work and i am asking for your help.

    Thank you ;o)

  2. #2
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    808

    Default Re: How to switch off dgpu with nouveau

    Quote Originally Posted by Christophe_deR View Post
    Initially, i realised that the intel driver for x was not installed. I had to install manually the xorg intel drivers and other things like : nf86-video-intel, and xf86-video-nv .... Don't which one is doing what...
    Most Intel gfx users have no need for xf86-video-intel, which hasn't had an official updated release in over 3 years. Intel gfx developers apparently put most of their time into the modesetting driver incorporated in the X server, which is why xf86-video-intel is commonly not installed. xf86-video-nv is only for antique NVidia gfx, more than somewhere around 12+ years old, long before Optimus first appeared. The modesetting driver should work for both Optimus GPUs for those who don't demand non-FOSS drivers for their games.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2) & 42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,others on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,GT218 &&&&

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,524

    Default Re: How to switch off dgpu with nouveau

    Quote Originally Posted by Christophe_deR View Post
    Just installed leap 15 on a laptop with nvidia optimus card.
    How did you install? Clean install or upgrade from 42.2?

    Before, i was runing leap 42.2, and everything went smooth with nouveau.
    The machine was switching from the discrete nvidia gpu and the intel integrated gpu silently without any action from me.
    The leds on the laptop was indicating that the discrete nvidia gpu was turned off when not needed and turned on when necessary.
    It was installed without any configuration from me.
    There was no such feature on a default install of 42.2, so either somebody configured that or you are not telling the whole story...

    Most important : the temperature and battery consumption was reasonable.

    And now the leds on the laptop indicate that the discrete nvidia gpu is always on.
    Disappointment : the temperature and battery consumption is high

    I tried to follow this :
    https://nouveau.freedesktop.org/wiki/Optimus/
    But it did not work.

    Initially, i realised that the intel driver for x was not installed. I had to install manually the xorg intel drivers and other things like : nf86-video-intel, and xf86-video-nv .... Don't which one is doing what...

    I also tried to install the switcheroo pakages and activated the service, but no joy.
    On a default install of LEAP 15 on an Optimus laptop discrete graphics is normally off and can be used by issuing "DRI_PRIME=1 <command>".
    xf86-video-intel, and xf86-video-nv are not needed, vga-switcheroo is not needed, so apparently you have been looking for trouble.
    Maybe restarting from scratch with a clean install is the easiest way forward unless you can undo what you did after the default install.
    Please show the result of:
    Code:
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    and describe further your HW if possible, maybe you are using an unusual model or configuration.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  4. #4
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    395

    Default Re: How to switch off dgpu with nouveau

    Sorry for my late reply, due some accident in life.

    So.

    It is a clean install.

    No. Really. Everything was working out of the box after 42.2 clean install.

    And modesetting was installed by default did not switch off dgpu automatically on opensuse 15.0 .

  5. #5
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,524

    Default Re: How to switch off dgpu with nouveau

    Quote Originally Posted by OrsoBruno View Post
    Please show the result of:
    Code:
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    and describe further your HW if possible, maybe you are using an unusual model or configuration.
    We cannot help if we don't understand what HW you are using, please provide the above info.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  6. #6
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    395

    Default Re: How to switch off dgpu with nouveau

    Wilco .
    Didn't have time till now. Will try later in the night.

  7. #7
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    395

    Default Re: How to switch off dgpu with nouveau

    Here you are :

    Code:
    [--chris@machine 23:35:23 ~] /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
            Subsystem: CLEVO/KAPOK Computer Device [1558:1550]
            Kernel driver in use: i915
            Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 650M] [10de:0fd1] (rev a1)
            Subsystem: CLEVO/KAPOK Computer Device [1558:1550]
            Kernel driver in use: nouveau
            Kernel modules: nouveau

  8. #8
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    395

    Default Re: How to switch off dgpu with nouveau

    Quote Originally Posted by OrsoBruno View Post
    xf86-video-intel, and xf86-video-nv are not needed, vga-switcheroo is not needed, so apparently you have been looking for trouble.
    Maybe restarting from scratch with a clean install is the easiest way forward unless you can undo what you did after the default install.
    Btw, i only installed xf86-video-intel, xf86-video-nv and vga-switcheroo __after__ : i decided to install theses packages only after i noticed that it didn't work properly, whereas with 42.2 it worked out of the box, without any configuration action from me.

    With 42.2, that i still use as my every day production tool, the dgpu only turns on when needed, and stays off otherwise.
    NB : on 42.2, without the proprietary driver = no bumblebee, only nouveau... And no configuration action from me.
    And i don't understand why it doesn't work out of the box with 15.0 .

    When dgpu does not turn off automatically, laptop is too warm and battery is too short. And i can see what happens because there is a led on the laptop that shows when dgpu is on and another led that shows when the integrated gpu is used instead.
    Moreover, the fan noise confirms that something is wrong.

    So with 15.0, laptop too warm and battery too short. Why ?

  9. #9
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,524

    Default Re: How to switch off dgpu with nouveau

    Quote Originally Posted by Christophe_deR View Post
    Here you are :

    Code:
    [--chris@machine 23:35:23 ~] /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
            Subsystem: CLEVO/KAPOK Computer Device [1558:1550]
            Kernel driver in use: i915
            Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 650M] [10de:0fd1] (rev a1)
            Subsystem: CLEVO/KAPOK Computer Device [1558:1550]
            Kernel driver in use: nouveau
            Kernel modules: nouveau
    That does not look like the usual "Optimus" laptop, seems more similar to a desktop setup. Maybe there is something in the firmware (BIOS) that can control which GPU is used?
    Please provide the result of the following command:
    Code:
    journalctl -b |grep -E 'DSM|nouveau'
    Maybe you can add nouveau.runpm=1 to the kernel boot line and see if something changes? (sorry, I'm just guessing; no direct experience with Clevo and some models might have unusual "custom" configurations)
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  10. #10
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    395

    Default Re: How to switch off dgpu with nouveau

    It __is__ a laptop.

    I will give the results of your request asap

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •