Results 1 to 6 of 6

Thread: Multiple problems with MTP

  1. #1
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    275

    Question Multiple problems with MTP

    Hello,
    I have multiple problems with Leap 15.0 and MTP. In Leap 42.3 I had zero problems and it was working perfectly fine.
    Now, when I plug any Android phone/tablet (from 5.0 to 7.1) I cannot open Dolphin from Device Notifier.
    I always get "The process for the mtp protocol died unexpectedly." error message
    If I open Dolphin, 8/10 times I get this message. Sometimes, I manage to get it working, but I haven't see any specific pattern.

    Also, on some of my phones/tablets I get a segFault when I try to connect to it via the "Android Phone" link in Devices, like this one:
    Code:
    Sep 13 19:01:15 peter.home kernel: kioclient5[32332]: segfault at 55989701e8c0 ip 000055989701e8c0 sp 00007fff16cc4928 error 15
    It started being very annoying not being able to access file files on the phones!

    So, any idea how to 1st debug it, 2nd fix it?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,469
    Blog Entries
    2

    Default Re: Multiple problems with MTP

    Have you enabled "Developer Tools" and any other related options in your Android device settings (options will vary depending on Android version)?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: Multiple problems with MTP

    so, some tips to try:
    - unlock the phone/tablet when connecting (mine wont work when locked)
    - press F5 (refresh) intermittently after you get the MTP died message

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,454

    Default Re: Multiple problems with MTP

    Not sure if there has been an upgrade to MTP but I understand that not all smartphone USB cables come with all the pins connected. I have three cables but only one works with Leap 15; my friends have had similar experiences.

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Multiple problems with MTP

    could be a bad cable or a failing microusb port
    have you tried a different cable
    most android devices support multiple protocols have you tried ptp or usb storage
    if the issue persists with multiple cable's I'd say it's a damaged microusb connector
    it's quite possible the charging leads are fine but the data ones are damaged

  6. #6

    Default Re: Multiple problems with MTP

    It seems far fetched that a cable or a port breaks down the moment the OP changes OS from 42.3 to 15.0. I would expect some differences between the 2 versions.

    @OP: start dolphin from a terminal so probably error messages are shown there which could help you any further.
    Have installed Tumbleweed and apart from some smaller issues I like it very much.
    CPU: 8-core AMD FX-8350, GPU: GTX-760, RAM: 16GB, Disks: SSD-128GB for / (including /home), 2 times 1TB (in RAID0) HDD for Data.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •