Results 1 to 5 of 5

Thread: keyboard switching shortcut does not survive reboot

  1. #1

    Question keyboard switching shortcut does not survive reboot

    Hi. I have a fresh install of Leap 15, about a month old. Plasma desktop. I'm trying to sort out the last minor inconvenience so I can get on with my life. The issue is that I use two keyboard layouts (English and Russian). For several versions of opensuse I have been using the Shft-Shft combination to toggle back and forth. I've set that up through Configure Desktop -> Input Devices -> Keyboard -> Layouts, and it actually works as expected.

    The problem is that when I reboot the laptop, the shortcut doesn't work. I can go to the above location, change "Switch Policy" from "Global" to "Desktop", or visa versa, and "Apply", and all is good again. All my setting are remembered, they are just not applied. It seems like there must be a service or similar that is not getting started automatically, but which is being launched by the "Apply" button. Ideas? Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: keyboard switching shortcut does not survive reboot

    As this seems to be being a desktop setting, I am amazed that it is lost only after a reboot. Are you sure it is NOT lost after log-out/log-in?
    Henk van Velden

  3. #3

    Default Re: keyboard switching shortcut does not survive reboot

    Quote Originally Posted by hcvv View Post
    As this seems to be being a desktop setting, I am amazed that it is lost only after a reboot. Are you sure it is NOT lost after log-out/log-in?
    You are correct, of course. It's a single user system, so I basically never log out. But yes, it would be more correct to say that the shortcut does not survive logout.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: keyboard switching shortcut does not survive reboot

    Quote Originally Posted by JJMT View Post
    You are correct, of course. It's a single user system, so I basically never log out. But yes, it would be more correct to say that the shortcut does not survive logout.
    It is not only "more correct", it is a crucial piece of information to avoid that people are starting to look for a solution in the wrong place!

    And while there maybe only one user that uses the system regularly, this thus not change the fact that Unix/Linux systems are multi-user/multi-session systems. Forgetting this will really not help you in understanding how your system works in a lot of aspects.
    Henk van Velden

  5. #5

    Default Re: keyboard switching shortcut does not survive reboot

    I resolved this issue by disabling ibus. To do that I set INPUT_METHOD = "none" in /etc/sysconfig/language. Hope this helps someone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •