Results 1 to 4 of 4

Thread: Libreoffice + ugly icons

  1. #1

    Default Libreoffice + ugly icons

    My first report with this regard is from 23 January 2017 (see https://bugs.documentfoundation.org/....cgi?id=105489).
    At that time I used LO 5.3.02, Linux, openSuse Leap 42.2, Plasma 5.8.5. The icons of the LO UI looked terribly. In toolbar,
    in sidebar and in all possible bars. Even is I selected small icons they appear big and ugly. Have tried all possible icon sets
    and options. No openGL ha sbeen used. If I turned openGL on, LO did not start at all. The problem occurred with LO 5.3, previous
    version were OK. The problem also remained if LO has been started with a brand new user profile.

    Now, I am on Leap 15.0 and LO 6.1 (supplied by SUSE) and the problem still persists. To be more specific, the problem can be
    recognised on my laptop only. It has 1920×1080 display, whereas on my desktop machine with 2560×1440 resolution, everything is fine.

    Any suggestion what to do, or has anything been done so far to face the problem.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Libreoffice + ugly icons

    Hi, there's one thing that bothers me: we don't see other reports here about this. A thing to try ( certainly on a laptop with FHD screen ) is to set ( in systemsettings-fonts ) the DPI to 120, anti-aliasing to RGB / Slight and logout and login. Must say though that over the past couple of years I haven't seen this issue before. Does it exist for a newly created user ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Libreoffice + ugly icons

    Quote Originally Posted by Knurpht View Post
    Hi, there's one thing that bothers me: we don't see other reports here about this. A thing to try ( certainly on a laptop with FHD screen ) is to set ( in systemsettings-fonts ) the DPI to 120, anti-aliasing to RGB / Slight and logout and login. Must say though that over the past couple of years I haven't seen this issue before. Does it exist for a newly created user ?
    Hi:
    Thank you for your tips. It works great now. As to the DPI settings, the default setting is 96. I changed it now to 120, set also anti-aliasing, and all looked nice now.

    Thanks again.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Libreoffice + ugly icons

    Quote Originally Posted by krpan View Post
    Hi:
    Thank you for your tips. It works great now. As to the DPI settings, the default setting is 96. I changed it now to 120, set also anti-aliasing, and all looked nice now.

    Thanks again.
    Nice. Now that it works, you can also set this from sddm.conf by adding
    Code:
    [X11]
    ServerArguments=-dpi 122
    at the end of that file, it will also make the sddm display manager's login screen look more readable
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •