Results 1 to 10 of 10

Thread: Can't install xpra - dependency error

  1. #1
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Can't install xpra - dependency error

    Hi!
    I'm trying to install xpra (2.3.2-lp150.1.8-x86_64) from http://packman.links2linux.de or xpra (2.3.2-lp150.3.1-x86_64) from obs://build.opensuse.org/home:zamzing.

    Both can't succeed. YAST complains that "typelib(GtkosxApplication) = 1.0" is mandatory for xpra.

    What is the correct rpm? "typelib-1_0-Gtk-3_0" is already installed on my system

    Thanks in advance.
    Bye!

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Can't install xpra - dependency error

    I can confirm this on LEAP 15.0 and xpra from packman there is an unsatisfied dependency
    this might be a bugzilla moment
    but as it's not an opensuse package you're better off reporting it to the packman mailing list
    http://lists.links2linux.de/cgi-bin/...stinfo/packman

  3. #3
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Can't install xpra - dependency error

    Thank you very much for the feedback.

    Bye!

  4. #4

    Default Re: Can't install xpra - dependency error

    xpra is still kind of a work in progress.
    Does the one from X11:Utilities work?

  5. #5
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Can't install xpra - dependency error

    Quote Originally Posted by alois View Post
    xpra is still kind of a work in progress.
    Does the one from X11:Utilities work?
    X11:Utilities provides " xpra-2.3.2-lp150.2.4.x86_64.rpm ": same problem.

    As far as I understand, the dependency requisite asks "Typelib = 1.0" ( equal, not >= ), but in my system there is an rpm called " girepository-1_0 " (installed not by myself) that has provided Typelib 2.0 (AFAIK).


    xpra was a second option, after I tried to install and use "x2go" (works on openSUSE 15 very badly, a lot of things crash and even disconnect doesn't work).

  6. #6

    Default Re: Can't install xpra - dependency error

    Quote Originally Posted by acez View Post
    X11:Utilities provides " xpra-2.3.2-lp150.2.4.x86_64.rpm ": same problem.

    As far as I understand, the dependency requisite asks "Typelib = 1.0" ( equal, not >= ), but in my system there is an rpm called " girepository-1_0 " (installed not by myself) that has provided Typelib 2.0 (AFAIK).


    xpra was a second option, after I tried to install and use "x2go" (works on openSUSE 15 very badly, a lot of things crash and even disconnect doesn't work).
    What a strange requirement, one would think that GtkosxApplication would be needed when building on a Mac.

    Two questions:
    1. Do you have any extra repositories installed besides packman?
    2. Does xpra work if you ignore that runtime dependency?


    Also you should know I'm only the nominal maintainer. The actual one said he might take a look in the week end.

    Regards

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Can't install xpra - dependency error

    I didn't check and see if there was an opensuse package as it's packaged in the X11:Utilities repo you should open a bug report (you can use your forum account)
    http://bugzilla.opensuse.org/
    the maintainer seams to be active
    https://build.opensuse.org/package/s...Utilities/xpra

  8. #8
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Can't install xpra - dependency error

    Quote Originally Posted by alois View Post
    What a strange requirement, one would think that GtkosxApplication would be needed when building on a Mac.

    Two questions:
    1. Do you have any extra repositories installed besides packman?
    2. Does xpra work if you ignore that runtime dependency?


    Also you should know I'm only the nominal maintainer. The actual one said he might take a look in the week end.

    Regards
    No, nothing strange except repos needed for x2go.
    But, just to be sure, I did a fresh install in a VM, with usual things that I install from Packman. Same problem, dependency error remains.


    >>>>

    Code:
    linux-ourc:~ # zypper repos
    Repository priorities are without effect. All enabled repositories share the same priority.                             
                                                                                                                            
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh                
    ---+---------------------------+-----------------------------------------+---------+-----------+--------                
     1 | libdvdcss_15.0            | libdvdcss_15.0                          | Yes     | (r ) Yes  | Yes                    
     2 | openSUSE-Leap-15.0-1      | openSUSE-Leap-15.0-1                    | No      | ----      | ----   
     3 | packman_15.0              | packman_15.0                            | Yes     | (r ) Yes  | Yes    
     4 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----   
     5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----   
     6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----   
     7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----   
     8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes    
     9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes    
    10 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----   
    11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----   
    12 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes    
    13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes    
    linux-ourc:~ #
    >>>>

    I didn't try ignoring dependency error, I had non time. T will try in the next days.

    TNX, bye!

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Can't install xpra - dependency error

    Quote Originally Posted by acez View Post
    No, nothing strange except repos needed for x2go.
    But, just to be sure, I did a fresh install in a VM, with usual things that I install from Packman. Same problem, dependency error remains.


    >>>>

    Code:
    linux-ourc:~ # zypper repos
    Repository priorities are without effect. All enabled repositories share the same priority.                             
                                                                                                                            
    #  | Alias                     | Name                                    | Enabled | GPG Check | Refresh                
    ---+---------------------------+-----------------------------------------+---------+-----------+--------                
     1 | libdvdcss_15.0            | libdvdcss_15.0                          | Yes     | (r ) Yes  | Yes                    
     2 | openSUSE-Leap-15.0-1      | openSUSE-Leap-15.0-1                    | No      | ----      | ----   
     3 | packman_15.0              | packman_15.0                            | Yes     | (r ) Yes  | Yes    
     4 | repo-debug                | openSUSE-Leap-15.0-Debug                | No      | ----      | ----   
     5 | repo-debug-non-oss        | openSUSE-Leap-15.0-Debug-Non-Oss        | No      | ----      | ----   
     6 | repo-debug-update         | openSUSE-Leap-15.0-Update-Debug         | No      | ----      | ----   
     7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No      | ----      | ----   
     8 | repo-non-oss              | openSUSE-Leap-15.0-Non-Oss              | Yes     | (r ) Yes  | Yes    
     9 | repo-oss                  | openSUSE-Leap-15.0-Oss                  | Yes     | (r ) Yes  | Yes    
    10 | repo-source               | openSUSE-Leap-15.0-Source               | No      | ----      | ----   
    11 | repo-source-non-oss       | openSUSE-Leap-15.0-Source-Non-Oss       | No      | ----      | ----   
    12 | repo-update               | openSUSE-Leap-15.0-Update               | Yes     | (r ) Yes  | Yes    
    13 | repo-update-non-oss       | openSUSE-Leap-15.0-Update-Non-Oss       | Yes     | (r ) Yes  | Yes    
    linux-ourc:~ #
    >>>>

    I didn't try ignoring dependency error, I had non time. T will try in the next days.

    TNX, bye!
    open a bug report so it gets fixed
    http://bugzilla.opensuse.org/

  10. #10
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Can't install xpra - dependency error


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •