Results 1 to 3 of 3

Thread: Cannot install python-qt4 on Leap 15.0

  1. #1

    Default Cannot install python-qt4 on Leap 15.0

    Hi all,
    I'm trying to install and run the QT interface for Autokey on Leap 15.0 x64. I'm having trouble finding a provider for dbus.mainloop.qt in the Leap 15.0 repos. I checked the spec file for the python-qt4 package and it says it should install the dbus binding I need, but I can't get it to install when I use the YMP or follow the commands from the python-qt4 for Leap 15.0 OpenSUSE Software page. It seems that the repo no longer exists:
    Code:
    # zypper addrepo https://download.opensuse.org/repositories/openSUSE:Leap:15.0/standard/openSUSE:Leap:15.0.repo
    File '/repositories/openSUSE:Leap:15.0/standard/openSUSE:Leap:15.0.repo' not found on medium 'https://download.opensuse.org/'
    Here's the error I get from Autokey:
    Code:
    $ autokey-qt
    Traceback (most recent call last):
      File "/usr/bin/autokey-qt", line 56, in <module>
        from autokey.qtapp import Application
      File "/usr/lib/python3.6/site-packages/autokey/qtapp.py", line 23, in <module>
        import dbus.mainloop.qt
    ModuleNotFoundError: No module named 'dbus.mainloop.qt'
    Thanks!
    DaAwesomeP

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,163

    Default Re: Cannot install python-qt4 on Leap 15.0

    I have no idea about your grand concept. I only did something very obvious (to me at least), checking that URL.

    Using a browser to https://download.opensuse.org/repositories, I cloud not find the next step openSUSE:Leap:15.0, but is could go down openSUSE:/ and thenLeap:/ and then 15.0.

    Maybe you should check the URL you want to use. Shouldn't that simply be the OSS repo (which you have already)?
    Henk van Velden

  3. #3

    Default Re: Cannot install python-qt4 on Leap 15.0

    Thank you for your response! After more investigation, I found the python3-qt4 package and was able to install it. I then verified that the Python module I require was installed, so the issue must be with Autokey.

    Thank you!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •