Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

  1. #1
    Join Date
    Sep 2018
    Posts
    10

    Default Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Hallo zusammen,

    ich habe gerade Leap 15 und anschließend den Nvidia-Treiber für meine GTX670 installiert. Nach einem Neustart wird nur ein default-Monitor mit einer Auflösung von 640x480 erkannt. Die Auflösung kann ich auch über Desktop Settings nicht ändern.
    Ich habe dann versucht über die Nvidia-Treiber GUI etwas einzustellen. Es erscheint aber eine Meldung, dass nvidia-xconfig als root ausgeführt werden muss.
    Das habe ich getan und anschließend über Strg+Alt+Backspace den X-Server neu gestartet. Damit wird die grafische Oberfläche verlassen und ich lande in einer Kommandozeilenumgebung die wild flackert. Auch nach einem Neustart. Ein Login ist quasi nicht möglich, weil es durch das Flackern Glücksache ist, ob ein Tastenanschlag erkannt wird oder nicht.

    Mit dem Nouveou-Treiber bekomme ich nach einer Neuinstallation eine vernünftige Auflösung.
    Hat jemand einen Rat?
    Danke im Voraus!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,131

    Default AW: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Poste:
    Code:
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    Code:
    cat /var/log/Xorg.0.log

  3. #3
    Join Date
    Sep 2018
    Posts
    10

    Default Re: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Ich versuchs morgen Abend. Wie gesagt, es ist durch das Flackern schwierig mich überhaupt anzumelden. Evtl. muss ich einfach neu installieren und die Infos nach Treiberinstallation, aber vor X-Server Neustart rausfinden.

  4. #4
    Join Date
    Sep 2018
    Posts
    10

    Default Re: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    So, hier nun die Infos:
    Code:
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 670] [10de:1189] (rev a1)
            Subsystem: eVga.com. Corp. Device [3842:2670]
            Kernel driver in use: nouveau
            Kernel modules: nouveau
    01:00.1 Audio device [0403]: NVIDIA Corporation GK104 HDMI Audio Controller [10de:0e0a] (rev a1)
            Subsystem: eVga.com. Corp. Device [3842:2670]
            Kernel driver in use: snd_hda_intel
            Kernel modules: snd_hda_intel
    02:00.0 Multimedia video controller [0400]: Conexant Systems, Inc. CX23887/8 PCIe Broadcast Audio and Video Decoder with 3D Comb [14f1:8880] (rev 04)
            Subsystem: Hauppauge computer works Inc. Device [0070:c138]
            Kernel driver in use: cx23885
            Kernel modules: cx23885
    Hier das (gekürzte) Xorg.0.log vor Nvidia-Treiber Installation. Es ist für mich unmöglich ein Log nach der Installation zu bekommen. Auch wenn ich versuche im Recovery-Modus zu booten, flackert die Kommandozeile.
    Ich habe versucht, in ein anderes Terminal zu wechseln (Alt+F?). Tastatureingaben scheinen in verschiedenen Terminals rauszukommen. Es scheint so, als würden die Terminals schnell nacheinander durchgewechselt.
    Code:
    [    28.448] (II) No input driver specified, ignoring this device.
    [    28.448] (II) This device may have been added with another device file.
    [    28.448] (II) config/udev: Adding input device (unnamed) (/dev/tty58)
    [    28.448] (II) No input driver specified, ignoring this device.
    [    28.448] (II) This device may have been added with another device file.
    [    28.448] (II) config/udev: Adding input device (unnamed) (/dev/tty59)
    [    28.448] (II) No input driver specified, ignoring this device.
    [    28.448] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty6)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty60)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty61)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty62)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty63)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty7)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty8)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (II) config/udev: Adding input device (unnamed) (/dev/tty9)
    [    28.449] (II) No input driver specified, ignoring this device.
    [    28.449] (II) This device may have been added with another device file.
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "evdev pointer catchall"
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "evdev keyboard catchall"
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "system-keyboard"
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "evdev pointer catchall"
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "evdev keyboard catchall"
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "libinput pointer catchall"
    [    28.449] (**) Logitech MX Ergo: Applying InputClass "libinput keyboard catchall"
    [    28.449] (II) Using input driver 'libinput' for 'Logitech MX Ergo'
    [    28.449] (**) Logitech MX Ergo: always reports core events
    [    28.449] (**) Option "Device" "/dev/input/event3"
    [    28.449] (**) Option "_source" "_driver/libinput"
    [    28.449] (II) libinput: Logitech MX Ergo: is a virtual subdevice
    [    28.449] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb5/5-1/5-1.3/5-1.3:1.2/0003:046D:C52B.0005/0003:046D:406F.0006/input/input3/event3"
    [    28.449] (II) XINPUT: Adding extended input device "Logitech MX Ergo" (type: KEYBOARD, id 13)
    [    28.449] (**) Option "xkb_model" "pc105"
    [    28.449] (**) Option "xkb_layout" "de"
    [    28.449] (**) Option "xkb_variant" "nodeadkeys"
    [    28.449] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    [    42.710] (II) NOUVEAU(0): EDID vendor "DEL", prod id 41083
    [    42.710] (II) NOUVEAU(0): Using EDID range info for horizontal sync
    [    42.710] (II) NOUVEAU(0): Using EDID range info for vertical refresh
    [    42.710] (II) NOUVEAU(0): Printing DDC gathered Modelines:
    [    42.710] (II) NOUVEAU(0): Modeline "1920x1200"x0.0  154.00  1920 1968 2000 2080  1200 1203 1209 1235 +hsync -vsync (74.0 kHz eP)
    [    42.710] (II) NOUVEAU(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
    [    42.710] (II) NOUVEAU(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz e)
    [    44.936] (II) NOUVEAU(0): EDID vendor "DEL", prod id 41083
    [    44.936] (II) NOUVEAU(0): Using hsync ranges from config file
    [    44.936] (II) NOUVEAU(0): Using vrefresh ranges from config file
    [    44.936] (II) NOUVEAU(0): Printing DDC gathered Modelines:
    [    44.936] (II) NOUVEAU(0): Modeline "1920x1200"x0.0  154.00  1920 1968 2000 2080  1200 1203 1209 1235 +hsync -vsync (74.0 kHz eP)
    [    44.936] (II) NOUVEAU(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "1280x960"x0.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz e)
    [    44.936] (II) NOUVEAU(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz e)
    Anschließend noch die xorg.conf nach Ausführung von nvidia-xconfig. Es sieht nicht danach aus, als würde irgendetwas vernünftig konfiguriert...
    Code:
    cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 390.87  (buildmeister@swio-display-x64-rhel04-14)  Tue Aug 21 17:33:38 PDT 2018
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from data in "/etc/sysconfig/mouse"
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "IMPS/2"
        Option         "Device" "/dev/input/mice"
        Option         "Emulate3Buttons" "yes"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,131

    Default AW: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Benenne einfach die xorg.conf um, meistens stört die.
    Als root:
    Code:
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    Und lass die Finger von nvidia-xconfig, auch das funktioniert nicht zuverlässig.

  6. #6
    Join Date
    Sep 2018
    Posts
    10

    Default Re: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Danke, das war wohl die Lösung.

    Ich habe nochmal neu installiert. Keine Chance irgendetwas einzugeben.

    Diesmal habe ich einfach nur den Nvidia-Treiber installiert und nicht weiter versucht etwas zu konfigurieren und irgendeine Xorg.conf zu verbasteln. Ich kann zwar damit Nvidia X Server Settings nicht nutzen, aber damit kann ich leben.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,131

    Default AW: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Ich kann zwar damit Nvidia X Server Settings nicht nutzen,
    Warum das nicht?

    Einfach nvidia-settings aufrufen und ohne speichern beenden, das geht automatisch, allerdings nicht in /etc/X11/xorg.conf.d/...........

  8. #8
    Join Date
    Sep 2018
    Posts
    10

    Default Re: AW: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Quote Originally Posted by Sauerland View Post
    Warum das nicht?
    Wenn ich Nvidia X Server Settings aufrufe, kommt die Warnung, dass nvidia-xconfig ausgeführt werden muss. (Was ich ja unterlassen sollte um nicht nochmal neu installieren zu müssen.)

    Außerdem startet nvidia-settings mit den folgenden Fehler die mir jetzt erst aufgefallen sind als ich es von einem Terminal aus versucht habe zu starten:
    Code:
    ERROR: NVIDIA driver is not loaded
    
    ERROR: Error querying enabled displays on GPU 0 (Missing Extension).
    
    ERROR: Error querying connected displays on GPU 0 (Missing Extension).
    
    ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and descriptions.

  9. #9
    Join Date
    Sep 2018
    Posts
    10

    Default Re: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Nachtrag: /var/log/Xorg.0.log ist voll mit Einträgen a'la
    Code:
    (WW) NOUVEAU(0): nouveau_dri2_flip_event_handler: Pageflip has impossible msc 1524881 < target_msc 1524882
    Der Nvidia-Treiber läuft wohl doch nicht...

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,131

    Default AW: Flackernde Kommandozeile nach Installation von Nvidia-Treiber

    Poste das komplette:
    Code:
    cat /var/log/Xorg.0.log
    Falls zu lang, benutze http://paste.opensuse.org/

    Code:
    zypper lr -d
    Code:
    zypper se -si nvidia

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •