Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Can't print in black&white/grey-scale on HP M277dw with hplip

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,393
    Blog Entries
    1

    Default Re: Can't print in black&white/grey-scale on HP M277dw with hplip

    Quote Originally Posted by RaveNBlack View Post
    Thank you for the links, I did see them.

    Unfortunately, even converting to PS does not fix the issue - still prints in color.
    A bug report is needed then. Perhaps see if any similar current bug open first....
    https://bugs.launchpad.net/hplip
    openSUSE Leap 15.0; KDE Plasma 5

  2. #12

    Default Re: Can't print in black&white/grey-scale on HP M277dw with hplip

    Thanks, I had a question (not a bug) posted there earlier.

    I also found similar bug posted, so linked our discussions there. Hope it will get fixed.

  3. #13

    Thumbs up Re: Can't print in black&white/grey-scale on HP M277dw with hplip

    In case somebody stumbles upon this thread, I'll share the (sort of) solution for myself.

    Firstly, I had to reinstall HPLIP because of other issues. Not sure if it has anything to do with the solution.

    I did find that HPLIP GUI interface has default printer settings. I always assumed that they are the same as CUPS/i.e. the interface actually changes CUPS settings. It turns out not to be the case. Once I've set HPLIP defaults to black and white - it prints everything in B&W. I haven't tested it extensively, but it seems that I need to change HPLIP defaults to colour if I need to print something in colour. However, I hardly ever ned colour prints, so haven't tested that too much.

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,393
    Blog Entries
    1

    Default Re: Can't print in black&white/grey-scale on HP M277dw with hplip

    Quote Originally Posted by RaveNBlack View Post
    In case somebody stumbles upon this thread, I'll share the (sort of) solution for myself.

    Firstly, I had to reinstall HPLIP because of other issues. Not sure if it has anything to do with the solution.

    I did find that HPLIP GUI interface has default printer settings. I always assumed that they are the same as CUPS/i.e. the interface actually changes CUPS settings. It turns out not to be the case. Once I've set HPLIP defaults to black and white - it prints everything in B&W. I haven't tested it extensively, but it seems that I need to change HPLIP defaults to colour if I need to print something in colour. However, I hardly ever ned colour prints, so haven't tested that too much.
    Thanks for the update.
    openSUSE Leap 15.0; KDE Plasma 5

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •