Results 1 to 5 of 5

Thread: schily-mt conflicts with cpio-mt

  1. #1

    Default schily-mt conflicts with cpio-mt

    Hi everyone,

    Can't zypper dup because of this problem:

    Code:
    Problem: schily-mt-2018.05.25-4.1.x86_64 conflicts with cpio-mt provided by cpio-mt-2.12-4.14.x86_64
     Solution 1: deinstallation of cpio-mt-2.12-4.14.x86_64
     Solution 2: deinstallation of star-rmt-1.5.3-7.3.x86_64
     Solution 3: deinstallation of tar-rmt-1.30-1.2.x86_64
     Solution 4: keep obsolete star-rmt-1.5.3-7.3.x86_64
    What should I do? Thanks in advance.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    10,420
    Blog Entries
    3

    Default Re: schily-mt conflicts with cpio-mt

    I went with solution 1.

    Whether that was a good idea -- only time will tell. However, "cpio-mt" looks (based only on the name) as if it is intended for use with magnetic tape. And I don't have any tape drives. I don't even know why I have that package -- it was probably a recommend from something else that is installed.

    I figured that I can do without "cpio-mt". And when the conflict are resolved, it will probably be pulled in again anyway.

    That was my thinking. You will have to make your own decision. And I'll note that I did not run into any other conflicts on this update.

    I should have added -- this was for the update to snapshot 20180827 (just in case anyone is wondering what this is all about).
    Last edited by nrickert; 29-Aug-2018 at 04:46.
    opensuse Leap 15.0; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  3. #3

    Default Re: schily-mt conflicts with cpio-mt

    I also went with solution #1. Discussion on the mailing list leads me to believe this package is a harmless 'recommends' package linked to something more universal (e.g. like `tar`)

    Regards,
    Chris

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    18,153
    Blog Entries
    14

    Default Re: schily-mt conflicts with cpio-mt

    I went with solution nr. 2, since star-mt is no longer part of the Tw distribution repos. Did a search for the conflicting packages and found out.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: schily-mt conflicts with cpio-mt

    i went with solution 4 and left it to update.
    i then used zypper rm star-mt, did a reboot and then did a zypper dup again to double check and this file was never reinstalled

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •