Results 1 to 5 of 5

Thread: KDE Plasma unstable

  1. #1
    Join Date
    Jun 2011
    Location
    Broadway, UK
    Posts
    38

    Default KDE Plasma unstable

    I've been running Leap42.3 for some time on my main desktop machine which was previously running 13.1 ... over the last couple of weeks it has become somewhat unstable and keeps switching from it's normal 1.5Gb of memory used to filling the 32G available and then trying to run in swap space. If I see it happening I can normally log out and in again, but it's happened twice now while I'm deep into some heavy writing.
    CURRENTLY I've just managed to log in via ssh from another machine and after a while one can get to a command prompt. Killing plasmashell takes out the desktop, but leaves all the other applications working fine, so this time I've managed to complete an email and save the backup work and am now on-line here without a problem.
    I've already switched off indexing on the desktop as that seemed to be a problem but perhaps it was just a side issue. I've 35Gb of emails indexed via Thunderbird, all the documents are in Libreoffice so don't index at all and all the code is managed via eclipse so does not use KDE index ... so that is a pointless operation anyway.
    Where can I go next to work out just what is causing the problem? I'm running what I think is the current 42.3 build on an 8core AMD FX8350 with 32Gb RAM SSD and HDD disks with plenty of space and a 4 screen display off a single Radeon R7 360 graphics card.
    I need to reboot to get at kinfocenter to run and check the software versions ...

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: KDE Plasma unstable

    run top or ksysgurad to see which app is eating mem

  3. #3
    Join Date
    Jun 2011
    Location
    Broadway, UK
    Posts
    38

    Default Re: KDE Plasma unstable

    Quote Originally Posted by gogalthorp View Post
    run top or ksysgurad to see which app is eating mem
    plasmashell is showing virtually all the memory usage - which is why I tried killing - Up until then I'd been kicking the power switch - having killed plasmashell I can navigate the remaining open apps and save anything important before hitting reboot.
    Current solution - I've got Gnome running and if that remains up I know it's not a hardware problem Just have to restore all the apps I normally use.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: KDE Plasma unstable

    Since you updated from all the way back from 13.1 there is bound to be problems in your home configuration files, Try a new test user and see if things are better, May be it is a bad/old widget. At least these are what you should be looking at,

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,551

    Default Re: KDE Plasma unstable

    Quote Originally Posted by lsces View Post
    over the last couple of weeks it has become somewhat unstable
    Given KDE Plasma, please install the package "kdebugsettings" from the main openSUSE Leap 42.3 Repository, start it from the user's CLI in a Konsole window, and then press the "Turn Off Debug" button.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •