Results 1 to 4 of 4

Thread: KDE failing in weird ways - No menu, no taskbar

  1. #1
    Join Date
    May 2009
    Location
    Germany, Greece
    Posts
    12

    Question KDE failing in weird ways - No menu, no taskbar

    Hello together

    I have severall computers at home running Leap 42.3 and a NAS which exports the home directories of several users via NFS to these computers. This is done mainly for convenience and easy backup reasons. Now I had some availability issues with the NFS volume (which is mounted as /home on the clients). I also sometimes use VNC to access a desktop machine from a laptop.

    After these issues with NFS I have similar problems on all machines in accessing KDE. It either does not start (it attempts to but fails) or it starts without showing a menu and taskbar (ALT-F2 works though and I can invoke a konsole) and sometimes also there are no window widgets (either the top bar does not exist or it is completely black). This happens both on display :0 as wenn as any VNC instance.

    I have tried erasing .kde .cache .dbus .local/share/* /tmp/*USERNAME* /tmp/*USERID* and also .vnc to no avail.

    What could cause that behaviour, which survives reboots?

    Best regards

    George

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: KDE failing in weird ways - No menu, no taskbar

    Perhaps altered permissions on the exports after your issue with NFS (which you may like to explain)?

  3. #3
    Join Date
    May 2009
    Location
    Germany, Greece
    Posts
    12

    Default Re: KDE failing in weird ways - No menu, no taskbar

    Quote Originally Posted by brunomcl View Post
    Perhaps altered permissions on the exports after your issue with NFS (which you may like to explain)?
    No, the permissions are ok. the NFS server was crashed for long periods of time, so the client was not seeing home directories of logged in users.
    Once the NFS was restarted and a
    Code:
    mount -a
    command was issued on the client operation could be resumed
    Unfortunately this happened many times and at some point resuming the session lead to above mentioned problems.

    Regards,

    George

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,507

    Default Re: KDE failing in weird ways - No menu, no taskbar

    If Desktop Manager plasma (Wayland) is being used try plasma without wayland

    If plasma is being used are the symptoms the same when using icedm

    If icedm works OK does toggling back to plasma improve things

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •