Results 1 to 2 of 2

Thread: invalid status "unresolvable"

  1. #1

    Default invalid status "unresolvable"

    Hi all,

    I have a package where Debian 7 variants show "unresolvable": https://build.opensuse.org/package/s...rhards/librelp

    However, I have changed the dependency that is said to be unresolvable (libgnutls28-dev). It is now libgnutls-dev, which is resolvable on Debian 7. The definition is obviously present inside debian.control, as the newer versions of Debian (expectedly) fail. No matter what I do, the "unresolvable" state does not change. I even removed the repository and added it again.

    It looks to me like the rules file is not parsed again by OBS and the status somehow sticks. I am now stuck. Any advise on how to resolve this would be most appreciated.

    Rainer

    PS: I originally wanted to try out alternate dependencies, but as the status never changes from "unresolvable", I could not do that. Now I am just to giving the Deb 7 dependency. So it is not my intent to have the newer Debs fail in the future, but I can't do my troubleshooting and testing due to the stuck step. Just FYI.
    Last edited by rgerhards; 23-Aug-2018 at 03:46. Reason: important typo

  2. #2

    Default Re: invalid status "unresolvable"

    Answering my own question: I overlooked that obs uses the .dsc file as well. There, it had the unresolved dependency. Replacing it in .dsc and .control make the build work for me :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •