Results 1 to 10 of 10

Thread: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

  1. #1

    Default Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Hallo,

    Ich habe mir OBS unter Tumbleweed installiert, wenn ich OBS ganz normal über das Menü starte geht es sofort wieder aus. Wenn ich OBS über das Terminal starte kriege ich
    Code:
    Speicherzugriffsfehler (Speicherabzug geschrieben)
    zurück und wenn ich OBS mit Root-Rechten starte kriege ich nur
    Code:
    Speicherzugriffsfehler
    zurück. Was ist das problem und wie löse es?

    Danke für alle antworten.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Es ist immer von Vorteil, die Ausgabe incl. der kompletten Eingabezeile zu posten.

  3. #3

    Default Re: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Code:
    max@openSUSE:~> obs
    Speicherzugriffsfehler (Speicherabzug geschrieben)
    max@openSUSE:~> sudo obs
    Speicherzugriffsfehler
    max@openSUSE:~>

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Poste:
    Code:
    zypper lr -d
    Code:
    zypper se -si obs

  5. #5

    Default Re: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Code:
    max@openSUSE:~> zypper lr -d
    Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.
    
    # | Alias                                  | Name                        | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                      | Dienst
    --+----------------------------------------+-----------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------+-------
    1 | download.nvidia.com-tumbleweed         | nVidia Graphics Drivers     | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | https://download.nvidia.com/opensuse/tumbleweed          |       
    2 | openSUSE-20180815-0                    | openSUSE-20180815-0         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/        |       
    3 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/      |       
    4 | packman                                | packman                     | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed         |       
    5 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository          | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/        |       
    6 | repo-debug                             | openSUSE-Tumbleweed-Debug   | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/  |       
    7 | repo-non-oss                           | openSUSE-Tumbleweed-Non-Oss | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/    |       
    8 | repo-source                            | openSUSE-Tumbleweed-Source  | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/ |       
    9 | repo-update                            | openSUSE-Tumbleweed-Update  | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/tumbleweed/          |       
    max@openSUSE:~> zypper se -si obs
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name       | Typ   | Version     | Arch   | Repository        
    ---+------------+-------+-------------+--------+-------------------
    i+ | obs-studio | Paket | 21.1.2-1.12 | x86_64 | packman           
    i+ | obs-studio | Paket | 21.1.2-1.12 | x86_64 | Packman Repository

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Poste:
    Code:
    zypper se -si nvidia
    Code:
    /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    Du machst Updates mit
    Code:
    zypper dup
    ?
    Last edited by Sauerland; 19-Aug-2018 at 02:59.

  7. #7

    Default Re: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Code:
    max@openSUSE:~> zypper se -si nvidia
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                      | Typ   | Version              | Arch   | Repository             
    ---+---------------------------+-------+----------------------+--------+------------------------
    i  | nvidia-computeG04         | Paket | 390.77-9.1           | x86_64 | nVidia Graphics Drivers
    i  | nvidia-gfxG04-kmp-default | Paket | 390.77_k4.17.7_1-9.1 | x86_64 | nVidia Graphics Drivers
    i  | nvidia-glG04              | Paket | 390.77-9.1           | x86_64 | nVidia Graphics Drivers
    i+ | x11-video-nvidiaG04       | Paket | 390.77-9.1           | x86_64 | nVidia Graphics Drivers
    max@openSUSE:~> /sbin/lspci -nnk | grep -EiA3 'vga|3d|display'
    08:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] [10de:1c03] (rev a1)
            Subsystem: ASUSTeK Computer Inc. Device [1043:85b7]
            Kernel driver in use: nvidia
            Kernel modules: nouveau, nvidia_drm, nvidia
    max@openSUSE:~> zypper dup
    Zur Durchführung einer Distributionsaktualisierung sind Root-Berechtigungen erforderlich.
    max@openSUSE:~> sudo zypper dup
    Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass diese Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'.
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Distributions-Aktualisierungen werden verarbeitet...
    
    Die folgenden 3 NEUEN Pakete werden installiert:
      libdvdcss2 vlc vlc-qt
    
    3 neue Pakete zu installieren.
    Gesamtgröße des Downloads: 1,8 MiB. Bereits im Cache gespeichert: 0 B. Nach der Operation werden zusätzlich 5,1 MiB
    belegt.
    Fortfahren? [j/n/...? zeigt alle Optionen] (j): j
    Paket vlc-qt-3.0.3-3.2.x86_64 abrufen                                                (1/3),   1,1 MiB (  3,3 MiB entpackt)
    Abrufen: vlc-qt-3.0.3-3.2.x86_64.rpm ...............................................................[fertig (680,2 KiB/s)]
    Paket vlc-3.0.3-3.2.x86_64 abrufen                                                   (2/3), 669,1 KiB (  1,6 MiB entpackt)
    Abrufen: vlc-3.0.3-3.2.x86_64.rpm ..................................................................[fertig (611,1 KiB/s)]
    Paket libdvdcss2-1.4.2-1.1.x86_64 abrufen                                            (3/3),  66,2 KiB (175,3 KiB entpackt)
    Abrufen: libdvdcss2-1.4.2-1.1.x86_64.rpm .........................................................................[fertig]
    Überprüfung auf Dateikonflikte läuft: ............................................................................[fertig]
    (1/3) Installieren: vlc-qt-3.0.3-3.2.x86_64 ......................................................................[fertig]
    (2/3) Installieren: vlc-3.0.3-3.2.x86_64 .........................................................................[fertig]
    Zusätzliche rpm-Ausgabe:
                                         ......            root@openSUSE 
         .,cdxxxoc,.               .:kKMMMNWMMMNk:.        ------------- 
        cKMMN0OOOKWMMXo. ;        ;0MWk:.      .:OMMk.     OS: openSUSE Tumbleweed 
      ;WMK;.       .lKMMNM,     :NMK,             .OMW;    Kernel: 4.17.14-1-default 
     cMW;            'WMMMN   ,XMK,                 oMM'   Uptime: 3 mins 
    .MMc               ..;l. xMN:                    KM0   Packages: 2698 (rpm) 
    'MM.                   'NMO                      oMM   Shell: bash 4.4.23 
    .MM,                 .kMMl                       xMN   Terminal: rpm 
     KM0               .kMM0. .dl:,..               .WMd   CPU: AMD Ryzen 5 1500X (8) @ 3.500GHz 
     .XM0.           ,OMMK,    OMMMK.              .XMK    GPU: NVIDIA GeForce GTX 1060 6GB 
       oWMO:.    .;xNMMk,       NNNMKl.          .xWMx     Memory: 1380MiB / 16035MiB 
         :ONMMNXMMMKx;          .  ,xNMWKkxllox0NMWk,
             .....                    .:dOOXXKOxl,                                 
    
    
    
    
    (3/3) Installieren: libdvdcss2-1.4.2-1.1.x86_64 ..................................................................[fertig]

    nach dem update klappt OBS immer noch nicht.

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,794

    Default AW: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Evtl. geht es mit dem Update:
    https://pmbs.links2linux.de/package/...dia/obs-studio

    Ich schätze mal, das das kürzlich veröffentlicht wird.......

  9. #9

    Default Re: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Wenn ich versuche das paket: https://pmbs.links2linux.de/package/...USE_Tumbleweed zu installieren sagt Discover: Interner Fehler

    Und bei dem paket: https://pmbs.links2linux.de/package/...USE_Tumbleweed sagt Discover: Stellen sie sicher, dass Appstream auf ihrem System korrekt eingerichtet ist.

  10. #10

    Default Re: Open Broadcaster Software Startet nicht Speicherzugriffsfehler

    Übringens die Snap version von OBS funktioniert.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •