Results 1 to 6 of 6

Thread: OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

  1. #1
    Join Date
    Jun 2016
    Location
    NY
    Posts
    17

    Default OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

    I'm updating a PC from an old version of Ubuntu to Leap 15.1. I have a desktop running Leap 42.3 that I really like, however with the OS turning obsolete every 2 years I really don't want to put 42.3 on another box. Here are my observations on trying to run samba on Leap 15.1.

    The samba configuration and enabling is done in yast. But its buggy. First the Yast Samba screen does not correctly show the internet zone for eth0. It always says its undefined even after you change the settings under Network. I found one should correctly set the Network location there first as we are going to have to set the firewall rules for that setting in order for them to take affect. I am using internal zone. One might wonder how Yast sets the firewall rules if it doesn't display the correct ethernet zone.

    Next I found that enabling the firewall ports through the samba page in Yast does not work correctly. samba client is enabled but the samba server never is. So once you exit/finish setting up samba, we must then go into the firewall settings, correctly set the zone to the one you are using and then enable samba. You must enable samba for current and for permanent or the firewall will not enable samba the next time you boot or maybe log off.

    At this point I was able to see the samba server machine but I could not log in to my share drive. This was from a samba client running leap 42.3. I had verified that iptables on 42.3 were setup to pass smb and nmb and netbios. The leap 15.1 samba server no longer shows netbios as an option. I found that we have to add the smb user to the smb user database, plus set the user's password.

    The command to add a user is:
    Code:
    user@sambaserver:->sudo pdbedit -a -u username[enter]
    You will then be prompted for a password.

    The command to list the samba users is:
    Code:
    user@sambaserver:->sudo pdbedit -L[enter]
    After all of this I am able to access my share drive on Leap 15.1 from Leap 42.3. Will be testing if Windows works next.

    To recap;
    1) Set your network zone in Yast / Network Settings
    2) Setup your samba shares using Yast / Samba
    3) Fix your firewall and enable samba for your current setting and permanent settings assuming you want to enable samba all the time in Yast / Firewall. You must do this every time you use Yast / Samba as it overwrites the rules.
    4) Open a terminal and add your samba username and define a password using pdbedit.

    Other helpful commands are, iptables --list , firewall-cmd --zone=internal --list-all, smbtree, cat /var/log/samba/log.smbd.
    I also recommend editing the /etc/samba/smb.conf file manually so you do not need to reset the firewall rules. You then need to use systemctl stop smd nmd, and systemctl start smd nmd.

    This was only one full day of debug using old notes for Leap 42.1, 42.2, 42.3, and Ubuntu 10, 12, and 14. Too bad I'll forget most of this in another year and a half when I need to update the OS again. Most likely the new useful commands will be different. I still have much more to install too. I would really love a linux distro with a 10 year life span like Red Hat's Fedora Core 4.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

    As this is not a request for assistance, it will be moved to 'General Chit-chat'. Firewalld information can be found here.



    openSUSE Leap 15.0; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,383
    Blog Entries
    1

    Default Re: OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

    Moved from 'Network/Internet' and open for posting again.
    openSUSE Leap 15.0; KDE Plasma 5

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,629
    Blog Entries
    3

    Default Re: OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

    I'll note that Leap 15.1 is not yet out.

    Yes, there is an installation DVD available. But it is considered an alpha release (or, really, pre-release).

    Or maybe this was supposed to be about 15.0. In any case, it might be better at this stage to test whether your problem applies to 15.0.

    At present, Leap 15.1 is far from finalized. I think bug reports are being accepted.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Jun 2016
    Location
    NY
    Posts
    17

    Default Re: OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

    Quote Originally Posted by nrickert View Post
    I'll note that Leap 15.1 is not yet out.

    Yes, there is an installation DVD available. But it is considered an alpha release (or, really, pre-release).

    Or maybe this was supposed to be about 15.0. In any case, it might be better at this stage to test whether your problem applies to 15.0.

    At present, Leap 15.1 is far from finalized. I think bug reports are being accepted.
    My post is incorrect. I've double checked and the iso downloaded is openSUSE-Leap-15.0-DVD-x86_64.iso, Plus the two systems I'm trying it on show Leap 15.0 in /etc/os-release file. I have no clue how I came up with thinking I'm on 15.1. Sorry.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,629
    Blog Entries
    3

    Default Re: OpenSuse Leap 15.1 Issues Setting Up Samba Using Yast

    Thanks for that clarification.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •