Hi,

I have two separate packages, avogadro2 (https://build.opensuse.org/package/s...n809/avogadro2) and avogadro2-libs (https://build.opensuse.org/package/s...avogadro2-libs). These are split into subpackages with the most relevant to this problem being libavogadro1_91, libavogadro1_91-devel and avogadro2-libs-devel.

avogadro2 depends on all three of the aforementioned subpackages in order for it to build properly. I've decided to save myself some time down the road by only making the package explicitly depend on avogadro2-libs-devel for the build (as libavogadro1_91 and its -devel package are likely to one day become libavogadro2_0 and -devel), and making avogadro2-libs-devel depend on libavogadro1_91 and libavogadro1_91-devel as runtime dependencies (i.e. Requires as it's called in spec files). Unfortunately, however, the build is failing at the configure stage and the log file (https://pastebin.com/ASZxaQYQ; pastebined in case I update the build and the log is discarded) clearly shows that the reason is that libavogadro1_91 is not being installed, although libavogadro1_91-devel is being installed. By-the-way, libavogadro1_91 is an explicit dependency of libavogadro1_91-devel too, as it has that Requires: line too!

I've rpm -qR'ed the avogadro2-libs-devel package and it returned:

Code:
Mesa-libGL-devel(x86-64)
avogadro2-libs(x86-64) = 1626-2.1
glew-devel(x86-64)
glu-devel(x86-64)
libavogadro1_91
libavogadro1_91-devel
libqt5-qtbase-devel(x86-64)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
spglib-devel(x86-64)
which as you can clearly see mentions both libavogadro1_91 and its -devel package.

Thanks for your time and help,
Brenton