Results 1 to 5 of 5

Thread: Leap15 + stellarium = Oops... Insufficient OpenGL version. Please update drivers, or graphics hardwa

  1. #1

    Default Leap15 + stellarium = Oops... Insufficient OpenGL version. Please update drivers, or graphics hardwa

    Leap15.0
    add stelalrium.
    Launch and have error:
    Code:
    kkk@kkph:~> cat /home/kkk/.stellarium/log.txt
    2018-08-11T18:41:17
    Linux version 4.12.14-lp150.12.13-default (geeko@buildhost) (gcc version 7.3.1 20180323 [gcc-7-branch revision 258812] (SUSE Linux) ) #1 SMP Wed Aug 8 19:31:27 UTC 2018 (942604c)
    Compiled using GCC 7.3.1
    Qt runtime version: 5.9.4
    Qt compilation version: 5.9.4
    Addressing mode: 64-bit
    MemTotal:        3059032 kB
    MemFree:          115696 kB
    MemAvailable:    1014700 kB
    SwapTotal:      14683132 kB
    model name    : Intel(R) Core(TM)2 CPU         T7400  @ 2.16GHz
    cpu MHz        : 2167.000
    model name    : Intel(R) Core(TM)2 CPU         T7400  @ 2.16GHz
    cpu MHz        : 2167.000
    stellarium -d 
     -------------------------------------------------------
    [ This is Stellarium 0.16.1 - http://www.stellarium.org ]
    [ Copyright (C) 2000-2017 Fabien Chereau et al.         ]
     -------------------------------------------------------
    Writing log file to: "/home/kkk/.stellarium/log.txt"
    File search paths:
      0 .  "/home/kkk/.stellarium"
      1 .  "/usr/share/stellarium"
    Config file is:  "/home/kkk/.stellarium/config.ini"
    Default surface format:  QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize -1, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize -1, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
    Desired surface format:  QSurfaceFormat(version 2.1, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
    StelGLWidget constructor
    StelGraphicsScene constructor
    initializeGL
    OpenGL supported version:  "1.4 Mesa 18.0.2"
    Current Format:  QSurfaceFormat(version 1.4, options QFlags<QSurfaceFormat::FormatOption>(DeprecatedFunctions), depthBufferSize 24, redBufferSize 8, greenBufferSize 8, blueBufferSize 8, alphaBufferSize 8, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::SwapBehavior(DefaultSwapBehavior), swapInterval 1, profile  QSurfaceFormat::OpenGLContextProfile(NoProfile))
    StelMainView::init
    Detected: OpenGL "1.4"
    Driver version string: "1.4 Mesa 18.0.2"
    GL vendor is "Intel Open Source Technology Center"
    GL renderer is "Mesa DRI Intel(R) 945GM "
    Oops... Insufficient OpenGL version. Please update drivers, or graphics hardware.
    kkk@kkph:~>
    Please, help me

    Serg

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,639
    Blog Entries
    3

    Default Re: Leap15 + stellarium = Oops... Insufficient OpenGL version. Please update drivers, or graphics ha

    Stellarium is starting up just fine here. This is with Intel graphics.

    It probably doesn't like your graphics card. And you have not indicated what that is.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Leap15 + stellarium = Oops... Insufficient OpenGL version. Please update drivers, or graphics ha

    Quote Originally Posted by nrickert View Post
    Stellarium is starting up just fine here. This is with Intel graphics.

    It probably doesn't like your graphics card. And you have not indicated what that is.
    My graphics card is:
    "
    Code:
    /sbin/lspci -nnk |grep -A3 VGA
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
        Subsystem: Hewlett-Packard Company Device [103c:30a2]
        Kernel driver in use: i915
        Kernel modules: i915
    "

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,639
    Blog Entries
    3

    Default Re: Leap15 + stellarium = Oops... Insufficient OpenGL version. Please update drivers, or graphics ha

    I tried running Stellarium on an older computer, also with Intel graphics. I got a warning that OpenGL has problems. But I was able to ignore those and it started. I have not tried seriously using it to see how broken the graphics are.

    I think your computer is even older.

    You could maybe try, at a terminal command line:

    Code:
    LIBGL_ALWAYS_SOFTWARE=1 stellarium
    That is supposed to force software emulation of OpenGL, which might work better. But you would be starting that software emulation after X11 is up and running, so it might not completely solve the problem.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: Leap15 + stellarium = Oops... Insufficient OpenGL version. Please update drivers, or graphics ha

    Thank you !!
    Guru !!!!!


    Serg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •