Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Black screen after choosing to boot in GRUB

  1. #11

    Default Re: Black screen after choosing to boot in GRUB

    I've tested the kernel in Kernel:/openSUSE-15.0:/Submit/ and it does not work too, like 12.13.1 and 12.10.1.
    I am using nvidia proprietary drivers :-/

  2. #12
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,490
    Blog Entries
    3

    Default Re: Black screen after choosing to boot in GRUB

    Quote Originally Posted by marcelovborro View Post
    I've tested the kernel in Kernel:/openSUSE-15.0:/Submit/ and it does not work too, like 12.13.1 and 12.10.1.
    I am using nvidia proprietary drivers :-/
    It looks as if there might be a separate issue involving nvidia drivers. Maybe start a new bug report (or check if one has already been started).

    The 12.13.1 kernel is working fine for me on the system where I originally ran into the kernel problem. But that's not nvidia.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #13

    Default Re: Black screen after choosing to boot in GRUB

    Quote Originally Posted by nrickert View Post
    It looks as if there might be a separate issue involving nvidia drivers. Maybe start a new bug report (or check if one has already been started).

    The 12.13.1 kernel is working fine for me on the system where I originally ran into the kernel problem. But that's not nvidia.
    I've just opened a new bug about this problem with nvidia proprietary drivers: https://bugzilla.opensuse.org/show_bug.cgi?id=1104512

  4. #14

    Default Re: Black screen after choosing to boot in GRUB

    Ok, thank you for your answers.
    I've post a message too quickly as there was already a message with this kind of bug.

    Now, I can install the new kernel. But I added nvidia repository and without selecting any package from it, YAST forces me to install nvidia-gfxG04-kmp-default.
    So is it a good idea to switch to nvidia driver with a kernel update while being with a XFCE session?

    Thanks

  5. #15
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,637

    Default Re: Black screen after choosing to boot in GRUB

    .12.13 fixed my NVIDIA GT218 [GeForce 210].
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  6. #16
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Black screen after choosing to boot in GRUB

    Quote Originally Posted by jnowe View Post
    Now, I can install the new kernel. But I added nvidia repository and without selecting any package from it, YAST forces me to install nvidia-gfxG04-kmp-default.
    So is it a good idea to switch to nvidia driver with a kernel update while being with a XFCE session?
    YaST doesn't "force" anybody: you can always change the proposal, for instance "taboo" the package you don't want installed.
    Maybe you can update everything in one step, but to be sure I would do the following:
    - "taboo" nvidia-gfxG04-kmp-default (or temporary disable the whole Nvidia repo)
    - update the kernel (and anything else that might be suggested)
    - reboot
    - re-enable the Nvidia repo or cancel the "taboo" from nvidia-gfxG04-kmp-default
    - logout from the graphics session and login to a console (ALT+CTRL+F1)
    - once logged on to the console, issue the following:
    Code:
    zypper ref
    zypper install nvidia-gfxG04-kmp-default
    That way you avoid troubles should the X-server crash during install of the new graphics driver.
    A final reboot and you should be good to go...
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  7. #17

    Default Re: Black screen after choosing to boot in GRUB

    Everything works fine, even with the nvidia driver.

    Thanks a lot

  8. #18

    Default Re: Black screen after choosing to boot in GRUB

    Quote Originally Posted by marcelovborro View Post
    I've just opened a new bug about this problem with nvidia proprietary drivers: https://bugzilla.opensuse.org/show_bug.cgi?id=1104512
    I've fixed my system after I reinstalled nvidia-gfxG03-kmp-default to make the post install scripts run again. Then I was able to boot with the kernel-default-4.12.14-lp150.12.13.1.x86_64 :-)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •