Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

  1. #1

    Question KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Hi,

    I recently installed openSUSE Leap 15 (KDE Plasma: 5.12.5, Frameworks: 5.45, Qt version: 5.9.4, OS: 64 bit, Kernel: 4.12.14-lp150.12.7-default) on my desktop. It takes very long time (more than 2 minutes) to logout and get to the SDDM login screen. The startup time is good (~30 seconds). I have openSUSE 43.3 (KDE Plasma: 5.12.4, Frameworks: 5.45, Qt version: 5.10) installed in a laptop and I don't experience such long logout times with my login screen as SDDM. Any help in troubleshooting this problem is very much appreciated. Thanks.
    OpenSUSE Leap 42.3, KDE Plasma: 5.12.3, KDE Frameworks: 5.44.0, Qt Version: 5.10.0, Kernel Version: 4.4.114-42-default.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,506
    Blog Entries
    3

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    I'm not experiencing that problem here.

    However, there are two options for login to Plasma. You can login with X11, or you can login with Wayland. You have not indicated which of those you are using.

    I mostly use X11, because Plasma-wayland doesn't seem quite ready for use. However, when I have tried Wayland, the logout time is noticeably longer.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,806
    Blog Entries
    14

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Quote Originally Posted by nrickert View Post
    I'm not experiencing that problem here.

    I mostly use X11, because Plasma-wayland doesn't seem quite ready for use. However, when I have tried Wayland, the logout time is noticeably longer.
    Same story here.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    You can login with X11, or you can login with Wayland. You have not indicated which of those you are using
    I am using X11 and I used IceWM too, no difference. The login time with X11 and IceWM is fast (~25 s), it is the logout time that is too long. Here is my desktop specifications: Dell Optiplex 7060 with an i7-8700 4.6GHz, 16GB 2666MHz DDR4, M.2 256GB SSD, 1TB HD, Nvidia GeForce GTX 1050 2GB. The 256 SSD is for windows virtual environment. The linux system is in 1TD HDD. I have dual monitors and the graphics card is nouveau (I had trouble installing NVIDIA card and I gave up.).

    Is there a way to figure out what is causing this long logout times ? Thanks.
    OpenSUSE Leap 42.3, KDE Plasma: 5.12.3, KDE Frameworks: 5.44.0, Qt Version: 5.10.0, Kernel Version: 4.4.114-42-default.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,506
    Blog Entries
    3

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Here's an experiment for you to try.

    While booting, hit 'e' on the grub menu. That should put you in an edit window.

    Scroll down until you find a line beginning with "linux" (or it might be "linuxefi")

    Scroll to the right on that line. And append " plymouth.enable=0" to the end of the line.
    Hit CTRL-X to resume booting.

    This disable plymouth. So your boot up might see lots of on-screen message. Ignore those for now. The idea is to see the effect on shutdown. My experience is that, without plymouth, shutdown is faster.

    It might not work out that way for you. But watch the screen during shutdown. Maybe you will notice something that is taking a lot of time.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,706

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Note if you use a database or other programs that may require cleanup or special shutdown routines it can take a bit to shut it down but you should see this in the shutdown screen minus plymouth

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,293
    Blog Entries
    1

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Observe the behaviour if you terminate the user session with
    Code:
    loginctl terminate-user <username>
    Does that get you back to a login screen faster? (Note that will also kill all applications running in your desktop session.)
    openSUSE Leap 15.0; KDE Plasma 5

  8. #8

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Quote Originally Posted by deano_ferrari View Post
    Observe the behaviour if you terminate the user session with
    Code:
    loginctl terminate-user <username>
    Does that get you back to a login screen faster? (Note that will also kill all applications running in your desktop session.)
    No, the login screen still takes a while to appear, however I think I may found the reason.....

    While booting, hit 'e' on the grub menu. That should put you in an edit window.

    Scroll down until you find a line beginning with "linux" (or it might be "linuxefi")

    Scroll to the right on that line. And append " plymouth.enable=0" to the end of the line.
    Hit CTRL-X to resume booting.

    This disable plymouth. So your boot up might see lots of on-screen message. Ignore those for now. The idea is to see the effect on shutdown. My experience is that, without plymouth, shutdown is faster.

    It might not work out that way for you. But watch the screen during shutdown. Maybe you will notice something that is taking a lot of time.
    Thanks for the tip ! When I logout and see the on-screen messages, it takes a long time at [OK] started locale service. I looked in opensuse forums and I came across this thread
    https://forums.opensuse.org/showthre...locale-service
    The problem posted in the above thread is different from mine, the user has problems booting while being stuck in [OK] started locale service . Whereas for me, after I press logout, the on-screen message gets stuck at [OK] started locale service but eventually (after 2 min or so) I get the login screen again. I did update my desktop system 4 days back.
    OpenSUSE Leap 42.3, KDE Plasma: 5.12.3, KDE Frameworks: 5.44.0, Qt Version: 5.10.0, Kernel Version: 4.4.114-42-default.

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,149
    Blog Entries
    2

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    You might try displaying your syslog while you're logging out... If it's taking over 2 minutes, I doubt that running a window displaying your syslog events in real time would affect your logout much...

    Recommend...
    Before you logout, open a console and run the following command to read your syslog in real time
    Code:
    journalctl -f
    While the window is open, try to logout.
    Note what displays in the window, if there are long pauses and what comes immediately before and after any pauses.

    Am speculating that there is something running on your machine that is preventing your system from logging out, if it can be identified then you might manually terminate it before logging out.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #10

    Default Re: KDE Plasma 5.12.5 :Very long time (> 2 min) to logout

    Quote Originally Posted by tsu2 View Post
    You might try displaying your syslog while you're logging out... If it's taking over 2 minutes, I doubt that running a window displaying your syslog events in real time would affect your logout much...

    Recommend...
    Before you logout, open a console and run the following command to read your syslog in real time
    Code:
    journalctl -f
    While the window is open, try to logout.
    Note what displays in the window, if there are long pauses and what comes immediately before and after any pauses.

    Am speculating that there is something running on your machine that is preventing your system from logging out, if it can be identified then you might manually terminate it before logging out.

    TSU
    I did what you suggested. When I press logout, the window goes blank and stays blank for a while. I have uploaded a video (https://youtu.be/T2gH39fn--g) to show what is going on. Please have a look.
    OpenSUSE Leap 42.3, KDE Plasma: 5.12.3, KDE Frameworks: 5.44.0, Qt Version: 5.10.0, Kernel Version: 4.4.114-42-default.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •