Results 1 to 7 of 7

Thread: Boot freeze

  1. #1

    Default Boot freeze

    Hi all

    I installed a new Leap 15 on my PC. This worked only after switching off UEFI in the BIOS. Three attempts with UEFI failed.
    After that I could install quite normal and it run exactly one time. It made updates and after reboot it freeze every time with the last message

    'started locale service'

    So I can't login any more

    The PC is a Asus B85-Plus board with Intel i5-4440@3,1 GHz CPU and a NVIDIA GF119 (GeForce GT610) graphic device.

    I could save several log files of this event with an older Suse version if necessary.

    Is there any idea what is the problem?

    Thank you in advance
    Joerg

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Boot freeze

    If it happened today maybe you were affected by this bug https://bugzilla.opensuse.org/show_bug.cgi?id=1104121
    If that is the case, try booting an older kernel until the problem is solved by a new update.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    90

    Default Re: Boot freeze

    All my laptops with NVidia chips failed with 4.12.14-lp150.12.10 that worked fine with earlier kernels- it appears that they added nouveau support into the kernel this is not compatible with my chipset and probably yours too. No laptop with only Intel graphics had a problem.

    I added the nouveau.modest=0 on my linux line in front of the splash= and that fixed the problem - your line might be different than mine as /dev/sda2 is my swap file and I want to see what loads so I changed the silent to verbose.

    I fixed this in /etc/default/grub

    GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda2 nouveau.modest=0 splash=verbose showopts"

    and ran this as root to fix the problem

    grub2-mkconfig -o /boot/grub2/grub.cfg

  4. #4

    Default Re: Boot freeze

    Thank you for the advice.
    I modified as suggested but nothing changed. It still freeze at the same point.

    But the kernel 4.12.14-lp150.11 still works.

  5. #5

    Default Re: Boot freeze

    with the latest update the new kernel works too

    Thank you for your help

  6. #6
    Join Date
    Nov 2008
    Location
    Northern VA
    Posts
    301

    Default Re: Boot freeze

    Tried the nouveau.modst-0 at the install. Declined to accept the license for the nouveau drive.
    Install seemed to proceed; logged in; used YaST2 to install some additional s/w.
    When the screen saver turned off the screen, it couldn't come back on with keyboard input or mouse movement.
    On a previous install (maybe #6 of 15), declining the nouveau license still resulted in it being installed.
    I knew when I bought this computer (HP Omen) that the nvidia chip would be a pain, but this is excruciating.
    Any more suggestions?
    Leap/KDE and a film-based photographer

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,645

    Default Re: Boot freeze

    1-Install using the detailed package selection option and taboo xf86-video-nouveau. Depending on which NVidia chip you actually have, the default Xorg driver might well work better anyway. There is nothing you can do about the nouveau support built into the kernel.

    2-Append plymouth.enable=0 to the installation kernel cmdline.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •