Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: [amdgpupro] no login screen

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,264
    Blog Entries
    1

    Default Re: [amdgpupro] no login screen

    Quote Originally Posted by soundlord View Post
    The 15.302 from amd won't install because X version is greater than 1.10 :{
    And I don't feel like downgrade X, I feel I gonna mess it up (even if I could rollback to a working snapshot)
    You're referring to the amdgpu-pro (closed-source) driver that sits on top of the amdgpu (open-source) driver. If I understood correctly, Malcolm's previous post in this thread suggested that the amdgpu driver has support for the AMD chipset you have, but not the closed-source component.
    Last edited by deano_ferrari; 18-Aug-2018 at 20:29.
    openSUSE Leap 15.0; KDE Plasma 5

  2. #12
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,650
    Blog Entries
    15

    Default Re: [amdgpupro] no login screen

    Quote Originally Posted by deano_ferrari View Post
    You're referring to the amdgpu-pro (closed-source) driver that sits on top of the amdgpu (open-source) driver. If I understood correctly, Malcolm's previous post in this thread suggested that the amdgpu driver has support for the AMD chipset you have, but not the closed-source component.
    Hi
    Correct, amdgpu oss driver and also ensure xf86-video-amdgpu is installed. AFAIK the proprietary driver won't work as it's not in the list of supported cards.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #13
    Join Date
    May 2009
    Location
    Liège Walifornia
    Posts
    386

    Default Re: [amdgpupro] no login screen

    Yep patience is a vertue, I just rumble as I worked on opengl "450 core" applications that won't work anymore, the shaders and fragments must be set to 320 es. That details but it sucks :{

    Anyway, I got this as result:

    Code:
    sirius:/netbeans/og_tutoriel3/shaders # rpm -q -a --last | grep radeon
    radeontop-lang-1.1-lp150.1.2.noarch           Sun Aug 19 03:51:41 2018
    radeontop-1.1-lp150.1.2.x86_64                Sun Aug 19 03:51:40 2018
    libvulkan_radeon-18.0.2-lp150.17.2.x86_64     Tue Jul 24 12:41:40 2018
    libvdpau_radeonsi-18.0.2-lp150.17.2.x86_64    Tue Jul 24 12:41:40 2018
    libdrm_radeon1-2.4.91-lp150.1.2.x86_64        Tue Jul 24 12:41:00 2018
    ...and...

    Code:
    sirius:/netbeans/og_tutoriel3/shaders # rpm -q -a --last | grep amdgpu
    xf86-video-amdgpu-18.0.1-lp150.1.1.x86_64     Tue Jul 24 12:45:26 2018
    libdrm_amdgpu1-2.4.91-lp150.1.2.x86_64        Tue Jul 24 12:41:00 2018
    Do I blacklist radeon driver or keep the "working" settings as is ?

  4. #14
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,650
    Blog Entries
    15

    Default Re: [amdgpupro] no login screen

    Quote Originally Posted by soundlord View Post
    Yep patience is a vertue, I just rumble as I worked on opengl "450 core" applications that won't work anymore, the shaders and fragments must be set to 320 es. That details but it sucks :{

    Anyway, I got this as result:

    Code:
    sirius:/netbeans/og_tutoriel3/shaders # rpm -q -a --last | grep radeon
    radeontop-lang-1.1-lp150.1.2.noarch           Sun Aug 19 03:51:41 2018
    radeontop-1.1-lp150.1.2.x86_64                Sun Aug 19 03:51:40 2018
    libvulkan_radeon-18.0.2-lp150.17.2.x86_64     Tue Jul 24 12:41:40 2018
    libvdpau_radeonsi-18.0.2-lp150.17.2.x86_64    Tue Jul 24 12:41:40 2018
    libdrm_radeon1-2.4.91-lp150.1.2.x86_64        Tue Jul 24 12:41:00 2018
    ...and...

    Code:
    sirius:/netbeans/og_tutoriel3/shaders # rpm -q -a --last | grep amdgpu
    xf86-video-amdgpu-18.0.1-lp150.1.1.x86_64     Tue Jul 24 12:45:26 2018
    libdrm_amdgpu1-2.4.91-lp150.1.2.x86_64        Tue Jul 24 12:41:00 2018
    Do I blacklist radeon driver or keep the "working" settings as is ?
    Hi
    Yes, as root user create a /etc/modprobe.d/50-radeon.conf
    Code:
    blacklist radeon
    Run mkinitrd and reboot, then check the lspci output again.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •