Results 1 to 3 of 3

Thread: Bluez cause high CPU

  1. #1
    Join Date
    Jul 2008
    Location
    Narvik, Norway
    Posts
    393

    Default Bluez cause high CPU

    I had some problem with systemd-udevd using 50% CPU. After some investigation i find out that this is caused by Bluez Bluetooth Stack. I uninstall Bluez and then systemd-udevd disapeare and CPU-usage is back as normal. This problem is reported to be a problem on mostly Dell-computers.
    My problem is when i upgrade system with zypper dup, then Bluez is automatic installed again.

    Is there a way of replacing BT Stack with something else than Bluez?
    --
    Best regards,
    Ronny Simonsen
    Narvik - Norway

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Bluez cause high CPU

    Pretty sure Bluez is it. Don't recall any other Bluetooth programs. As to stopping the reinstall just blacklist the rpm. easiest to do in Yast-software Management

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,643
    Blog Entries
    3

    Default Re: Bluez cause high CPU

    This problem has been reported as Bug 1092246.

    In my case, I disabled bluetooth in the BIOS to solve the problem. As gogalthorp has suggested, you can uninstall bluez, and then taboo it (blacklist, lock whatever) so that it is never reinstalled. Just search for it in Yast software management, and right-click on that line. You should get a menu which allows you to blacklist that package.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •