Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: DEFAULT_WM="xfce" yet still KDE Plasma loads?

  1. #1

    Question DEFAULT_WM="xfce" yet still KDE Plasma loads?

    I have updated one computer from Leap 42.3 to Leap 15.0
    While on 42.3 it always had auto login for XFCE and it workes fine.

    However after updating it attempts to boot into KDE Plasma and hangs at that. The only way out is hardware reset. Or to avoid reaching the point when that is needed, while KDE Plasma tries to load I press Alt+Ctrl+F1 and after some waiting back Alt+F7 - then a login prompt is displayed but strangely, still Plasma is selected in the dropdown.

    Regardless of how many times I login/logout explicitly selecting XFCE and reboot - nothing changes.

    I have:

    Code:
    $ grep 'DISPLAYMANAGER=' /etc/sysconfig/displaymanager
    DISPLAYMANAGER="lightdm"
    $ grep 'DEFAULT_WM=' /etc/sysconfig/windowmanager
    DEFAULT_WM="xfce"
    $ cat ~/.dmrc 
    [Desktop]
    Session=xfce
    *FWIW: using nouveau

    What might the be causing all this?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,823
    Blog Entries
    1

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    1. Disable auto-login (Can be set in YaST > /etc/sysconfig editor > Desktop > Display manager > DISPLAYMANAGER_AUTOLOGIN
    2. On the login screen where you enter username/password, you can select your Desktop there. I haven't found any other way to select the Desktop reliably.

    You can view and change your Window Manager with the following, but what results depends heavily on whether your Window Manager is supported by your chosen Display Manager
    Code:
    update-alternatives --config default-xsession.desktop
    Done properly,
    You shouldn't need to back screen or other unusual actions... Everything should move to the next screen naturally.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Quote Originally Posted by tsu2 View Post
    1. Disable auto-login (Can be set in YaST > /etc/sysconfig editor > Desktop > Display manager > DISPLAYMANAGER_AUTOLOGIN
    2. On the login screen where you enter username/password, you can select your Desktop there. I haven't found any other way to select the Desktop reliably.
    The people who use that computer want the conveniece of having auto login, so telling them they can't have it because the software is unreliable sounds bad. I am looking for way to give them what they want (which is what they had for years).

    You shouldn't need to back screen or other unusual actions... Everything should move to the next screen naturally.
    What are you talking about?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Quote Originally Posted by heyjoe View Post
    The people who use that computer want the conveniece of having auto login, so telling them they can't have it because the software is unreliable sounds bad. I am looking for way to give them what they want (which is what they had for years).


    What are you talking about?
    Two options:
    - Make these persons aware that auto_login is a major security issue.
    - Do what Tsu wrote, login on Xfce once, use YaST - System - sysconfigeditor to search for autologin and set it by putting in the username. The session will be remembered, so the next autologin should be in Xfce
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Quote Originally Posted by Knurpht View Post
    Two options:
    - Make these persons aware that auto_login is a major security issue.
    I have done that but they still prefer the convenience. Plus that's their home computer, not a publicly accessible machine.

    - Do what Tsu wrote, login on Xfce once, use YaST - System - sysconfigeditor to search for autologin and set it by putting in the username. The session will be remembered, so the next autologin should be in Xfce
    Please let me check if I understand correctly:

    Before opening this thread I have already visited sysconfigeditor in Yast and the username was there, so no change was required as everything was already set (as it has always been). Are you suggesting that removing the username, then putting it again and confirming would "remember" something more than what is already set in sysconfig? If yes - where exactly is that remembered? Is it not DEFAULT_WM setting which is used to "remember" that? (please consider the info in the OP)

    Also - how does all this explain the hanging which I described?

    This is all quite confusing, I hope you can clarify.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,823
    Blog Entries
    1

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Disable autologin.
    Set your Desktop and your desired Window Manager (depends on whatever is offered)
    Then disable autoloin.

    You'll be back to an automatic login with the settings you want.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Quote Originally Posted by tsu2 View Post
    Disable autologin.
    Set your Desktop and your desired Window Manager (depends on whatever is offered)
    Then disable autoloin.
    I suppose you mean "then enable"?

    You'll be back to an automatic login with the settings you want.
    I will try this tomorrow when I visit that PC. Meanwhile - could you please tell where these settings are saved? Is it not ~/.dmrc which remembers that and which I already have?

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,185
    Blog Entries
    3

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Quote Originally Posted by heyjoe View Post
    Code:
    $ grep 'DISPLAYMANAGER=' /etc/sysconfig/displaymanager
    DISPLAYMANAGER="lightdm"
    $ grep 'DEFAULT_WM=' /etc/sysconfig/windowmanager
    DEFAULT_WM="xfce"
    $ cat ~/.dmrc 
    [Desktop]
    Session=xfce
    Your basic problem is that "/etc/sysconfig/displaymanager" is not being used the way it was used in 42.3

    Login to whatever desktop you get.
    Open a terminal ("konsole" or "xterm") and "su" to become root. Or open a root terminal from the menu, which I think gives you "konsole".
    Code:
    update-alternatives --config default-displaymanager
    and select "lightdm" as your choice.

    Optionally,
    Code:
    update-alternatives --config default-xsession.desktop
    and set that to XFCE (maybe it says "xfce" or "xfce-session" or similar). But you are given a list of choices.

    I say "optional" because it doesn't actually matter.

    When you have made those choices, reboot.

    If you finish up in the wrong desktop environment, then logout. You should get a login screen. From there, you can select your desktop and login. For "lightdm" the desktop selector is an icon near the top right of the screen. You may have to experiment with clicking on icons to see which gives you a desktop choice.

    Once you have logged in to your desired desktop, "lightdm" should remember your selection and use that the next time.
    openSUSE Leap 15.1; KDE Plasma 5;

  9. #9

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    The update-alternatives way worked. Thanks!


    Quote Originally Posted by nrickert View Post
    Your basic problem is that "/etc/sysconfig/displaymanager" is not being used the way it was used in 42.3
    Why is that?
    Where are the settings stored in Leap 15.0?

    Also - why auto login to KDE Plasma results in hanging of the computer during this auto login but manually logging into Plasma works?

  10. #10
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: DEFAULT_WM="xfce" yet still KDE Plasma loads?

    Quote Originally Posted by heyjoe View Post
    The update-alternatives way worked. Thanks!



    Why is that?
    Where are the settings stored in Leap 15.0?

    Also - why auto login to KDE Plasma results in hanging of the computer during this auto login but manually logging into Plasma works?
    As Neil said, it has moved up to update-alternatives.

    Now in /etc/alternatives/default-displaymanager which is a symlink to the file in /usr/lib/X11/displaymanagers/
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •