Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Support for older gcc versions

  1. #21

    Default Re: Support for older gcc versions

    Quote Originally Posted by I_A View Post
    currently only gcc7.3 and gcc8.1 are available for LEAP 15.0
    http://download.opensuse.org/reposit...USE_Leap_15.0/
    while 3.3 4.8 7.3 and 8.1 are available for 42.3
    http://download.opensuse.org/reposit...USE_Leap_42.3/
    you could open a bug report and ask for those older compilers be made available for 15.0
    https://bugzilla.opensuse.org/
    or build them manually
    you can switch between gcc compilers using update-alternatives
    I see only gcc7.3, but not gcc8.1 in Leap 15.0. Perhaps gcc8.1 is available in some other repository other than the default ones which come with Leap 15.0

  2. #22

    Default Re: Support for older gcc versions

    Quote Originally Posted by dcurtisfra View Post
    Yes!
    And, therefore, my suggestion is, that, you should attempt to have more than a few, physical, platforms running with the last available patches/updates of «older» operating systems with the (from then) supported GCC versions -- for testing purposes -- forget about the security implications -- you're maintaining a test environment/laboratory -- which should be isolated from the rest of the world anyway …
    • Putting my ISTQB certified Tester hat on: AFAICS it's not a good idea to attempt to run a test environment which «needs» older GCC versions on «newer» platforms which do not support the «older» compiler versions …
    I do have more than one Linux distro by which I can test older gcc versions. But it is certainly not an advertisement for OS Leap 15.0 if I need to boot another Linux version in order to test gcc older than version 7.3.

    I did, nonetheless, manage to successfully install in Leap 15.0 gcc-4.8, gcc-5.3, and gcc-6.2 from the latest packages for those versions on OS Leap 42.3, which I was able to download from https://pkgs.org/ . None of these packages impact the default version of gcc-7.3 which comes with OS Leap 15.0 in any way. Although it was a bit of work install these packages, with their C++ versions as well as their dependencies, I was able to do it with the help of the very good Yast Install Software application and the available packages in the aforesaid website.

    I am not saying that some Leap 15.0 repository should have at least included these packages, with their dependencies, from Leap 42.3 as an optional package choice for those who might want earler gcc releases to be installed. But I am glad I was able to install them in Leap 15.0 and that I can successfully test with them.

  3. #23
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Default Re: Support for older gcc versions

    Quote Originally Posted by eldiener View Post
    I am not saying that some Leap 15.0 repository should have at least included these packages, with their dependencies, from Leap 42.3 as an optional package choice for those who might want earler gcc releases to be installed. But I am glad I was able to install them in Leap 15.0 and that I can successfully test with them.
    I admit that, having "valid hardware per GCC release" is a luxury these days -- previously, there were employers who could afford such testing environments …

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •